Posts by illyaine

    Hallo,


    ja, benutze schon ne Zeit lang das WBB und co :D


    Ja, ist in meinem Fall nur nervig, weiß ja jetzt nicht welche Einträge alles betroffen sind. Müsste dann mal diese löschen und neu erstellen. Außer WoltLab hat noch eine Idee dafür :)

    Kann es sein, dass durch das deaktivieren der "Mehrsprachigkeit" in der Filebase die Einträge nicht mehr richtig behandelt werden?
    Habe jetzt bei einem Eintrag eine neue Version hinzugefügt. Und, diese wird auch angezeigt, aber ändere ich den Haupteintrag (also Titel usw) wird es zwar geändert und übernommen, aber im Eintrag nicht angezeigt und entsprechend auch kein Update im Supportthema erstellt.


    Da natürlich der Eintrag ja mehrsprachig angelegt wurde, Sprache kann auch geändert werden, aber man kann nur noch Deutsch ändern, Englisch ist somit nicht mehr bearbeitbar.


    Edit: Da fällt mir ein, wie ich den Eintrag bearbeitet hatte, da war entsprechend Titel, Beschreibung usw. leer. Habe ich dann hinzugefügt.

    Ja zwei Sprachen sind installiert. Aber das Forum selber wird nicht zweisprachig genutzt. Die zweite Sprache ist selber nur für die englisch sprachigen das die Oberfläche auf englisch ist.


    Ist in dem Fall eher unglücklich gelöst. Da dies auch erst seit kurzen aufgetaucht ist.


    Die Filebase selber wird auch nur einsprachig benutzt, muss mal schauen ob ich die Mehrsprachigkeit dort ausschalten kann

    Version: 5.3.6


    Hatte jetzt den zweiten Fall, dass sich das Support Thema doppelt in dem vordefinierten Forum erstellt hat.

    Aktiviert ist die Option "Einheitliches Forum für alle Kategorien verwenden".


    Der Support Thema im Filebase Eintrag leitet zum Thema 1 von 2.


    Ist hier schon etwas bekannt über dieses Verhalten? Danke schon mal im Voraus.

    Requested URL
    /
    Referrer
    https://www.trlevel.de/forum/index.php?board/10-tomb-editor-levelbau/
    Error Message
    Trying to get property 'className' of non-object
    Type
    wcf\system\exception\ErrorException
    File (Line)
    /www/htdocs/ORDNER/lib/system/WCF.class.php (341)
    Stacktrace
    1. /www/htdocs/ORDNER/lib/data/user/activity/event/ViewableUserActivityEventList.class.php (67): wcf\system\WCF::handleError(…)
    2. /www/htdocs/ORDNER/lib/system/box/AbstractDatabaseObjectListBoxController.class.php (352): wcf\data\user\activity\event\ViewableUserActivityEventList->readObjects(…)
    3. /www/htdocs/ORDNER/lib/system/box/RecentActivityListBoxController.class.php (164): wcf\system\box\AbstractDatabaseObjectListBoxController->readObjects(…)
    4. /www/htdocs/ORDNER/lib/system/box/AbstractDatabaseObjectListBoxController.class.php (326): wcf\system\box\RecentActivityListBoxController->readObjects(…)
    5. /www/htdocs/ORDNER/lib/system/box/AbstractDatabaseObjectListBoxController.class.php (293): wcf\system\box\AbstractDatabaseObjectListBoxController->loadContent(…)
    6. /www/htdocs/ORDNER/lib/system/box/RecentActivityListBoxController.class.php (131): wcf\system\box\AbstractDatabaseObjectListBoxController->hasContent(…)
    7. /www/htdocs/ORDNER/lib/data/box/Box.class.php (291): wcf\system\box\RecentActivityListBoxController->hasContent(…)
    8. /www/htdocs/ORDNER/lib/data/box/Box.class.php (276): wcf\data\box\Box->hasContent(…)
    9. /www/htdocs/ORDNER/templates/compiled/0_wcf_1_cms.php (1895): wcf\data\box\Box->render(…)
    10. /www/htdocs/ORDNER/lib/system/template/TemplateEngine.class.php (334): include(…)
    11. /www/htdocs/ORDNER/lib/page/AbstractPage.class.php (323): wcf\system\template\TemplateEngine->display(…)
    12. /www/htdocs/ORDNER/lib/page/AbstractPage.class.php (114): wcf\page\AbstractPage->show(…)
    13. /www/htdocs/ORDNER/lib/system/request/Request.class.php (83): wcf\page\AbstractPage->__run(…)
    14. /www/htdocs/ORDNER/lib/system/request/RequestHandler.class.php (107): wcf\system\request\Request->execute(…)
    15. /www/htdocs/ORDNER/index.php (9): wcf\system\request\RequestHandler->handle(…)


    Diese Meldung kam gerade, ist aber durchs löschen des Cachs auch wieder verschwunden. Ist wie ich der Fehlermeldung entnehmen kann auch kein Problem eines Plugins, sondern vom WCF selber -> RecentActivity etc.


    Evtl. steht für WoltLab etwas wichtiges mit in der Fehlermeldung, weshalb dies auftritt, damit man das ggf fixen kann.


    Edit: Irgend was ist gerade im Busch bei mir. Jetzt hagelt es laufen weiter Fehlermeldungen, auch zu der WL Filebase usw (

    Use of undefined constant FILEBASE_ENABLE_SELLING - assumed 'FILEBASE_ENABLE_SELLING' (this will throw an Error in a future version of PHP)), aber auch da konnte man was dagegen tun, durch das löschen der "options.inc.php" Datei.

    Ich würde mir für die "Labels" Funktion wünschen, dass man für "Apps" alle Kategorien "abhaken" kann, und natürlich nur für App XY, nicht für alles.
    In meiner Filebase/Lexikon nutze ich immer die selben Labels und wenn dann eine neue Kategorie hinzukommt (kommt bei mir im Lexikon öfters vor, da dies eine Tutorial Datenbank ist). Ist es natürlich etwas Mühselig zu suchen wo noch nichts abgehakt wurde.

    Labelgruppen Verfügbarkeit - Apps farblich trennen


    Zu dem Vorschlag im verlinkten Thema, hätte ich noch etwas anzumerken.
    Wenn die Liste der Kategorien für die Labelgruppe natürlich länger ist, da sieht man natürlich schlecht, welche Kategorien man noch nicht abgehakt hat. Daher würde ich mir wünschen das man die "aktivierten" auch etwas hervorhebt, damit man besser sieht, welche noch nicht aktiviert wurden (absichtlich die aktivierten, da dies logischer wäre, als die nicht aktivierten).

    Es wäre schön wenn die Labelgruppen bzw. die Apps darinnen, etwas besser getrennt wären. Aktuell ist die "App" mit einem blauen Unterstrich sichtbar.

    Es wäre aber hier besser, wenn das ganze farblich etwas abgetrennt wäre.


    So wie es damals im WBB3.1 der Fall war, dort war "DIV 1 - Farbe 1" und "DIV 2 - Farbe 2", also einen ticken dunkler, damit man gleich gesehen hat, jetzt kommt etwas neues.


    Ich selber habe neben "Artikel" nur das Forum, Lexikon und Filebase installiert. Aber entsprechend viele Kategorien/Foren dafür. Die Übersicht lässt so leider zu wünschen übrig.

    Den man sieht nicht direkt auf den ersten Blick was wo dazu gehört.

    Dürfte aber auch kein Thema sein, das mittels Plugin zu lösen...


    Man kann vieles durch Plugins lösen. Aber ich finde es inzwischen auch schöner wenn manche Sachen lieber bei der Hauptsoftware dabei ist. Da ich bei mir auf meiner Seite inzwischen so wenig wie möglich installiere.


    WoltNet, ja wäre dann gut wenn es dies überall gibt. Den bei dem ein oder anderen gibt es dies ja schon, müsste daher nicht neu erfunden werden.

    Mir kam gerade so die Idee, dass eine Funktion ganz praktisch wäre, dass man auswählen könnte (Datum und Uhrzeit) wann ein Eintrag in der Filebase aktiviert bzw. deaktiviert werden sollte.

    Das ganze hat den Vorteil das wenn man Downloads erst zu einem bestimmten Termin benötigt, man entsprechend alles vorbereiten kann und dann wird es automatisch aktiviert.

    Bsp, wenn man Downloads für einen Adventskalender bereitstellt uvw.

    Ich teste gerade etwas mit dem CMS/Box System herum.


    Wenn ich jetzt eine Box erstelle, welche als Navigation dienen soll:


    Code
    <ol class="boxMenu">
        <li><a href="LINK" class="boxMenuLink"><span class="boxMenuLinkTitle">SEITE A</span></a></li>
        <li><a href="LINK" class="boxMenuLink"><span class="boxMenuLinkTitle">SEITE B</span></a></li>
    </ol>


    Kann ich das ganze so bauen, dass wenn man auf SEITE A ist, entsprechend bei der manuell erstellten Navigation ein "active" in die class gesetzt wird? Oder gibt es eine allgemeine Möglichkeit anhand ausgewählter Seiten eine Navigationsbox zu erstellen? :/

    Ich möchte natürlich jetzt das ganze dynamischer haben. Könnte ja natürlich die Hammer Methode nehmen und für jede Seite eine eigene Box erstellen, aber wäre nur unnötige Arbeit wenn ich mal was an der Navigation ändern/erweitern möchte.


    Ziel des ganzen ist natürlich, da ich die aktive Seite in der Navigation hervorheben möchte, damit man dort sieht wo man ist.