Posts by M-B

    Hallo, ich habe gestern das Update von 5.4.4 auf 5.4.6 durchgeführt (habe den Core, das Forum und die Galerie) und seitdem ist in den Foren nur noch bei manchen Themen zu sehen, dass Reaktionen enthalten sind - wo die ganzen Icons stehen. Bei den Themen, wo kein Icon ist, sind aber auch Reaktionen enthalten. Ich habe schon den Cache gelöscht und alle Anzeigen aktualisiert, es ändert sich aber nichts.


    Was kann das sein?

    Na dann setze ich die drei Werte in den Benutzerprofilen (Letzte Aktivität, Letzte Profilbesucher und Benachrichtigungen) sowie den Wert für das globale Änderungsprotokoll wieder auf 30 Tage zurück. Muss ich dann noch den Cache leeren und alle Anzeigen aktualisieren? Und falls nicht, schaden kanns ja auch nicht, oder? ;)


    Vielen Dank für Eure kompetenten und ausführlichen Antworten. :thumbup:

    Alle Aktivitäten, die älter sind als der bisher eingestellte Wert in Tagen, wurden durch den Cronjob bereits aus der Liste entfernt und können dort nicht wieder hinzugefügt werden.

    Obwohl sie vorhanden sind - also auf jeden Fall die Themen und Beiträge? Wie das mit den Reaktions- und sonstigen Aktivitäten-Protokollen aussieht, weiss ich ja nicht. Schade, ich hätte gern eine Art "History" über sämtliche Community-Aktivitäten gehabt.


    Edit: Ab wann zählen eigentlich die jetzt eingestellten 365 Tage? Von der ältesten heute angezeigten Aktivität (22. Juli)? Oder ist dann ab morgen, wenn der Cronjob durchgelaufen ist, die älteste Aktivität die, welche seit der Änderung von 30 auf 365 Tage hinzugekommen ist? Also beispielweise ein Beitrag, der nach der Einstellungsänderung geschrieben wurde.

    Insofern die Daten nicht (mehr) in der Datenbank vorliegen, könnten diese rückwirkend dann natürlich nicht mehr angezeigt werden.

    Von welchem Bereich redest du? Ich finde über die Suche nach "Aktivität" keine Option die unter "Mitglieder" einsortiert ist. Ist das bei dir eventuell eine Option, die durch ein Plugin kommt?

    Das sind die letzten Aktivitäten, korrekt. Hast du hier im Dashboard ebenfalls.

    Die "Speicherzeit für Änderungen" bezieht sich auf die Aufbewahrung im globalen Änderungsprotokoll, korrekt.

    Danke Fighter456, die Themen und Beiträge von vor den 30 Tagen sind ja in der Datenbank vorhanden, aber bekommt man die jetzt noch nachträglich in die Liste der Aktivitäten aller Benutzer?

    Ich meine den Bereich unter "Benutzer", wo man auch die Dauer der Anzeigen "Letzte Profilbesucher" und "Aufbewahrungszeit von Benachrichtigungen" einstellen kann. Ich habe alle drei Optionen jetzt auf 365 Tage gesetzt. Plugins habe ich keine installiert.

    Und im globalen Änderungsprotokoll werden mir ja die bearbeiteten Inhalte angezeigt - ebenfalls für die letzten 30 Tage. Diesen Wert habe ich auch auf 365 Tage geändert. Kann man die älteren Inhalte jetzt durch diese Änderung auch noch nachträglich sichtbar machen?

    Ich habe die Option für "letzte Aktivitäten" im Benutzerprofil jetzt auf 365 Tage erhöht. Gilt das dann auch gleichzeitig für das Dashboard unter "Aktivitäten aller Benutzer"? Oder gibt es da noch eine separate Einstellung? Ich bin jetzt das ganze ACP durchgegangen. Eine andere Option habe ich auch noch von 30 auf 365 Tage erhöht: "Änderungen" - worauf bezieht sich das? Auf die Anzeige im globalen Änderungsprotokoll des ACPs?

    Eine rückwirkende Befüllung der Tabelle mit älteren Datensätzen ist nicht vorgesehen.

    Das heisst also, ich kann keine Aktivitäten, die älter als 30 Tage (aktuelle Einstellung) sind, anzeigen lassen, selbst wenn ich den Wert jetzt auf 60 erhöhe? Und gibt es da ein Limit für den Wert? Dann würde ich den auf 365 Tage einstellen.


    Ich habe jetzt im ACP mehrere Optionen für "letzte Aktivitäten" gefunden - auch unter "Mitglieder" - muss ich das dann überall ändern?

    Standardmäßig werden alle Aktivitäten älter als 30 Tage per DailyCleanUpCronjob gelöscht. Ergo existieren die Einträge für die Aktivitäten nicht mehr. Egal ob man jetzt die Anzeige für das Dashboard erhöht oder nicht.

    Gilt das auch für die WoltLab-Suite 5.4.4?

    Ich habe mich eben mal durchgeklickt und der älteste Eintrag ist vom 22. Juli 2021.

    Und wo kann man die Anzeige für das Dashboard erhöhen?

    Und schon habe ich den Fehler gefunden: Ich habe heute die Boxen "Benutzer online" und "Benutzer waren online" auch in der Forenliste anzeigen lassen, zusätzlich zum Dashboard. Jetzt habe ich die Anzeige im Forum wieder deaktiviert und es funktioniert.


    Oder kann es daran liegen, dass ich bei CSS den folgenden Code eingefügt habe, um Namen ohne Komma und untereinander anzeigen zu lassen? Die Anzeige der Boxen im Forum dürfte doch die Bearbeitung der Thementitel nicht beeinflussen.

    Hallo, momentan kann ich nur Themen bearbeiten, die ich erstellt und als Ankündigung gesetzt habe. Eigene Themen, die angepinnt sind oder normalen Status haben bzw. Themen anderer Mitglieder kann ich nicht bearbeiten (mit Bearbeiten meine ich den Thementitel ändern).

    Ich klicke also das Thema an, bei welchem ich den Titel bearbeiten möchte, dann oben rechts auf "Thema bearbeiten", jedoch fehlt dann bei den Optionen "Erweitert", bei der man ja den Titel, die Tags und Labels ändern kann. Ich kann auch kein Thema auf "Ankündigung" umändern.

    Ich habe eben meinen WSC-Ordner mit Putty gesichert, jedoch kommt keine Verbindung mit der DB zustande, um auch diese zu sichern.

    Die Logindaten sind korrekt und die Meldung lautet:

    Code
    mysqldump: Got error: 2002: "Can't connect to local MySQL server true socket '/run/mysqld/mysqld.sock' (2)" when trying to connect

    Gestern funktionierte es noch - kann das dann eher am Hoster oder an Putty liegen?