Posts by Modelcarforum

    Nachdem ich im Forum meinen Verdacht geäußert hatte, dass offenbar nur Threads mit bei "Abload" gehosteten Fotos von diesem Phänomen betroffen sind, haben das zumindest zwei weitere User gezielt getestet und ebenfalls bestätigt.

    Das ist für mich auch die einzig schlüssige Erklärung für dieses Verhalten.


    Somit denke ich, können wir diesen Thread hier getrost mit "Ist kein Fehler" labeln. :)

    Beim Umzug vom alten auf den neuen Server hast du ganz sicher alle Bilder im binären Modus übertragen?

    Weder noch, ich muss noch dazu sagen, dass es sich ausschließlich um fremdgehostete (un somit nur eingebundene) Fotos handelt.


    Mir kam aber zwischenzeitlich ein neuer Verdacht und ich habe das mal von mehreren Usern testen lassen: Es scheint sich wohl bisher nur um Fotos zu haneln, die beim Pic-Hoster "Abload" gehostet werden.

    Somit würde ich das Phänomen eher zu denen schieben als zu unserer Software. :D Ich lasse das mal gezielt von Usern beobachten.


    Seltsam bleibt aber dennoch der Umstand, dass das NUR in der mobilen Ansicht passiert, nicht bei Desktops (auch denen der selben User nicht). Die Fotos werden also nach wie vor definitiv von dort ausgeliefert. Der "Mobile-Style" (ist es ja technisch nicht mehr) sendet aber prinzipiell keine anderen Requests über den Browser an den Server als ein Desktop Browser.... von daher bleibt das schon etwas auffällig.


    Hat jemand anderes hier dieses Phänomen schon mal seit 5.4.x beobachtet? Denn ansonsten könnte man die Software (WoltLab) ja restlos ausschließen.

    Hallo zusammen,


    hier im Forum habe ich noch kein passendes Thema gefunden und da mir langsam die Ideen zur Lösung ausgehen, wende ich mich hier mal an Betreiber, die ebenfalls Foren mit teils "Bild-lastigen" Beiträgen betreiben:


    Seit dem Upgrade auf die Version 5.4.x häufen sich vermehrt die Klagen von Usern, dass auf diversen mobilen Endgeräten neue Threads/Beiträge mit mehreren Fotos nicht mehr korrekt dargestellt werden.

    Das äußert sich dann dergestalt, dass (bei z.B. 10 untereinander gezeigten Fotos) mittendrin 2, 3 oder teils willkürlich mehrere Fotos "fehlen" und stattdessen nur das berühmte Icon angezeigt wird.

    Ruft der User den Thread dann später wieder auf bzw. führt mehrfache Refreshes der Seite aus, ist alles wieder vorhanden.


    Betroffen sind offenbar mehrere Smartphone- und Tablet-Hersteller (bisher meistens Android) sowie nicht nur der Chrome, sondern auch andere Browser wie z.B. der Opera sowie auch der Chrome in der modifizierten Samsung-Version.


    Da sich dieses Problem nur schwer bis gar nicht bewusst provozieren lässt, die Frage an Euch: Hat jemand (mit vielen Fotos in Beiträgen) schon ähnliche Beschwerden nach der Umstellung auf 5.4 bekommen?

    Gab es maßgebliche Änderungen in 5.4 an der mobilen Ansicht der Software, abgesehen vom "nach unten verlagerten Reaktionssystem" in Beiträgen? (dieses kann ja wohl kaum daran schuld sein)


    Die Domain ist sogar kürzlich auf einen leistungsstärkeren Server umgezogen und die Settings (inkl. MySQL/MariaDB) sind recht großzügig gesetzt, an Ausführungszeiten etc. liegt es also nicht. Selbst vorher auf dem schwächeren Server unter 5.3 traten derartige Effekte nicht auf.


    Was von den Usern bisher (teils auf meine Empfehlung hin) probiert wurde:


    • testweise den Browser wechseln (z.B. von Chrome auf Opera oder Firefox)
    • Cache mindestens für die Domain leeren
    • Datensparmodus testweise ein- und ausschalten und damit testen (der Fehler tritt aber sowohl bei LTE/4G als auch in 50.000er DSL/WLAN Netzwerken auf, also kann man die Option ausschließen)
    • Schriftart bzw. -größe der Website-Darstellung ändern, resp. Seiten-Zoom
    • Werbeblocker deaktiviert
    • komplettes Zurücksetzen aller Browserdaten bzw. -Settings (hatte ein User von sich aus getan, das war keine Empfehlung von mir)


    All das brachte nicht. Gerade erfahre ich vom ersten User mit diesem Problem, dass sich die Darstellung bei ihm auch mit jedem Refresh ändert. Mal fehlen einzelne zwischendurch, mal nahezu alle und dann werden wieder ein paar mehr dargestellt usw. usw. Nicht beeinflussbar.

    Die fehlenden werden dann als Icon samt Dateinamen angezeigt, aber nicht als Foto.


    Noch irgendwelche anderen Ideen? Wenn er mir das gestattet, zeige ich hier gerne auch mal seinen Screenshot von dem Problem. Bei den anderen betroffenen Usern sieht das aber ganz ähnlich aus, nur bei jedem jeweils etwas anders, was die Anzahl betrifft.

    Das befindet sich als Perl-Script bereits innerhalb des Dumpers (sofern es nicht in aktuellen Versionen entfernt wurde, das entzieht sich gerade meiner Kenntnis) und muss nur passend eingerichtet werden.


    Du hinterlegst Deinen absoluten Server-Pfad zur Installation und lässt anschließend den Perl-Test 1x durchlaufen. Meldet der "OK", kannst Du im Anschluss sofort ein manuelles Backup via Perl im Dumper anstoßen.


    Läuft auch das ohne Abbruch, gibt Dein Server diese Möglichkeit her und es spricht nichts mehr gegen die Einrichtung eines Cronjobs. Was dazu im Einzelen an Einträgen nötig ist, hängt von Deinem Hoster ab und weicht ab, je nach Crontab und Admin-Panel.


    Im damaligen MySQLDumper-Forum hatte ich vor vielen Jahren mal die Konfigurationen diverser Hoster samt Screenshots gepostet, aber das Forum hat Daniel ja leider platt gemacht, da es nach Einstellung der Weiter-Entwicklung nicht mehr benötigt wurde.


    Nachtrag: Der absolute Pfad zur Config muss in die Datei crondump.pl eingetragen werden.

    Da ich ja früher zur MySQLDumper-Zeit auch zum dortigen Team gehörte und hier wiederholt die Frage aufkam, warum man überhaupt ein derartiges Tool benötigt, kann ich vielleicht auch etwas dazu sagen:


    Diese Frage kam auch dort im Support-Forum manchmal auf und die Antwort ist (wie auch teils hier schon erwähnt wurde) ganz einfach:

    Weil

    • längst nicht alle Admins über eigene Server verfügen, sondern beispielsweise auf Shared ohne SSH-Berechtigung liegen
    • dort meistens nur "Standard"-Tools wie das fehlerträchtige phpMyAdmin zur DB-Verwaltung angeboten werden, die aber zur Sicherung größerer Datenbanken via PHP ungeeignet sind (Timeout-Gefahr durch kurze Script-Laufzeiten)
    • gerade der MySQLDumper/MyOOSDumper dieses Problem durch ständige (frei konfigurierbare) Selbstaufrufe im Browser umgeht und
    • dazu etliche komfortable Funktionen zur DB-Verwaltung bietet,
    • deutlich komfortabler mittels GUI zu bedienen ist als beispielsweise SSH via PuTTY-Client (damit muss man sich auskennen und das tun längst nicht alle Admins)
    • nicht zuletzt damit bei Bedarf auch sehr einfach einzelne Tabellen wiederhergestellt werden können (z.B nur alle User-Tables)
    • sich damit sehr einfach Cronjobs per PERL-Script einrichten lassen, z.B: zur täglichen Sicherung


    Nichtsdestotrotz ist falls möglich natürlich SSH/Konsole vorzuziehen, keine Frage. Zumal damit eine Sicherung deutlich schneller läuft als über einen Browser.

    Für komplette Backups/Restores reicht das allemal und lässt sich ja ebenfalls als Cron ausführen.


    WENN aber der Dumper verwendet wird, empfehle ich dringend unbedingt sofort den Verzeichnis-Schutz via .htaccess/.htpasswd einzurichten! . Das geht direkt über das Tool bei der Einrichtung, aber auch später jederzeit.

    Denn man darf nie vergessen, dass jeder diesen Pfad erraten kann und somit vollen Zugriff auf die DB hätte, wenn nicht geschützt!


    Das war leider damals auch manchmal Thema bei uns im Support, da manche Admins das nicht für nötig halten (aber auch nicht wissen, was die damit riskieren). Ein .htaccess-Schutz ist hingegen praktisch nicht zu umgehen, da dazu Server-Zugriff (oder ein KeyLogger zum Passwort-Abgriff) nötig wäre und wenn ein Unbefugter diesen Zugriff hat, ist eh alles zu spät bzw. wurde dann etwas gründlich falsch gemacht....

    Ohje, dann hat sich also meine Befürchtung während der Alpha-Phase hier im Forum doch bestätigt. :( Ab da tauchten ja auch hier schon sämtliche Beiträge von Team-Mitgliedern als "offiziell" auf und ich hatte geahnt, dass das künftig ein "Automatismus" ist und niocht fallweise gewählt werden kann (bzw. muss, wenn benötigt). :(


    Es jedes Mal manuell abzuwählen, wenn es NICHT benötigt wird (ca. 95-99% aller Fälle bei Admins außer in Support-Foren wie hier), ist ja tatsächlich der absolute Schwachsinn und wenn das nicht wieder zurück geändert bzw. diese Funktion umgekehrt wird, werde ich das vorläufig auch nirgendwo auf 5.4 upgraden. Das können wir ja nun wirklich überhaupt nicht gebrauchen und zum Glück sehen das offenbar bisher auch nahezu 100% der Kunden hier so (wenn man mal quer durchs Forum liest).


    Von daher würde ich ebenfalls en Antrag dringend unterstützen, für künftige Updates 1. diese Funktion nicht als "default" zu setzen und 2. vor allem nicht durch Upgrade einfach ALLE bestehenden Beiträge bestimmter Mitglieder rückwirkend als "offiziell" zu deklarieren. Das ist ja der Horror! :D Wie viel "Smalltalk" oder "normale" Beiträge sind in Foren nicht auch von Admins und Mods dabei?

    Wenn schon eine solche Funktion, dann bitte NUR manuell schaltbar und am besten auch nur für Administratoren oder bestenfalls noch wenige ausgewählte Moderatoren, aber och nicht für komplette Teams und nur "gruppenweise" schaltbar.....


    Derartige Funktionen sollten immer fallweise bzw. Benutzer-bezogen schaltbar sein, wenn man sie denn überhaupt benötigt....

    Die "Wichtigkeit" einer Nachricht ist nicht von irgendeinem Label abhängig, sondern viel eher vom Ansehen der jeweiligen Person bei en Usern, die sie verfasst hat. Und wenn eine Team-Mitteilung relevant für die User ist, lässt sie sich ja auch in nahezu jeder Software seit Urzeiten als "Offizielle (globale) Ankündigung" oder in einem bestimmten (Unter-)Forum als Ankündigung oder Sticky-Thread verfassen.


    Begrüßt ein Admin aber z.B. einen Neuuser, muss da ganz sicher nicht "offiziell" dahinter stehen....

    Eine manuell nötige Abwahl vor dem Verfassen JEDEN Beitrags halte ich für hoffnungslos übertrieben - um nicht zu sagen "grundfalsch".Ich weiß nicht, wer immer auf solche Ideen kommt.... :(

    Auch eine manuelle Änderung durch Kunden via SQL-Query plus div. Template-Änderungen, um dieses Verhalten wieder zu ändern, halte ich für den verkehrten Weg.

    Es kann nicht die Aufgabe der (zahlenden) Kunden sein, eine neue Software wieder "umzuprogrammieren", nur damit sie wieder vernünftig nutzbar ist....

    Zumal dem weitaus größten Teil der Kundschaft sogar die nötigen Kenntnisse dazu fehlen dürften. Längst nicht jeder Forenbetreiber ist auch fit in MySQL oder Programmierung.

    Genau diese Frage stellt sich mir (allerdings in 5.3.x) gerade auch, da ich diese Funktion kürzlich in einem Forum (über PayPal, den im WBB derzeit einzig möglichen Zahlungsanbieter) eingerichtet habe.

    Im System selbst ist dazu leider kein Hinweis zu finden und auch hier steht ja eine Antwort bisher aus.


    Schön wäre natürlich eine automatisierte E-Mail, da nicht jeder betroffene User laufend eingeloggt ist und somit nicht unbedingt zeitnah die Hinweise im Forum sieht. Zumal Hinweise nicht gruppenabhängig "zeitgesteuert" sind.


    Und glücklicherweise habe ich vor Absenden dieses Beitrags gerade mal in die Cronjobs geschaut, ob dort keiner davon evtl eine derartige E-Mail versendet. Und siehe da, ich hätte mir den Beitrag eigentlich sparen können: :D

    Denn es gibt in der Tat einen, der E-Mails über ablaufende Mitgliedschaften versendet und somit haben wir Alle die Antwort auf diese Frage:


    Quote from Cronjob-Verwaltung

    Sendet Benachrichtigungen über ablaufende bezahlte Mitgliedschaften


    Somit habe ich mich gerade entschlossen, diesen Beitrrag doch abzusenden, denn die Frage taucht sicherlich auch später noch beim einen oder anderen Betreiber auf und nun haben wir wenigstens eine Antwort darauf. :)

    Zur Ergänzung noch, falls jemand es ähnlich setzen möchte:

    Die "Team-Mitglieder" Box ist separat (für Zugriffsberechtigungen) schaltbar. Wenn man nicht möchte, dass auch Gäste diesen Online-Status (von Team-Mitgliedern, die ihren Status nicht selber im Profil verbergen) in der eigenständigen Box sehen, trotzdem aber die allgemeinen Benutzer-Online Listen sehen sollen/dürfen, reicht die folgende Einstellung aus:


    • Via ACP-Suche die Option Kann Benutzer-Online-Listen sehen suchen und dort der Gruppe "Gäste" das Recht auf "Ja" und bei "Jeder" auf "Nein" setzen (alle anderen Gruppen wie gewünscht). Mit dieser Methode geht es am schnellsten, bevor man jede Gruppe einzeln aufruft und bearbeitet.
    • Anschließend zu Inhalt -> Boxen wechseln und dort die Box Team-Mitglieder online suchen und aufrufen.
    • Unter "Zugangsbeschränkung" nun Inhalt ist für alle Benutzer sichtbar auf "Nein" setzen und darunter die Benutzergruppe Registrierte Benutzer eintragen.
    • Zuletzt diese Option über Absenden speichern und freuen.


    So hatte ich das in besagtem Forum wohl auch ursprünglich gesetzt (und jetzt erneut).

    Damit sind für Gäste zwar die Online-Listen weiterhin sichtbar, nicht aber diese eigenständige "Team-Box" in der Sidebar. Nach dem Login wird diese selbstverständlich wie gewohnt eingeblendet.

    Zu dem Schluss war ich auch gekommen:



    Eine (vermutliche) Erklärung für dieses Phänomen habe ich gerade gefunden:

    Wenn ich der Gruppe Jeder das Recht erteile, Mitglieder-Online-Listen zu sehen, funktioniert es auch wieder für Gäste. Ansonsten nicht.


    Was mich nur verwundert hatte, ist, dass nach dem Update auf 5.3.5 dieses Recht in der Gruppe "Jeder" plötzlich "zurück gesprungen" war und ich es erneut setzen musste. Das fand ich etwas ungewöhnlich.

    aber mich würde dennoch interessieren, weshalb du frühestens nach 24 Stunden eine weitere Antwort erlaubst?

    Die Funktion, mit der Du das verwechselst, nennt sich " Flood-Control (Mindestzeit zwischen zwei Beiträgen)."

    Diese ist je Benutzergruppe unabhängig von "Mindestzeit zwischen zwei Antworten" einstellbar.

    Eben, das ist genau das Problem. Deshalb auch das

    Eine "starre" Empfehlung gibt es da eigentlich nicht.


    Gäbe es die, könnte man sie auf allen Servern auch gleich "In Stein meißeln". Das geht aber bei Konfigurationen jeglicher Art praktisch nie, dafür sind die Szenarien zu unterschiedlich.


    Ja, leider ist "Es gibt keine Auffälligkeiten" die Standard-Antwort Nummer 1 der wohl meisten Hoster. Es ist ärgerlich, dass dann häufig der Kunde den "Gegenbeweis" antreten und entsprechend selber genug im Thema sein muss. Was aber eigentlich nicht die Aufgabe eines Hosting-Kunden ist (oder sein kann).


    Der Laie muss sich eigentlich auf den Fachmann verlassen und wenn von diesem immer nur ein "da ist nichts!" kommt, ist das wenig befriedigend....

    Die müsste man dann evtl. abwarten.

    Es mag theoretisch sein, dass bei der Anzahl der Kunden / Arten der Anwendungen auf diesem Server der Wert trotzdem noch zu eng bemessen ist. Eine "starre" Empfehlung gibt es da eigentlich nicht.


    Aber auch andere Gründe für das Verhalten würde ich nicht kategorisch ausschließen. Diese kann aber am besten tatsächlich der Hoster herausfinden (der seine Konfiguration kennt und über Monitoring verfügt).

    Hallo,


    wäre es eventuell möglich, "zu moderierende" (also (temporär) deaktivierte) Threads im Moderationsmenü künftig nur als kompletten Thread darzustellen, statt mit jedem einzelnen Beitrag?

    Denn so wird es ja vorübergehend doch recht unübersichtlich bis zur Markierung, spätestens bei längeren Threads mit vielen Antworten.


    Auch die schlagartig große Zahl von "xx" im Mod-Dreieck könnte für kurze Verwirrung unter Moderatoren sorgen, ich weiß nicht wie da Eure Erfahrung ist? Bei einer Thread-Anzeige würde dort auch dort dann nur eine "1" stehen und das Thema schnell gefunden (und später erneut freigeschaltet) werden.


    Sofern es "nur" mehrere Einzelbeiträge innerhalb eines ansonsten geöffneten/aktivierten Threads betrifft, ist das natürlich kein Problem. Aber bei kompletten Threads finde ich diese Einzelauflistung etwas problematisch und vermutlich schreckt das auch Moderatoren manchmal ab, sich da alles einzeln über das Mod-Menü anzusehen. Auch wenn man dann schnell "Zum Inhalt gehen" kann.

    Das stimmt - und ist ja nach der Lösung jetzt auch nicht das "wahnsinnig große Problem".

    Es ist aber ebenso auch mal wieder "eines der Themen", in denen sich manche Standard-User wie in nahezu jedem Beitrag als "Möchtegern-Moderator" eines fremden Forums aufspielen möchten... ;)


    Da darf man sich jetzt gerne überlegen, was davon nun "schlimmer oder besser" ist. Oder noch besser, ob man derartige Entscheidungen und Aussagen nicht lieber dem jeweils tatsächlichen Team überlassen möchte. :)

    Es ist keineswegs obsolet. Grade in Zeiten von mobilen Internet...

    Mobil ist noch mal ein anderes Thema da stimme ich Dir zu.Dort hat es mit Blick auf (niedrige) Datenvolumen durchaus noch Berechtigung. Wir beziehen es hier ja aber eher auf den stationären Betrieb, und dort macht es für einen User eigentlich keinen Unterschied, wenn er vordergründig keinen Unterschied im Aufbau feststellen kann.