Posts by RN_Flocke

    Guten Morgen ,

    Ich hab mal eine Grundsätzliche Frage zum Impressum .

    Ja man findet einiges in Der Suche , mir geht es aber nochmal darum es eindeutig zu wissen . Quasi : Impressums Erklärung für Dummis :)

    Was ist genau Pflicht bei einer Privaten , bzw. Community Seite ?

    Mit meiner Aussage will ich auch keineswegs die neue Software in Frage stellen. Es ist aber zumeist ganz natürlich, dass in der Anfangsphase der ein- oder andere Fehler erst im laufenden Betrieb festgestellt wird.

    Hab Ich auch nicht so verstanden . Es war von mir aus gemeint : Das Ich es noch nie so leicht hatte ein update zu machen . Das letzte mal musste mein Vater das machen . ;)

    Hallo,


    ImageMagick kann WebP schon seit mindestens Version 6.9.4-0 (https://github.com/ImageMagick…f317f73f6e0f1b4043a76728a). Die Unterstützung für WebP in ImageMagick ist aber davon abhängig, ob ImageMagick mit WebP-Unterstützung kompiliert wurde. Ein reiner Vergleich von Versionsnummern ist hier also nicht ausreichend.

    Ging Ja bei mir vorher nicht.Habe es Selber updaten können .

    Aber Die Info das es nicht von der Version abhängig ist , Erklärt mir auf jedenfall einige. Musste ganz schön rumbasteln.

    imagick module version 3.4.4

    Imagick compiled with ImageMagick version ImageMagick 6.9.10-68 Q16 x86_64 2020-04-01
    Imagick using ImageMagick library version ImageMagick 6.9.10-68 Q16 x86_64 2021-02-24

    Für mich sieht Deine Version Neuer ( bis auf das Ich 3.5 habe ) aus . Bzw. Wenn das hinten das Datum ist .

    Ich habs mit :

    Code
    3.5.0
    imagick classes     Imagick, ImagickDraw, ImagickPixel, ImagickPixelIterator, ImagickKernel
    Imagick compiled with ImageMagick version     ImageMagick 6.9.10-23 Q16 x86_64 20190101 https://imagemagick.org
    Imagick using ImageMagick library version     ImageMagick 6.9.10-23 Q16 x86_64 20190101 https://imagemagick.org 

    Jetzt Installieren können ( Test Installation ) .

    Weiß nicht wie ich das fixen kann :

    Code
    rror Message:
    
    rename(/var/www/vhosts/roughnecks-germany.de/httpdocs/tmp/atomic_52936ee46bc25f95c04ca9bb3328797b3047fbbb,/var/www/vhosts/roughnecks-germany.de/httpdocs/acp/templates/compiled/0_reauthentication.meta.php): Operation not permitted

    Denn anderen Fehler habe Ich beheben können .

    Guten morgen ,


    Eigentlich geht es um die version 5.4.0 RC2


    Ich habe alles übertragen fast alle seiten laufen . Nur meine Nicht .

    Der Fehler ist :

    Requested URL
    GET /forum/thread/2174-shoutbox-enter-taste-statt-absenden/?postID=5183
    Referrer
    Error Message
    Unable to find class 'wbb\system\event\listener\WhoreadThreadListener'
    Type
    wcf\system\exception\SystemException
    File (Line)
    /var/www/vhosts/roughnecks-germany.de/httpdocs/lib/system/event/EventHandler.class.php (228)
    Stacktrace
    1. /var/www/vhosts/roughnecks-germany.de/httpdocs/lib/page/AbstractPage.class.php (145): wcf\system\event\EventHandler->fireAction(…)
    2. /var/www/vhosts/roughnecks-germany.de/httpdocs/lib/page/MultipleLinkPage.class.php (115): wcf\page\AbstractPage->readData(…)
    3. /var/www/vhosts/roughnecks-germany.de/httpdocs/forum/lib/page/AbstractThreadPage.class.php (194): wcf\page\MultipleLinkPage->readData(…)
    4. /var/www/vhosts/roughnecks-germany.de/httpdocs/forum/lib/page/ThreadPage.class.php (79): wbb\page\AbstractThreadPage->readData(…)
    5. /var/www/vhosts/roughnecks-germany.de/httpdocs/lib/page/AbstractPage.class.php (339): wbb\page\ThreadPage->readData(…)
    6. /var/www/vhosts/roughnecks-germany.de/httpdocs/lib/page/AbstractPage.class.php (122): wcf\page\AbstractPage->show(…)
    7. /var/www/vhosts/roughnecks-germany.de/httpdocs/lib/system/request/Request.class.php (89): wcf\page\AbstractPage->__run(…)
    8. /var/www/vhosts/roughnecks-germany.de/httpdocs/lib/system/request/RequestHandler.class.php (119): wcf\system\request\Request->execute(…)
    9. /var/www/vhosts/roughnecks-germany.de/httpdocs/forum/index.php (11): wcf\system\request\RequestHandler->handle(…)

    Kommt wenn Ich ein Thema Lesen will .

    Wo ist denn dieser Pfad ? Ich find nix mit wbb !?

    Da das Plugin nicht mehr zur verfügung steht , Ich aber das Backup habe und auch korrekt Hochgeladen habe , check ich das einfach nicht.


    Der zweite Fehler Taucht auf wenn ich ins acp will :

    Requested URL
    GET /dashboard/
    Referrer
    Error Message
    rename(/var/www/vhosts/roughnecks-germany.de/httpdocs/tmp/atomic_2e69e0cf2e4f0b733b4a0c84f9fa5978365e035a,/var/www/vhosts/roughnecks-germany.de/httpdocs/cache/cache.wbb_BoardData.php): Permission denied
    Type
    wcf\system\exception\ErrorException
    File (Line)
    /var/www/vhosts/roughnecks-germany.de/httpdocs/lib/system/WCF.class.php (344)
    Template Context
    <div id="pageHeaderContainer" class="pageHeaderContainer"> <header id="pageHeader" class="pageHeader"> <div id="pageHeaderPanel" class="pageHeaderPanel"> <div class="layoutBoundary"> ====> <?=$this->v['__wcf']->getBoxHandler()->getBoxByIdentifier('com.woltlab.wcf.MainMenu')->render();?> <?php if (!isset($this->pluginObjects['wcf\system\template\plugin\UserFunctionTemplatePlugin'])) { $this->pluginObjects['wcf\system\template\plugin\UserFunctionTemplatePlugin'] = new wcf\system\template\plugin\UserFunctionTemplatePlugin; } if (!isset($this->pluginObjects['wcf\system\template\plugin\LinkBlockTemplatePlugin'])) { $this->pluginObjects['wcf\system\template\plugin\LinkBlockTemplatePlugin'] = new wcf\system\template\plugin\LinkBlockTemplatePlugin;
    Stacktrace
    1. [internal function] (?): wcf\system\WCF::handleError(…)
    2. /var/www/vhosts/roughnecks-germany.de/httpdocs/lib/system/io/AtomicWriter.class.php (103): rename(…)
    3. /var/www/vhosts/roughnecks-germany.de/httpdocs/lib/system/cache/source/DiskCacheSource.class.php (76): wcf\system\io\AtomicWriter->flush(…)
    4. /var/www/vhosts/roughnecks-germany.de/httpdocs/lib/system/cache/CacheHandler.class.php (97): wcf\system\cache\source\DiskCacheSource->set(…)
    5. /var/www/vhosts/roughnecks-germany.de/httpdocs/lib/system/cache/builder/AbstractCacheBuilder.class.php (45): wcf\system\cache\CacheHandler->set(…)
    6. /var/www/vhosts/roughnecks-germany.de/httpdocs/forum/lib/data/board/BoardCache.class.php (109): wcf\system\cache\builder\AbstractCacheBuilder->getData(…)
    7. /var/www/vhosts/roughnecks-germany.de/httpdocs/lib/system/SingletonFactory.class.php (29): wbb\data\board\BoardCache->init(…)
    8. /var/www/vhosts/roughnecks-germany.de/httpdocs/lib/system/SingletonFactory.class.php (67): wcf\system\SingletonFactory->__construct(…)
    9. /var/www/vhosts/roughnecks-germany.de/httpdocs/forum/lib/system/page/handler/BoardListPageHandler.class.php (34): wcf\system\SingletonFactory::getInstance(…)
    10. /var/www/vhosts/roughnecks-germany.de/httpdocs/lib/data/menu/item/MenuItem.class.php (143): wbb\system\page\handler\BoardListPageHandler->isVisible(…)
    11. /var/www/vhosts/roughnecks-germany.de/httpdocs/lib/data/menu/item/MenuItemNodeTree.class.php (143): wcf\data\menu\item\MenuItem->isVisible(…)
    12. /var/www/vhosts/roughnecks-germany.de/httpdocs/lib/data/menu/item/MenuItemNodeTree.class.php (106): wcf\data\menu\item\MenuItemNodeTree->generateNodeTree(…)
    13. /var/www/vhosts/roughnecks-germany.de/httpdocs/lib/data/menu/Menu.class.php (122): wcf\data\menu\item\MenuItemNodeTree->__construct(…)
    14. /var/www/vhosts/roughnecks-germany.de/httpdocs/lib/data/menu/Menu.class.php (71): wcf\data\menu\Menu->getMenuItemNodeTree(…)
    15. /var/www/vhosts/roughnecks-germany.de/httpdocs/lib/data/box/Box.class.php (332): wcf\data\menu\Menu->hasContent(…)
    16. /var/www/vhosts/roughnecks-germany.de/httpdocs/lib/data/box/Box.class.php (311): wcf\data\box\Box->hasContent(…)
    17. /var/www/vhosts/roughnecks-germany.de/httpdocs/templates/compiled/18_wcf_1_cms.php (1736): wcf\data\box\Box->render(…)
    18. /var/www/vhosts/roughnecks-germany.de/httpdocs/lib/system/template/TemplateEngine.class.php (346): include(…)
    19. /var/www/vhosts/roughnecks-germany.de/httpdocs/lib/page/AbstractPage.class.php (371): wcf\system\template\TemplateEngine->display(…)
    20. /var/www/vhosts/roughnecks-germany.de/httpdocs/lib/page/AbstractPage.class.php (122): wcf\page\AbstractPage->show(…)
    21. /var/www/vhosts/roughnecks-germany.de/httpdocs/lib/system/request/Request.class.php (89): wcf\page\AbstractPage->__run(…)
    22. /var/www/vhosts/roughnecks-germany.de/httpdocs/lib/system/request/RequestHandler.class.php (119): wcf\system\request\Request->execute(…)
    23. /var/www/vhosts/roughnecks-germany.de/httpdocs/index.php (11): wcf\system\request\RequestHandler->handle(…)

    Die rechte sind aber korrekt gesetzt .

    Wäre Super wenn mir jemand helfen könnte .

    Vielen Dank schonmal .

    Der Fehler war, dass dies beim Upgrade nicht korrekt geprüft wurde, sondern nur bei der Neuinstallation bzw. der Systemüberprüfung. Mit der RC 2 haben wir die fehlende Prüfung beim Upgrade ergänzt.


    Die Version stammt also vom 14. Januar 2017, das ist ziemlich alt.


    Es würde ausreichen, die PHP-Erweiterung "imagick" zu deaktivieren, diese stellt ImageMagick bereit.

    Nein . Reicht nicht aus .