Posts by surfingseacow

    I have some new signups that contact me saying that they aren't getting an activation email. I have "Approval through email confirmation" selected in ACP / Options / Users / Registration. Yet they aren't getting any.


    It's not an isolated case. I've had 4-5 people mentioning it.


    Anyone has any ideas on why? Or how to fix it?

    Hi,


    I seem to have a noobish question. I'm struggling with BBcodes, my color BBcode isn't working. I imported my vBulletin over, but not sure if this included the BBcodes I used on it as well.


    This is what I get:


    And these are my settings:




    Anyone knows what I'm doing wrong? Or how I can fix this.


    I also have a secondary BBcode question. I need 2 codes to preferably create a tag to a thread, or in worst case, do nothing. The codes are a result of an output by a third party software, so I have to deal with them. Is there a way to do this?


    Also: is there a manual when it comes to BBcodes? because it seems like bad advertisement that I always need to consult phpBB or Xenforo websites to find info about something for burning board. Maybe add more entry level manuals

    Apparently the answer has just been in front of us the whole time.


    MessageParser.class.php has the following code on lines 255-281



    So all I had to do was "activate" line 271 (17 here) and "deactivate" line 273 (19 here). By doing so apparently you don't need the whitespace to parse smileys / smilies.


    Keep in mind that I have no PHP knowledge. I did however knew that // kinda makes a line not work (expert explanation), realized that they looked similar and tried adjusting it.


    Kinda weird noone here knew this. Hope this shows up in searches by people, because I'm obviously not the only one that will have this issue.

    I imported my attachments from vBulletin 4.2. The import didn't work properly as it was [ attach=config ] 1234 [ /attach ] on the old forum, but wbb uses [ attach] [ /attach ] as bbcode.


    I noticed that just manually changing and saving the post fixed the issue and displayed the attached pictures in their original place.


    I performed a sql query to replace all the [ attach=config ] by [ attach ] using

    Code
    update wbb1_post set message = replace(message, '[ATTACH=CONFIG]', '[ATTACH]');


    But although this worked, the [ attach=config ] 1234 [ /attach ] now has been preplaced with the link to the attachment, and not the picture itself.
    If I edit + save the post (without changing something) it does fixes the issue.


    I'm having a bit of an issue with links, within posts, or incoming. The structure of vBulletin for the forum was: example.com/forum/forum/thread
    This now changed to example.com/forum/thread


    Is there a way of automaticly sending all incoming links to "one step down" the tree? This might be a more general redirecting issue, and not really a WBB issue. But it's what caused it, so I'm asking it here :)


    Pointing me towards the right documentation is more than enough :) love to learn new stuff.


    I know I can add stuff in the .httacces, something called redirect 301, but that seems to be for every individual link. And I need to mass redirect everything to take out 1 "forum/" in the old url's.


    Thanks in Advance

    Hi Morik,


    Thanks for the answer.


    The problem is that most of my members will copy paste poker hand histories from a third party software, and it's output is without the whitespace. Given the nature of the board (a pokerforum) I'm pretty sure this is an essential item that I need to fix :)


    An example:


    [converted_hand][hand_history]Poker Stars, $0.10/$0.25 No Limit Hold'em Cash, 6 Players


    SB: $28.64 (114.6 bb)
    BB: $39.69 (158.8 bb)
    UTG: $25.25 (101 bb)
    MP: $49.26 (197 bb)
    CO: $25.22 (100.9 bb)
    Hero (BTN): $42.17 (168.7 bb)


    Preflop: Hero is BTN with 6:spade: 6:heart:
    [color="red"]UTG raises to $0.75[/color], 2 folds, Hero calls $0.75, [color="grey"]SB folds[/color], BB calls $0.50


    Flop: ($2.35) T:spade: 6:diamond: T:club:[color="blue"] (3 players)[/color]
    BB checks, UTG checks, [color="red"]Hero bets $1.90[/color], BB calls $1.90, [color="grey"]UTG folds[/color]


    Turn: ($6.15) 4:spade:[color="blue"] (2 players)[/color]
    BB checks, [color="red"]Hero bets $5[/color], [color="red"]BB raises to $13[/color], [color="red"]Hero raises to $39.52 and is all-in[/color], BB calls $24.04 and is all-in


    River: ($80.23) 8:spade:[color="blue"] (2 players, 2 are all-in)[/color]


    [spoil]Results: $80.23 pot ($2 rake)
    Final Board: T:spade: 6:diamond: T:club: 4:spade: 8:spade:
    BB showed T:heart: A:spade: and lost (-$39.69 net)
    Hero showed 6:spade: 6:heart: and won $78.23 ($38.54 net)
    [/spoil][/hand_history][/converted_hand]


    We also use [Ad] smiley codes for cards. And they suffer from the same thing.

    Originally posted this in the "Creating Styles" section, but I guess it was the wrong subforum.


    I'm having a problem with old smilies on my forum.


    Burningboard needs a space before and after the smiley in order to turn it into the image, but in practice that kinda beats a big protion of the smilies we have in place. Anyone has an idea?


    (screenshot)
    https://gyazo.com/aa52fb9c7fdcf53fcda0b14336104c73


    EDIT:


    I found a thread on the support forum of phpbb with the same issue, and they fixed it. Unfortunatly I have no idea where to start looking in Burning Board.


    https://www.phpbb.com/community/viewtopic.php?f=72&t=2168761
    https://www.phpbb.com/community/viewtopic.php?f=46&t=1928675


    EDIT 2:


    I'm just trying a bunch of stuff. Let me know if you think I'm on the right track. Because I haven't got a clue what I'm doing.


    In the \wcf\acp\templates folder I found bbcodeAdd.tpl, bbcodeList.tpl, bbcodeMediaproviderAdd.tpl, bbcodeMediaProviderList.tpl & bbCodeSelectOptionType.
    I also found SmileyList & SmileyAdd.tpl


    I presume I should alter one of those files in the same fashion as suggested in the phpbb link I provided.


    Anyone knows how exactly to do this?

    I'm just trying a bunch of stuff. Let me know if you think I'm on the right track. Because I haven't got a clue what I'm doing.


    In the \wcf\acp\templates folder I found bbcodeAdd.tpl, bbcodeList.tpl, bbcodeMediaproviderAdd.tpl, bbcodeMediaProviderList.tpl & bbCodeSelectOptionType.
    I also found SmileyList & SmileyAdd.tpl


    I presume I should alter one of those files in the same fashion as suggested in the phpbb link I provided.

    You can deactive per forum the posibility to count posts. If those spam forums are counted for posts then no points will be distributed.

    Ideally I would like to award them as well, but just a lot less.


    Do you have examples of communities that use that user trophy system? I would like to see the possibilities. Seems like it's what I'm looking for though, but since it costs €10 I can't really try it out.


    Jcoins seem indeed what I would like, going to play around with it.

    I want to be able to award the activity points more scpecific.
    We have "spam" parts on our forum where people talk about nonsense, and we have very dedicated & usefull content. I want to be able to award more activity points for posting in those specific subforums.
    Is that possible? Might there be a plugin that takes care of this?


    Secondary, I'm looking for a way to auto award badges if they complete certain tasks on the forum. So if you know a plugin that takes care of that, feel free to point me in the right direction. Because atm I'm kinda lost between the large amount of plug ins provided, since I'm not really used to the software yet.


    Tertiary, ultimately I want the users to be able to change those points into rewards. I saw a plugin "jcoins" and some extensions. Is this what it does?


    Would appreciate help :) Because after 13 years of basic vBulletin I'm excited about and both lost in the possibilities