E-Mail an alle Benutzer senden führt oft zu Gateway Timeout

  • Affected Version
    WoltLab Suite 5.4

    Hallo,


    ich habe einen externen E-Mail- Anbieter als SMTP eingerichet. Auch bei Registrierungen erhalte die User auch soweit ihre Aktivierungslinks.

    Wenn ich aber "E-Mail an alle Benutzer" senden möchte, bleibt es bei 0% und führt dann zu:

    Quote

    Gateway Timeout

    The gateway did not receive a timely response from the upstream server or application.

    Das muss ich dann bestätigen, dann bricht es ab und ich erhalte vom WSC die Meldung:


    Quote

    Die von Ihnen angeforderte Seite wurde nicht gefunden. Bitte überprüfen Sie die Adresse oder gehen Sie zurück auf die Startseite

    Unter Verwaltung > Emails steht das meiste auf "Versendet" und/oder "wartend".
    Wenn ich die Seite aktualisiere, scheinen auch die "wartend" durchzlaufen und andere stehen dann wieder auf "wartend".

    Ab einem gewissen Punkt hört es einfach auf. Nur um grob eine Zahl zu nennen von 200 Mitglieder erhalten vielleicht 20 eine Mail.


    Aber einige erhalten keine E-Mail.


    Woran "kann" das eventuell liegen?

    Beste Grüße

  • qBass17

    Changed the title of the thread from “E-Mail an alle Benutzer senden führ oft zu Gateway Timeout” to “E-Mail an alle Benutzer senden führt oft zu Gateway Timeout”.
  • Ich denke das liegt nicht an der Software. Vielleicht solltest du mal mit deinem Hoster reden, wie viele Emails per SMTP in so kurzer Zeit erlaub sind. IdR. werden sone Massen-Aktionen blockiert bzw. es kommt zu Abbrüchen und damit zu schlechter Zustellbarkeit.

    mfg

    moere

    Edited once, last by moere22 ().

  • Das habe ich als Antwort vom Hoster erhalten

    Wenn ich den Prozess noch einmal ausführe und die Fehlermeldung wieder erscheint, was schicke ich dem Hoster dann am besten zu ? Reicht der Fehler-Log aus dem WSC?

    Beste Grüße

  • Hallo,


    einen externen E-Mail- Anbieter als SMTP

    gibt es einen besonderen Grund dafür? Normalerweise empfiehlt es sich gerade für "Massenmails" ja eher, den eigenen Server dafür zu benutzen.



    Wenn ich aber "E-Mail an alle Benutzer" senden möchte, bleibt es bei 0%

    Weil dieser fremde Anbieter vermutlich (berechtigterweise) Probleme mit dieser massiven Flut an Mails hat und diese für SPAM bzw. evtl. Bot-Netz-Aktivitäten hält. Was ja auch nicht ganz abwegig ist.

    Auch auf Shared-Servern wird eine derartige Masse selten problemlos verschickt, oder nur in sehr kleinen Chargen und mit langer Verzögerung.

    Deshalb würde ich von dieser Funktion eher abraten bzw. wirklich auf das allernötigste beschränken. Also keine "wöchentlichen Newsletter" oder ähnliches.

    Es kann auch sehr helfen, einzelne Benutzergruppen zu filtern und nur denen diese Mails (nacheinander) zu senden. An "registrierte" würde ich sie nicht senden, wenn es mehr als 500 User in Deinem Forum sind, denn darin ist ja praktisch Jeder.


    Ich habe gerade nicht vor Augen, ob man diese Chargen (wie im vBulletin) auch im WL selber aufteilen kann. Wenn ja, wähle mal Zahlen um die (maximal) 200 Mails pro Charge. Das hilft auch schon sehr und macht auch den Hoster nicht sofort "stutzig".

    Bei ca. 500 bekam ich vor Jahren schon mal eine "freundliche Anfrage" eines Hosters, was an dem Tag los war und ob das wirklich gewollt war.

    Gruß

    Jörg

    (Jaydee)

  • gibt es einen besonderen Grund dafür?

    Ja, weil nicht jeder davon Ahnung hat und dazu kommt noch die ganze Absicherung.
    Es gibt zig Anleitungen... Aber welche ist in soweit korrekt, dass man sich dabei sicher sein kann? Und die meisten sind auch nicht wirklich vollständig was die ganze Konfigurationen betrifft.


    Weil dieser fremde Anbieter vermutlich (berechtigterweise) Probleme mit dieser massiven Flut an Mails hat und diese für SPAM bzw. evtl. Bot-Netz-Aktivitäten hält. Was ja auch nicht ganz abwegig ist.

    Ich werde den Anbieter dann auch dazu noch einmal befragen.

    Danke


    LG

    Beste Grüße

  • Ich werde den Anbieter dann auch dazu noch einmal befragen.

    Danke

    Das wird der beste/einzige Weg sein, ja. Er kennt den Grund (und seine definierten Grenzen) ja am ehesten.


    Ein weiteres Indiz, dass es daran liegt, ist auch dass die normalen "System-Mails" ja klaglos durchgehen (eben weil sie "einzeln" versendet werden).

    Gruß

    Jörg

    (Jaydee)