Dropdownmenü in mobiler Version geht nicht

  • Affected Version
    WoltLab Suite 5.4

    Moin,

    Wenn ich in meinem Forum in der mobilen Version das Hauptmenü(Dropdown) öffnen möchte bekomme ich keine Reaktion.

    Das gleiche im ACP dort wird einfach nur der ganze Bildschirm blau.

    Das was ich bis jetzt zu solchen Themen gefunden habe, hat entweder nicht geholfen oder wurde nicht beantwortet.

    Hier im Woltlabforum geht's ja offensichtlich.


    Wurde getestet auf:

    Pixel 5 Chrome

    P30 lite Chrome

    IPhone 10 Safari

    Chrome Webansicht auf win10


    Kann mir da jemand helfen?

  • Go to Best Answer
  • Also die Konsole in Chrome gibt mir folgenden Issue: DevTools failed to load source map: Could not load content for https://***.de/proxy_sourcemap.php?mKtaRSkXCezAWscEWWkOKYifHE…L0nfQ/WCF/d6ee4d4…: Load canceled due to load timeout

  • Hast du den Debug-Modus im ACP an gemacht?

    Luca heißt mein 🐶 👀 Den könnt ihr hier nicht besuchen 🤷‍♂️ Das ist mein 🐶 den ich nicht mit Fremden wie euch teile☝️

  • Also bei mir geht das Dropdown Menü schon auf.... Aber es ist leer ^^

    Ja, scheint wohl vom Handy abhängig zu sein auf meinem Pixel 5 und dem Chrome Emulator ist's auch so


    Ich würde auf ein CSS Problem tippen.

    Und was kann ich da probieren? Habe bereits mal den Standard Stil genutzt, was auch nichts geändert hat.

  • Ich denke, wenn du die Seite hier postest, und man nicht über Social-Engineering sie suchen muss, fällt es den passenden Leuten einfacher dir zu helfen.

    Projekte:

    XIVDATA - Eorzea Database


    A red dragon falls from the heavens... Ah, that memory has been lost. A shame. It was a favorite of mine...


  • Okay, du hast sie ja scheinbar schon gefunden :D handelt sich um (Link entfernt)

    Habe gerade mal ne frische Installation woanders aufgesetzt, dort geht es scheinbar, auch mit den gleichen Plugins :/

    Ist aber logischerweise nicht meine bevorzugte Methode.

    • Best Answer
    • Official Post

    Die Ursache ist ungültiges HTML, konkret ein Link der geöffnet, aber nicht geschlossen wird.


    Im Copyright am Seitenende wurde eigenes HTML/JavaScript eingefügt, dies ist aber ungültig. Als Folge davon generiert der Browser stumpf weitere Links in das HTML und zerstört dabei die Struktur des nachfolgenden HTML, u.a. das mobile Menü befindet sich danach.

    Alexander Ebert
    Senior Developer WoltLab® GmbH