Update von 5.3 auf 5.4 - Unterstützung für WebP-Grafiken in Imagick fehlt

  • Affected Version
    WoltLab Suite 5.4

    Nach dem Klicken auf die Infobox im Acp erfolgt bei mir folgende Meldung:

    Quote

    Unterstützung für WebP-Grafiken in Imagick fehlt

    Wie genau gehe ich jetzt vor?

  • Habe den selben Fehler :(

    Wenn Du zu viele Überstunden machst, organisiert Du Deine Arbeit falsch.
    Wenn Dein Boss zu viele Überstunden macht, opfert er sich für das Unternehmen
    auf.

  • Bei mir auch.


    Unterstützung für WebP-Grafiken in GD fehlt


    Betrifft aber die neue Version nicht die Beta.


    Erledigt, lag an PHP 7.3. bei 7.4 klappt es

    • Official Post

    Die Meldung deutet darauf hin, dass eine stark veraltete Version von Imagick auf dem Server zum Einsatz kommt. Das Problem kann nur der Webhoster beheben. Alternativ kann die genutzte Grafik-Bibliothek in den Einstellungen der WoltLab Suite auf "GD" umgestellt werden.

  • Wie genau gehe ich jetzt vor?

    Falls du keinen eigenen Server betreibst, musst du dich an deinen Hoster wenden. MIt der Suchfunktion findest du einige Beiträge zu dem Thema.


    lg,

    Chris


    edit: da ich wohl zu langsam...

  • Bei mir geht es auch nicht mit PHP 7.4 .....wieso

  • Dann erscheint nämlich selbige Meldung.

    Genau da kannst umstellen wie willst Du die Meldung bleibt die Alte

    Wenn Du zu viele Überstunden machst, organisiert Du Deine Arbeit falsch.
    Wenn Dein Boss zu viele Überstunden macht, opfert er sich für das Unternehmen
    auf.

  • Hallo zusammen,

    ich habe auch PHP 7.4 drauf und wenn ich mir die PHP Info aufrufe sind auch alle Sachen enabled.


    Trotzdem erhalte ich immer noch den Fehler. Hat jemand eine Idee?

  • Huhu zusammen,


    Ich denk nicht das es damit zu tun hat. Aber ich hatte das gleiche Problem nach dem ich auf php8 gestellt hatte war es weg.

    Wieso auch immer..

    Mein Anbieter ist: lima-city

    Kleiner Nachtrag:

    Ich verwende auch gd.

    • Official Post

    Mit dem Update 5.4.1 werden wir den Vorgang so anpassen, dass ImageMagick (bzw. "Imagick") nur geprüft wird, wenn dies auch ausgewählt ist. Andernfalls ist die GD-Bibliothek mit WebP-Unterstützung vollkommen ausreichend.


    Dessen ungeachtet handelt es sich seit vielen Jahren um eine Standardfunktion (!) von GD und ImageMagick. Offenbar gibt es eine Reihe an defekten Varianten dieser PHP-Erweiterung, hier sollte der Hosting-Anbieter angesprochen werden, damit dieser den Fehler korrigieren kann.

  • Dessen ungeachtet handelt es sich seit vielen Jahren um eine Standardfunktion (!) von GD und ImageMagick.

    Gerade Server Systeme werden aber häufig mit älteren, "stabilen" LTS-Versionen betrieben, was bei Servern ja durchaus auch gewünscht ist. Beispielsweise hatte ich einen Ubuntu 18 LTS Server mit php 7.4, wo WebP zumindest für ImageMagick nicht vorhanden war. Und für php 8.0 ist ImageMagick AFAIK noch gar nicht offiziell verfügbar.


    Für mich ist dies nun kein Problem, da ich schlichtweg das komplette System mit allen Paketen aktualisieren konnte.

    Gruß aus Südhessen

    • Official Post

    Beispielsweise hatte ich einen Ubuntu 18 LTS Server mit php 7.4, wo WebP zumindest für ImageMagick nicht vorhanden war. Und für php 8.0 ist ImageMagick AFAIK noch gar nicht offiziell verfügbar.

    ImageMagick unterstützt WebP seit März 2011. Eigentlich sollte man annehmen, dass 10 Jahre ausreichend sind, um so etwas korrekt zu berücksichtigen.

    • Official Post

    Also ich habe nun auch mal auf PHP 8 umgestellt und habe dort die gleiche Fehlermeldung. In meiner Info Datei ist aber alles drinnen. Oder hab ich was übersehen?

    Nein, ImageMagick ("imagick") verfügt über kein WebP, die GD-Bibliothek aber schon. Mit dem kommenden Update werden wir es so ändern, dass bei ausgewählter GD-Bibliothek auch nur diese überprüft wird, so dass ImageMagick keine Rolle spielt, da man nur eines von beidem benötigt.