Will MySQL 5.7.31 be a prerequisite for 5.4?

  • Affected Version
    WoltLab Suite 5.4 (Beta)

    I use GoDaddy for my hosting (shared) and I was installing the 5.4 beta in a sub domain when the MySQL error came up. I then contacted GoDaddy to ask about upgrading from MySQL 5.6 to 5.7, but the answer was a bit vague. I'll be contacting them again to see if they have a server-wide plan for updating to 5.7 or higher, but in the meantime I'd like to know if this will impede my WoltLab upgrade path in the future if GoDaddy don't upgrade MySQL.

    • Official Post

    We require one of these:

    • MySQL 5.7.31 or newer
    • MySQL 8.0.19 or newer
    • MariaDB 10.1.44 or newer


    To put this in perspective:

    • MySQL 5.6 was first released on 5 February 2013
    • MySQL 5.7 was first released on 21 October 2015
    • MySQL 5.7.31 was released on 13 July 2020


    It's not like we're asking for bleeding edge software by any means.

    Alexander Ebert
    Senior Developer WoltLab® GmbH