Error während Update von 3.0 auf 3.1

  • Affected Version
    WoltLab Suite 3.0

    Hallo, eigentlich möchte ich am Ende auf die neuste Version updaten aber man soll es ja mit Zwischenschritten machen. Ich wollte zuerst auf 3.1 updaten und dann erhalte ich sobald ich nun auf Updates suchen klicke folgenden Fehler:


    • Error Type:

      wcf\system\exception\ErrorException

    • Error Message:

      Use of undefined constant ENABLE_DEVELOPER_TOOLS - assumed 'ENABLE_DEVELOPER_TOOLS' (this will throw an Error in a future version of PHP)

    • File:

      */lib/system/WCF.class.php (335)

    • Stack Trace:
      • #0 */acp/templates/compiled/0_wcf_1_packageUpdate.php (65):
      • wcf\system\WCF::handleError(2, 'Use of undefined constant ENABLE_DEVELOPER_TOOLS - assumed \'ENABLE_DEVELOPER_TOOLS\' (this will throw an Error in a future version of PHP)', '*/acp/templates/compiled/0_wcf_1_packageUpdate.php', 65, [ 7 items ])
      • #1 */lib/system/template/TemplateEngine.class.php (320):
      • include('*/acp/templates/compiled/0_wcf_1_packageUpdate.php')
      • #2 */lib/page/AbstractPage.class.php (308):
      • wcf\system\template\TemplateEngine->display('packageUpdate', 'wcf')
      • #3 */lib/acp/page/PackageUpdatePage.class.php (60):
      • wcf\page\AbstractPage->show()
      • #4 */lib/page/AbstractPage.class.php (103):
      • wcf\acp\page\PackageUpdatePage->show()
      • #5 */lib/system/request/Request.class.php (83):
      • wcf\page\AbstractPage->__run()
      • #6 */lib/system/request/RequestHandler.class.php (94):
      • wcf\system\request\Request->execute()
      • #7 */acp/index.php (9):
      • wcf\system\request\RequestHandler->handle('wcf', true)


    Woran kann das liegen? Das Update war übrigens nicht erfolgreich. Ein Backup habe ich vorher gemacht.

    Danke im Voraus



    Mit freundlichen Grüßen

  • Hallo,


    die Meldung kommt, sobald du in der noch bestehenden WSC 3.0 - Installation nach Updates suchst, richtig? Oder sobald das Update auf die 3.1 durchgelaufen ist und du erneut nach Updates suchst?


    Kannst du mal bitte den Inhalt der Datei WSC_INSTALLATIONSVERZEICHNIS_/acp/templates/packageUpdate.tpl sowie /acp/templates/compiled/0_wcf_1_packageUpdate.php posten?

  • Installation nach Updates suchst, richtig

    Genau


    Die packeUpdate

    0_wcf_1_packageUpdate


    Grüße

  • Jetzt nochmal bitte die Datei WSC_INSTALLATIONSVERZEICHNIS_/acp/templates/header.tpl. Aus irgendeinem Grund scheint diese Datei bereits aus einer späteren Suite-Core-Version (3.1) zu stammen, obwohl du diese ja erst installieren willst. Ist mir gerade unverständlich, wieso das ACP überhaupt bisher funktioniert, denn mit der Funktion "Nach Update suchen" ist der Update-Prozess ja noch nicht gestartet.

  • Okay, das klingt wirklich komisch.

    Hier ist der Inhalt:

  • Habe ich gemacht, zeigt leider keine Wirkung. Ich erstell ein Ticket und poste dann hier die Lösung falls das Problem noch jemand hat.

    Danke dir trotzdem


    Grüße