Sofortige Email-Benachrichtigung

  • Affected Version
    WoltLab Suite 5.2

    Hallo Zusammen,


    wir haben die Einstellungen im ACP für die Benachrichtigungen für das Forum wie folgt gesetzt (wird korrekt im Benutzerprofil so auch angezeigt):



    Jedoch werden auch wie hier beschrieben, die Nachrichten nicht direkt verschickt. In der Warteschlange unter /index.php?background-queue-perform ist auch nichts drin und dort wird nur eine 0 angezeigt. Der Versand der Mails ist über SMTP eingerichtet und funktioniert auch an alle Nutzer perfekt. Jedoch kommen die Benachrichtigungen z.B. bei einem neuem Forumpost einfach nicht. Wo kann man denn da noch nachschauen bzw. nachjustieren :/?


    Vielen Dank.


    Shorty

    VG Shorty

  • Jedoch kommen die Benachrichtigungen z.B. bei einem neuem Forumpost einfach nicht.

    "Nicht", oder einfach nur zeitverzögert? Denn je nach Auslastung (gerade des Mail-Servers) kann das ja schon mal etwas versetzt geschehen.

    Allerdings sollten sich entsprechende Mails dann zumindest in der Queue befinden.

    Wenn dort Null angezeigt wird wie Du schreibst, ist das in der Tat schon eigenartig.


    Also die Forenmails werden alle über SMTP verschickt und der Rest kommt normalerweise auch an? Nur die Benachrichtigungen nicht?

    Wie zeitnah kommen denn die restlichen Benachrichtigungen ("Glocke") zu denselben Ereignissen an? Vielleicht kann man es damit etwas eingrenzen bzw. das System schon mal ausschließen.

    Gruß

    Jörg

    (Jaydee)

  • Also die Forenmails werden alle über SMTP verschickt und der Rest kommt normalerweise auch an? Nur die Benachrichtigungen nicht?

    Wie zeitnah kommen denn die restlichen Benachrichtigungen ("Glocke") zu denselben Ereignissen an? Vielleicht kann man es damit etwas eingrenzen bzw. das System schon mal ausschließen.

    naja, es kommen nur die manuellen Mails vom ACP an alle Benutzer an. Der Rest nicht. Auch eine Mail an den einzelnen Benutzer aus dem ACP geht nicht raus. Im Mailserver kommt dort auch keine entsprechende Anfrage vom Server an. Schicke ich jedoch eine Mail im ACP an alle Nutzer kommt diese sofort an.

    Und wie schon geschrieben, in der Warteschlange ist nichts zu sehen.:/

    VG Shorty

    Edited 2 times, last by _shorty ().

  • Hallo Jörg,


    cronjobs sind soweit ok. Ich habe aber noch etwas herausgefunden.


    Im Forum wird aktuell nur der letzte Benutzer benachrichtigt, der einen Beitrag geschrieben hat, obwohl alle Nutzer (in diesem Fall 3 Testbenutzer mit Email-Adresse) das Thema abonniert haben.

    Aber das denke ich ist nur eine Einstellung.


    Ich behalte das mal im Auge.;)

    VG Shorty

    Edited once, last by _shorty ().

  • Vielleicht muss ich hier trotzdem nochmal einhaken. Die Benachrichtigungen kommen nun zwar, aber nur für den Nutzer der zu letzt auf das Thema im Forum geantwortet hat.


    folgendes Beispiel


    Nutzer A erstellt ein Thread und abonniert damit automatisch das Thema

    Nutzer B antwortet darauf, abonniert es automatisch und Nutzer A bekommt eine Nachricht über einen neuen Eintrag.

    Nutzer C antwortet auf das Thema, Nutzer B bekommt die Mail, aber Nutzer A nicht.


    Die Einstellungen werden für alle Nutzer global, wie oben gezeigt, festgelegt.

    VG Shorty

  • Nutzer B antwortet darauf, abonniert es automatisch und Nutzer A bekommt eine Nachricht über einen neuen Eintrag.

    Nutzer C antwortet auf das Thema, Nutzer B bekommt die Mail, aber Nutzer A nicht.

    Hat denn Nutzer A seit der Benachrichtigung über den neuen Beitrag von Nutzer B das Forum / den Eintrag erneut aufgerufen? Das müsste er, um weitere Benachrichtigungen über Beiträge anderer Nutzer zu erhalten.

    Viele Grüße,

    smers