Install and update error

  • Affected Version
    WoltLab Suite 5.2

    How to fix it?


    Can't install or update over web interface... =/


    Firewall is OK, double checked.


    Is there any config that I must change at Apache's httpd-ssl.conf file?

    Best Regards,
    Evandro (aka e.meneses)


    Help translate Woltlab: I'm in!

  • Just out of curiosity. What did you check?

    Besides disable it at all...


    Code
    openssl s_client -connect google.com:443 -state
    openssl s_client -connect update.woltlab.com:443 -state

    The first one works great. Trying to connect to woltlab server, got an error.



    Is allow_url_fopen enabled? (php.ini)

    Yes, it is.

    Code
    allow_url_fopen = On


    Do you use Plesk?

    No, I don't. It's my localhost. Just Apache and MySQL... Nothing else.

    Best Regards,
    Evandro (aka e.meneses)


    Help translate Woltlab: I'm in!

  • Is there the possibility that the files when uploaded where under a root or elevated user? I had that problem once, your non-sudoed user wont have access to overwrite files.

  • Is there the possibility that the files when uploaded where under a root or elevated user? I had that problem once, your non-sudoed user wont have access to overwrite files.

    It doesn't even download the file... Anyway, when I upload the files it's works fine so I guess it's not the problem.


    In my case, I explicitly allow Apache for outbound/inbound connections and updates will work fine. Using WCF here for firewall rules.

    Yes... But for some reason it doesn't work at all. All ports are open... Apache has no restrictions at all.



    BTW... Is there any place that I can download update files for Core?

    Best Regards,
    Evandro (aka e.meneses)


    Help translate Woltlab: I'm in!

    Edited once, last by e.meneses ().