Pre-upgrade questions

  • Affected Version
    WoltLab Suite 5.2

    I'm excited to see that 5.2 has been released and I'm planning to upgrade in the next few days, once I've done some tidying up.

    Is it best to update all the plugins first prior to upgrading, assuming that they are all compatible? Or just select all updates and hit submit?

    Would a database back up and full home directory back up from within CPanel be sufficient in case they are needed? That's where I usually do my back ups anyway.

    Many thanks for the help.

    8)

  • Is it best to update all the plugins first prior to upgrading, assuming that they are all compatible? Or just select all updates and hit submit?

    Some updates do not require 5.2, so these can and should be installed first. The easiest way to do this is to disable those update servers for 2019 and run the update, once there is nothing left, proceed with the upgrade. The upgrade requires all available updates to be selected, because they need to be applied in the same process.


    Would a database back up and full home directory back up from within CPanel be sufficient in case they are needed? That's where I usually do my back ups anyway.

    This should be fine.

    Alexander Ebert
    Senior Developer WoltLab® GmbH

  • Is this a paid upgrade and if so, what is the cost? Or is it free to existing 3.1 users?

    This is a paid upgrade. However, starting with WoltLab Suite 5.2 each license, including those upgraded from Burning Board 4.0 or newer, will receive all new versions that are released within one year. Please see Sales Launch and Pricings of WoltLab Suite 5.2 to learn more.


    I'm sure I saw that Link Preview is part of the new 5.2 forum, although I may be mistaken.

    There had been plans at one point, but these have been postponed for now due to legal concerns, in particular in regards to the EU Directive 2019/790 (Directive on Copyright in the Digital Single Market), which is still pending to be implemented by the member states.

    Alexander Ebert
    Senior Developer WoltLab® GmbH

  • I had a look at the EU directive aka Article 13, I believe and it's so intentionally vague and obfuscating that it doesn't make any sense at all. Yet there is an implication that a preview of a URL is in some way a copyright infringement which as we all know, is nonsense. Or is it that they're making a stand against fake news?

    A YouTube clip embedded in a post or website could therefore be constituted as a copyright infringement since it's a preview just like a preview of a BBC site or any other snippet.

    I don't need to ask permission from Google to embed a YouTube video or CNN to embed a news story? Or do I?

    Quote


    memes and GIFs are now specifically excluded from the directive and start-up platforms are subject to lighter requirements.

    Well, there's a relief! (sarcastic)

  • I' ve just bought the forum and gallery upgrades, updated all the plugins and those that were preventing the upgrade have been deleted.

    The only obstacle now is the CLS Design Nexus Blue style which is our default theme and I cannot remove this (?)


    CLS have a guide which is only in German but I've translated it into English and even then, it's difficult to follow.

    There is no compatibility for 5.2 when uploading the new style for 5.2.

    https://www.cls-design.com/styleupdate/

    How should I proceed to update the style without losing all the style settings?

  • There appears to be an updated version available for that style, have you set up their package servers so it can fetch the updated version?

    Alexander Ebert
    Senior Developer WoltLab® GmbH

  • Nothing has to be done manually in regard to the style to have it working, because this has nothing to do with the style. The package that is being reported is the wrapper around the actual style, it is all about that package, not the style! Ask them to provide you with instructions how to properly gain access to the update, that's all that needs to be done.

    Alexander Ebert
    Senior Developer WoltLab® GmbH

  • In the end we came up with a manual solution to the theme issue by deleting the style (theme) and associated templates, upgrading the forum to 5.2, then installing the style 5.2 package and importing my original which I had exported, which Tom at CLS manually updated at his end and sent back to me.

    The forum upgrade went through after five attempts which I suspect may have been a Godaddy issue and I'm pleased to say that the forum is now up and running smoothly on 5.2.8.

    This software must be quite robust.

  • Glad to hear that it's working for you :) We're always looking into opportunities to optimize parts of the software to further increase the speed, it's always nice to hear when that effort pays off!

    Alexander Ebert
    Senior Developer WoltLab® GmbH