Fehler bei Update auf 5.2 RC2 [error.databaseChange]

  • So nochmals ein Test gemacht mit meiner Installation aber erhalte beim starten des Updates (Core) bei 2% unten stehende Fehlermeldung.


    Requested URL
    /acp/index.php?install-package/&t=65fac2767ae271d6b497969c5686021c662c6ecd
    Referrer
    https://domain.com/acp/index.php?package-update/
    Error Message
    wcf.acp.package.error.databaseChange
    Type
    RuntimeException
    File (Line)
    /var/www/vhosts/domain.com/httpdocs/XXX_wsc/lib/system/database/table/DatabaseTableChangeProcessor.class.php (960)
    Stacktrace
    1. /var/www/vhosts/domain.com/httpdocs/XXX_wsc/acp/update_com.woltlab.wcf_5.2.php (212): wcf\system\database\table\DatabaseTableChangeProcessor->process(…)
    2. /var/www/vhosts/domain.com/httpdocs/XXX_wsc/lib/system/package/plugin/ScriptPackageInstallationPlugin.class.php (72): include(…)
    3. /var/www/vhosts/domain.com/httpdocs/XXX_wsc/lib/system/package/plugin/ScriptPackageInstallationPlugin.class.php (50): wcf\system\package\plugin\ScriptPackageInstallationPlugin->run(…)
    4. /var/www/vhosts/domain.com/httpdocs/XXX_wsc/lib/system/package/plugin/AbstractPackageInstallationPlugin.class.php (70): wcf\system\package\plugin\ScriptPackageInstallationPlugin->install(…)
    5. /var/www/vhosts/domain.com/httpdocs/XXX_wsc/lib/system/package/PackageInstallationDispatcher.class.php (673): wcf\system\package\plugin\AbstractPackageInstallationPlugin->update(…)
    6. /var/www/vhosts/domain.com/httpdocs/XXX_wsc/lib/system/package/PackageInstallationDispatcher.class.php (144): wcf\system\package\PackageInstallationDispatcher->executePIP(…)
    7. /var/www/vhosts/domain.com/httpdocs/XXX_wsc/lib/acp/action/InstallPackageAction.class.php (73): wcf\system\package\PackageInstallationDispatcher->install(…)
    8. /var/www/vhosts/domain.com/httpdocs/XXX_wsc/lib/action/AbstractDialogAction.class.php (68): wcf\acp\action\InstallPackageAction->stepInstall(…)
    9. /var/www/vhosts/domain.com/httpdocs/XXX_wsc/lib/action/AbstractAction.class.php (47): wcf\action\AbstractDialogAction->execute(…)
    10. /var/www/vhosts/domain.com/httpdocs/XXX_wsc/lib/system/request/Request.class.php (83): wcf\action\AbstractAction->__run(…)
    11. /var/www/vhosts/domain.com/httpdocs/XXX_wsc/lib/system/request/RequestHandler.class.php (96): wcf\system\request\Request->execute(…)
    12. /var/www/vhosts/domain.com/httpdocs/XXX_wsc/acp/index.php (9): wcf\system\request\RequestHandler->handle(…)

    Gruss Grischabock

    Plugins | Stile | Support | Blog | Technik | Review | Gaming | Creative | Streaming | NinoxDB | Shop | Marktplatz

    GrischaNetwork.com

    • Official Post

    Auf welche Version wurde versucht zu aktualisieren? Die Sprachdateien werden beim Update noch vor dem Durchlauf der SQL-Änderungen aktualisiert, daher ergibt die Fehlermeldung für mich so keinen Sinn.

  • Requested URL
    /acp/index.php?install-package/&t=0305de09c3e9b03972c43d6ea143f7e455b4b148
    Referrer
    https://www.beta.die-legionaere.de/acp/index.php?package-update/
    Error Message
    wcf.acp.package.error.databaseChange
    Type
    RuntimeException
    File (Line)
    /var/www/vhosts/xxx-xxx.de/beta.xxx-xxx.de/de/lib/system/database/table/DatabaseTableChangeProcessor.class.php (960)
    Stacktrace
    1. /var/www/vhosts/xxx-xxx.de/beta.xxx-xxx.de/de/acp/update_com.woltlab.wcf_5.2.php (212): wcf\system\database\table\DatabaseTableChangeProcessor->process(…)
    2. /var/www/vhosts/xxx-xxx.de/beta.xxx-xxx.de/de/lib/system/package/plugin/ScriptPackageInstallationPlugin.class.php (72): include(…)
    3. /var/www/vhosts/xxx-xxx.de/beta.xxx-xxx.de/de/lib/system/package/plugin/ScriptPackageInstallationPlugin.class.php (50): wcf\system\package\plugin\ScriptPackageInstallationPlugin->run(…)
    4. /var/www/vhosts/xxx-xxx.de/beta.xxx-xxx.de/de/lib/system/package/plugin/AbstractPackageInstallationPlugin.class.php (70): wcf\system\package\plugin\ScriptPackageInstallationPlugin->install(…)
    5. /var/www/vhosts/xxx-xxx.de/beta.xxx-xxx.de/de/lib/system/package/PackageInstallationDispatcher.class.php (673): wcf\system\package\plugin\AbstractPackageInstallationPlugin->update(…)
    6. /var/www/vhosts/xxx-xxx.de/beta.xxx-xxx.de/de/lib/system/package/PackageInstallationDispatcher.class.php (144): wcf\system\package\PackageInstallationDispatcher->executePIP(…)
    7. /var/www/vhosts/xxx-xxx.de/beta.xxx-xxx.de/de/lib/acp/action/InstallPackageAction.class.php (73): wcf\system\package\PackageInstallationDispatcher->install(…)
    8. /var/www/vhosts/xxx-xxx.de/beta.xxx-xxx.de/de/lib/action/AbstractDialogAction.class.php (68): wcf\acp\action\InstallPackageAction->stepInstall(…)
    9. /var/www/vhosts/xxx-xxx.de/beta.xxx-xxx.de/de/lib/action/AbstractAction.class.php (47): wcf\action\AbstractDialogAction->execute(…)
    10. /var/www/vhosts/xxx-xxx.de/beta.xxx-xxx.de/de/lib/system/request/Request.class.php (83): wcf\action\AbstractAction->__run(…)
    11. /var/www/vhosts/xxx-xxx.de/beta.xxx-xxx.de/de/lib/system/request/RequestHandler.class.php (96): wcf\system\request\Request->execute(…)
    12. /var/www/vhosts/xxx-xxx.de/beta.xxx-xxx.de/de/acp/index.php (9): wcf\system\request\RequestHandler->handle(…)

    Ich habe das ganze jetzt nochmal nach gestellt.


    So sieht der Sprachen-Cache vor dem Update-Versuch aus:




    Die Datei sieht vor dem Update-Versuch so aus (1_wcf.acp.package.php)


  • Konnte hier etwas gefunden werden? Habe auch noch selbes Problem und kann nicht Updaten

    Gruss Grischabock

    Plugins | Stile | Support | Blog | Technik | Review | Gaming | Creative | Streaming | NinoxDB | Shop | Marktplatz

    GrischaNetwork.com

  • Alexander Ebert

    Set the Label from Feedback required to Fixed