Update von 4.0 auf 5.1 bzw auf die Suite 3.1

  • Hi,


    ich habe vor unser WBB 4.0 auf das WBB 5.1 bzw. die Suite 3.1 upzudaten.

    Aktuell ist noch PHP 5.2.17


    Ich bin mir nicht ganz sicher, wie genau ich vorgehen soll :/

    Könnt ihr mir dafür bitte Tips geben, wie ich vorgehen soll?
    Also wann ich auf welche Version und wann auf welche PHP-Version switchen muss, damit am Ende das Forum / die Suite läuft?


    Ich wäre sehr dankbar für Eure Hilfe. ;)

    Vielen Dank!


    Lieben Gruß

  • Hier mal die Mindestanforderungen für den Betrieb eines WSC 3.1:


    * Ein Webserver mit PHP 5.5.4 oder höher

    * Folgende PHP-Erweiterungen werden benötigt: mbstring, libxml, dom, zlib, pdo, pdo_mysql, json, pcre

    * Der PHP Safe Mode muss deaktiviert sein

    * Eine MySQL-Datenbank in Version 5.5.35 oder neuer / alternativ MariaDB 10.0.22 oder neuer, jeweils mit InnoDB Unterstützung

    * Ca. 20 MB Festplattenspeicher

    * Ein FTP-Programm, um die Programmdateien auf den Webserver/Webspace zu laden


    Bezüglich PHP empfiehlt sich allerdings eine aktuellere Version (7.x).





    Gruß norse

  • Du könntest mit PHP 5.6 anfangen, das können sowohl das Burning Board 4.0 als auch die WoltLab Suite. Du wirst letztendlich drei Upgrades machen müssen, von WCF 2.0 / Burning Board 4.0 auf die Version 2.1 / 4.1 und dann auf die WoltLab Suite 3.0. Ab da dann noch eine Stufe weiter auf die WoltLab Suite 3.1, das ist momentan das aktuellste.


    Klickst du hier oben auf der Seite auf Hilfe gibts haufenweise Material und Lesestoff dazu. Am besten fängst du mit einem Backup an, daraus baust du dir dann eine Testinstallation („Umzug“) mit der du das Upgrade testen kannst. Die einzelnen Schritte für die Upgrades sind dort auch beschrieben. Wenn’s mal klemmt, helfen wir, wenn du konkrete Situationen schilderst und mit Fehlermeldungen und Co. untermauerst.

    Bedenke, dass es Sinn machen kann, noch bis Ende des Jahres auf die Suite 3.2 zu warten; du hast bisher nicht das neuste gehabt, also kommt es auf ein paar Monate vermutlich auch nicht an, aber du sparst dir einmal die Upgradekosten. Nur die PHP-Version würde ich vorher nach Möglichkeit anheben; 5.6 sollte das WBB 4.0 können, bei 7.x bin ich mir nicht sicher, aber ich glaube nicht.

  • Hi,


    Also ich habe nun Die neue Suite einfach installiert und das alte dann importiert.

    Das war der einfachste Weg. Auch mit PHP ging das dann ohne Aufhebens.

    Trotzdem vielen Dank an Euch für Eure Tips!


    Allerdings habe ich noch eine Frage zu einer Meldung, die ich im ACP bekomme:

    Quote
    Der Paket-Server für „maelstrom“ („http://store.woltlab.com/maelstrom/“) wurde noch nicht abgefragt, bitte lassen Sie zuerst nach Updates suchen, um den Server abzufragen.

    Ich habe mehrmals nach Updates gesucht, aber es ändert nichts!

    Habt ihr ne Idee, wie ich den Server zum Laufen bekomme?


    Vielen Dank!