WoltLab Suite 5.2 Beta 2 Download

  • Introducing WoltLab Suite 5.2, the next big step in the history of community and forum solutions and successor of the previous WoltLab Suite 3 series.

    System Requirements

    WoltLab Suite 5.2 requires the following prerequisites to install and run the software:


    • Webserver with PHP 7.0.22 or newer (PHP 7.3+ recommended)
    • MySQL 5.5.35 (or newer) / MariaDB 5.5.47 (or newer) / MariaDB 10.0.22 (or newer)
    • 20 MB free disk space
    • Current Webbrowser (Chrome 76+, Firefox 68+, Safari 12+, Microsoft Edge 44+ [EdgeHTML 18+])

    Installation Guide

    1. Download the installation archive onto your computer.
    2. Extract the archive.
    3. Upload the files install.php, test.php and WCFSetup.tar.gz onto your webserver.
    4. Start the installation by navigating with your webbrowser to the test.php.

    Updating from earlier versions

    This beta version explicitly does not support updating from WoltLab Suite 3.x, update support will be added with future releases.

    Usage and Support

    This evaluation version is not suitable for use in production environments, doing so is entirely at your own risk. An update from WoltLab Suite 5.2 Beta 2 to future versions is not guaranteed. You may use the apps until December 6th, 2019, if you would like to continue using this software past this date, you'll have obtain a valid product license.


    We're looking forward to hear your feedback and report of possible issues in this forum.

    Version Number Changes

    The forum app historically used a much higher version number, which wasn't ideal at all times. Starting with this release, all our products have been bumped up to version 5.2.



    Download WoltLab Suite Forum 5.2 Beta 2

    Download WoltLab Suite Blog 5.2 Beta 2

    Download WoltLab Suite Calendar 5.2 Beta 2

    Download WoltLab Suite Gallery 5.2 Beta 2

    Download WoltLab Suite Filebase 5.2 Beta 2