Teaser shown in article while be better not shown

  • Hello,

    This is my website and I use WSC 3.1.10 pl 2:


    In this article, I have written a teaser to show in the home page but I see that it's still shown in the article page itself which causes to add an extra paragraph.


    Could you help me how to prevent teaser being shown in the article page? I have not found any options in ACP.

    P.N: I think it's called teaser as I see 'wcf.acp.article.teaser' in the phrases corresponds to my translated string. In WordPress it's called Excerpt, so if I'm wrong, then I mean this phrase and definition.

    Thanks in advance

  • Hello,

    The teaser is always shown at the top of the article, so you have two options:

    1. Keep the teaser and incorporate it into your article. In your example above the content contains the teaser text again, just remove the first paragraph from your content.
    2. Remove the teaser, it will then be automatically generated from the article itself based on a fixed number of characters.

    Alexander Ebert
    Senior Developer WoltLab® GmbH

  • Hello,

    Thanks for the reply Alexander Ebert

    I should think about the first one you have mentioned later, but regarding the latter, I have removed the teaser and now in the main page of my site I see that lots of characters are considered as that 'fixed number of characters'.


    I'm afraid I cannot find any options to change this number in ACP.

    As the teaser's style is bold, I prefer to lessen the numbers of characters fetching from the article.

  • Thanks for your suggestion, we'll look into this and see if we can find a better solution for this in the future.

    Alexander Ebert
    Senior Developer WoltLab® GmbH