How to make the word "Blog" plural

  • Hi PJK , well, I have this problem like everyone else.

    Interesting thing according to renaming for the reason that I also renamed most apps since WBB 4.1.

    App blog to blogs:

    (ACP - Configuration - Packages - Manage Apps - Path) plus

    ACPContentSitesBlog list / example.com/blogs/blog-list/Content


    In Gallery, however, the way for site renaming is different, especially for displaying the apps name in the browsers top bar:

    App gallery to photos

    (ACP - Configuration - Packages - Manage Apps - Path) plus

    ACPCustomizationLanguagesManage Phrases Search for gallery.image.images - Rename Images to Photos and

    ACPCustomizationLanguagesManage Phrases Search for gallery.image.imagesAndVideos - Rename Images{if GALLERY_VIDEO_UPLOAD | | GALLERY_VIDEO_LINKS} Videos{/if} to Photos{if GALLERY_VIDEO_UPLOAD | | GALLERY_VIDEO_LINKS} 📸 Videos{/if}


    All these changes are safe/resistent for updates/upgrades!


    Edit: In my profile is my .com, where the changes are visible.

  • Thank you Dukemaster for taking the time to share this information to all of us who regularly look over these Threads and Posts here on the Woltlab Forum.


    There is something else I would like to add - and perhaps you have already noticed it:


    There are several places throughout the Forum Software a repeated sentence that bugs me - bugs me because of several reasons, one being that no one apparently noticed it OR did not tell the Woltlab Developers about it, OR they failed to make a correction; and secondly, because for us English speaking / reading individuals of the old school were taught that it was not proper English.


    To which sentence am I referring to?

    This: "There are not any items at the moment"

    It should read: "There are no items at the moment" OR, "There are no items available to read at the moment"




    Customer

  • Lol don't get me started on how some 3rd party devs write things in English language with their plug-ins.


    I always end up having to edit the English language file it's that bad for some things

  • Hi, evmiller , if you want to rename an APP you only have to change the path in ACP "Manage Apps" and then login by FTP and rename the APP-directory too.

    Nothing more.

    Just tested it for you and renamed the Chat app by Tim's Bastelstube in an test installation and it worked like a charm. e.g.: /chat/ to /chat-world/

    Before renaming the app directory/folder via FTP I got the same error like you.


    The most important thing I do, according to all changes, no matter what it is (e.g. Woltlab itself, plugins, configurations), is to clear/empty/delete the Cache. But in this case it wasn't necessary.


    Lots of greets