Unable to uninstall packages

  • Hello everyone!

    I'm encountering an error whenever I try to uninstall any package and can't really understand why.


    This is the error message:


    All the best guys!

  • Hei, thank you for the reply!

    Unfortunately I don't think it is because of that reason because I did installed and uninstalled packages until yesterday, today it stopped for some reason.


    I hope I didn't mess the whole thing up :D


    all the best

  • I would put a support ticket in to fix it, if that is what you want. They don't like answering anything on the forums when it comes to a problem with your site

  • Hello everyone!

    I'm encountering an error whenever I try to uninstall any package and can't really understand why.


    Hello SupaHigher,


    I may be mistaken, however I seem to recall Alexander Ebert stating that the preferred PHP Version to use is 7.1; additionally, using version 7.2 OR 7.3 can lead to various problems with various apps and plugins - among other problems as well.


    Even on the PHP website they say to use Version 7.1 (and they further identify this version by stating it as 7.1.30)


    If you continue to have a problem with uninstalling packages perhaps you should open a support ticket with Woltlab ...;)

  • Hi

    I may be mistaken, however I seem to recall Alexander Ebert stating that the preferred PHP Version to use is 7.1; additionally, using version 7.2 OR 7.3 can lead to various problems with various apps and plugins - among other problems as well.

    The preferred version is the newest version that supports all your apps and plugins. Apps and plugins from us will support PHP 7.3 just fine!


    SupaHigher Apparently a database table the plugin created during installation and tries to remove during uninstallation is missing, leading to this issue. I can second the existing advice to file a ticket so that we can look into it and hopefully fix the database of your community.

  • I may be mistaken, however I seem to recall Alexander Ebert stating that the preferred PHP Version to use is 7.1; additionally, using version 7.2 OR 7.3 can lead to various problems with various apps and plugins - among other problems as well.

    I think you are getting a bit mislead by what he said. He did actually say use the highest PHP version you can in that reply, which is PHP 7.3. And I have run WBB on the same 7.3.x PHP version without getting any error logs that something wasn't working right, the site ran fine. So don't think there is any issues running it on 7.3, but the preferred version at minute is probably 7.2 because that is the most stable PHP version to use over 7.3


    He pointed out that some changes have been made in PHP 7.2 and 7.3 that could lead to problems with other 3rd party apps sold that may need changes/or not to be compatible with PHP version above 7.1. But the WBB official apps sold all work with PHP 7.3

  • Hi

    The preferred version is the newest version that supports all your apps and plugins. Apps and plugins from us will support PHP 7.3 just fine!


    SupaHigher Apparently a database table the plugin created during installation and tries to remove during uninstallation is missing, leading to this issue. I can second the existing advice to file a ticket so that we can look into it and hopefully fix the database of your community.

    Hi Tim Düsterhus ,

    I have just filed a ticket I hope we can fix it too =O


    all the best

  • The preferred version is the newest version that supports all your apps and plugins. Apps and plugins from us will support PHP 7.3 just fine!

    Hello Tim Düsterhus,


    At the present time my Hosting Provider has the PHP set at 7.1

    Thus regarding what you stated in your response to me in Post #5, do you think I should have them change the setting to PHP Version 7.3?


    I haven't as yet purchased an install from Woltlab for uploading Version 5.1 to my website (I intend to do this on or about July 1st)

    so if I should have the PHP setting changed FROM 7.1 TO 7.3, now would probably be the time to have the change made.

  • If they have CPanel, then it would be super easy for them to install multiple PHP instances and the best part is they can keep some hostees on 7.1 and make your primary 7.3.

  • Hi

    Thus regarding what you stated in your response to me in Post #5, do you think I should have them change the setting to PHP Version 7.3?

    If you don't run any plugins then I recommend PHP 7.3. If you do you might need to check with the authors whether PHP 7.3 is supported. It should be supported for most.