Not able to update my local installation

  • I am using XAMPP on Windows 10. I have 2 updates pending in ACP. When I try to update and enter license and serial no, it simply goes back to enter license + serial ( which is now blank ) page. I tried 2-3 times and the same thing happens. Can someone help me update to latest version, please.

  • I have the 'Core' installed on WAMP and managed to update to the latest version of that, without any problem.

    Having just bought the 'Blog' I am having problems updating from 'Core' to 'Blog'

  • In the package list all that I am seeing is the already installed Core version 3.1.9 pl 2
    As I am running a localhost perhaps the best bet is to download the Blog and install it myself on top of the Core.

    Wher can this be found ?


    I have the License / Serial / Authentication details

  • Here on the WoltLab site go to My Account > Downloads > WoltLab Suite Blog > Download Update. The wording can be confusing but you do not want to download the setup, you would do that if you had nothing at all installed yet.

  • I have managed that OK, and when I get to the upload package I navigate to the downloaded zip file on my Desktop. Then whan I hit upload I am presented with a page asking for.........
    Package Name - Package Description - Package Identifier


    What are these ?

  • BillM8 You should be able to go from your ACP to Configuration > Packages > Install Package and then you should see the option to either search for a package or upload a file. If you are going back a step when you try to upload a file something is wrong and you should probably create a support ticket with WoltLab.

  • Do yourself a favour then and delete the Core you installed and instead download the Full Blog package (not the update package) and install that instead from a clean install. It will install the Blog "which comes with Core". Rather than you trying to install the Blog update to the free Core downoad you already installed previously

  • If you are going back a step when you try to upload a file something is wrong and you should probably create a support ticket with WoltLab.

    Not much point if he's running it localhost, WBB staff won't have access most likely on his PC localhost running it from

  • I think that I will download the full package again that has the Blog.
    Sorrey if I interupted someones post. As it was about a XAMP problem and mine is a WAMP problem I thought it might be relevant.

  • Don't know why he jumped on you asking you to contact WBB staff when he didn't do the same himself and knows you can't grant access on localhost for them to even look at WAMP. Same way as he can't do it on XMAPP

  • Thanks to everyone !

    Anyway, I have downloaded and installed the full package and it is all working just fine.
    I will now spend some time finding my way around. A lot of time really.
    This is very impressive software at the price.


    Thanks again.

  • Funny enough. I've had the the same problem tonight trying to install FileBase upgrade package to the Core only I have installed. Keeps trying for ages to install it and then throws up a DB error. Tried increasing max execution time from 30 to 300 and even increasing memory from 256 to 512k for PHP. Both post_max_size and upload_max_filesize is already set at 128mb for them, so that should not be stopping the upgrade from installing either. But nothing works so far trying to install the upgrade for FileBase


    Sounds a bit like the same problem you had also with Blog upgrade package trying to install it on the just the Core installed


    This is the error I get each time trying:


  • Hello GTB,


    I noticed you are using PHP 7.2.19

    Somewhere here on Woltlab I thought I had read something about there being problems (of various sorts) by using PHP Versions above 7.1.x

    Do you think possibly this could be your problem?


    The main website of PHP recomends using Version 7.1.30 - as it is the latest Version (30 May 2019) - as the only fully supported version of PHP currently available.

  • PHP 7.2.19 is the default PHP version now set by my host.


    I have not upgraded to that PHP version, that is the default on my host set. I can change it to PHP 7.3 but have not done so and stayed with default they have it at. No, I don't think PHP 7.2 should cause a problem with WBB. I'm running phpBB 3.2.7 on the same version of PHP without any issues on another shared box that's exactly the same specs, plus I'm having no problems running just the WBB Core app on it.

  • I got round this problem by deleting the forum on my localhost, and after I had purchased the Blog I downloaded the complete Blog package, and not just the update. This went in just fine.