Purchased theme, now cant upload?

  • I purchased this theme but the upload is saying " unable to upload the selected style, the upload file is not a valid style"


    Is this because there is a delay between my purchase and when the style is validated? Or is there something I am missing? Thanks

  • Hello,


    The style upload has a small sub feature that attempts to detect packages and redirect to the package installation instead. Possibly, it was simply unable to figure this one out and eventually gave up.


    That said, files downloaded from the Plugin-Store are always meant to be installed through the package system, there are no exceptions.

  • Hello,


    The package manager did not work and gave us an error. We did the same thing as before and used a free theme to make sure we're doing it correctly and that worked fine. The error when trying to upload the bought theme is below. Is this a problem we caused or a problem from the theme?


    What happened?

    An error has occurred while trying to handle your request and execution has been terminated. Please forward the above error code to the site administrator.


    The error code can be used by an administrator to lookup the full error message in the Administration Control Panel via “Logs » Errors”. In addition the error has been written to the log file located at */log/2019-02-12.txt and can be accessed with a FTP program or similar.


    Notice: The error code was randomly generated and has no use beyond looking up the full message.

    System Information

    • PHP Version:

      7.2.6

    • WoltLab Suite Core:

      3.1.8

    • Peak Memory Usage:

      10.735/128 MiB

    • Request URI:

      /acp/index.php?package-start-install/

    • Referrer:

      http://landoflegion.com/acp/index.php?package-start-install/

    • User Agent:

      Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/72.0.3626.96 Safari/537.36

    Error

    • Error Type:

      wcf\system\exception\ErrorException

    • Error Message:

      DOMDocument::loadXML(): Empty string supplied as input

    • File:

      */lib/system/WCF.class.php (346)

    • Stack Trace:
      • #0 */../../../../[internal function] (?):
      • wcf\system\WCF::handleError(2, 'DOMDocument::loadXML(): Empty string supplied as input', '*/lib/util/XML.class.php', 89, [ path => , xml => ])
      • #1 */lib/util/XML.class.php (89):
      • DOMDocument->loadXML('')
      • #2 */lib/system/package/PackageArchive.class.php (160):
      • wcf\util\XML->loadXML('package.xml', '')
      • #3 */lib/system/package/PackageArchive.class.php (140):
      • wcf\system\package\PackageArchive->readPackageInfo()
      • #4 */lib/system/package/validation/PackageValidationArchive.class.php (92):
      • wcf\system\package\PackageArchive->openArchive()
      • #5 */lib/system/package/validation/PackageValidationManager.class.php (86):
      • wcf\system\package\validation\PackageValidationArchive->validate(0)
      • #6 */lib/acp/form/PackageStartInstallForm.class.php (136):
      • wcf\system\package\validation\PackageValidationManager->validate('*/tmp/package_fed65745172b8003c73b374cb8b37b5e9993980d.tar.gz', false)
      • #7 */lib/acp/form/PackageStartInstallForm.class.php (101):
      • wcf\acp\form\PackageStartInstallForm->validateUploadPackage()
      • #8 */lib/form/AbstractForm.class.php (60):
      • wcf\acp\form\PackageStartInstallForm->validate()
      • #9 */lib/form/AbstractForm.class.php (113):
      • wcf\form\AbstractForm->submit()
      • #10 */lib/page/AbstractPage.class.php (291):
      • wcf\form\AbstractForm->readData()
      • #11 */lib/acp/form/PackageStartInstallForm.class.php (213):
      • wcf\page\AbstractPage->show()
      • #12 */lib/page/AbstractPage.class.php (114):
      • wcf\acp\form\PackageStartInstallForm->show()
      • #13 */lib/system/request/Request.class.php (83):
      • wcf\page\AbstractPage->__run()
      • #14 */lib/system/request/RequestHandler.class.php (96):
      • wcf\system\request\Request->execute()
      • #15 */acp/index.php (9):
      • wcf\system\request\RequestHandler->handle('wcf', true)
  • Hello,


    The error message indicates that an unpacked file is empty, which should never happen. I was able to successfully install the style in a local installation, so the file itself is working just fine, most likely this was just a quirk of the system your webspace is running on?


    I would suggest that you try it again, and if it persists, submit a ticket so that we can look into it ourselves in order to figure out what causes the problem.