Fehler beim Upgrade von WoltLab Suite 3.0 auf WoltLab Suite 3.1

  • Hallo, ich habe meine Website 1 zu 1 gespiegelt und versuche gerade ein Upgrade durchzuführen. Jedoch bleibt es mit folgender Fehlermeldung hängen



    Kann mir dazu jemand etwas sagen?

  • Welche MySQL Version nutzt du? Ich hatte ständig dieses Problem mit MySQL 5.6 und habe es dann auf einem Server mit 5.7 versucht und da lief es durch. Als ich dann meinen Server auf 5.7 upgedatet hatte, war das Problem dort auch verschwunden. Bei mir war es so, dass es diese Spalte nicht gab. Und bei jedem neuen Versuch war es eine andere Spalte die angeblich schon existierte, was sie aber zu Beginn des Upgrades nicht tat.

  • Welche MySQL Version nutzt du? Ich hatte ständig dieses Problem mit MySQL 5.6 und habe es dann auf einem Server mit 5.7 versucht und da lief es durch. Als ich dann meinen Server auf 5.7 upgedatet hatte, war das Problem dort auch verschwunden. Bei mir war es so, dass es diese Spalte nicht gab. Und bei jedem neuen Versuch war es eine andere Spalte die angeblich schon existierte, was sie aber zu Beginn des Upgrades nicht tat.

    Hallo Susi, danke für die Antwort. Ich verwende derzeit die PHP-Version 5.6.38. Ich habe die Version 5.7 jedoch nicht auf meinem System



    Ich kann ja mal zum testen hochstellen auf Version 7.0.32

  • Nein, nicht die php Version, sondern die Datenbankversion ist gemeint!


    Die php Version kannst du auf mindestens 7 stellen, dann müsste auch alles schneller gehen. Allerdings nur, wenn alle PlugIns das können.

  • Dann ist es eine Maria DB oder?

    https://packages.debian.org/de/jessie/mariadb-client-10.0


    Auf jeden Fall wird es dann nicht der gleiche Fehler sein wie bei mir, aber wenn das mit deinem Datenumfang möglich ist, würde ich versuchen, das Upgrade mal auf einem anderen Server durchzuführen. Ich habe neben meinem Server noch ein Hostingpaket und da hatte ich das dann ausprobiert. Wenn das bei dir nicht so einfach geht, dann würde ich direkt ein Ticket eröffnen.