Extracting a TAR file and rebuilding it again leads to plugin not working

  • I have a question. Before when I downloaded a TAR file plug-in, extracted it and made some changes to files. Then created the Tar file archive again. When you upload it to use on your site, you get an error and and are unable to install the Tar file plug-in. The only way I've been able to make some file changes to a TAR plug-in (that still works) installing it on your site - is by using 7zip and making changes to files without extracting the TAR file, as 7zip lets you edit files inside a TAR archive and rebuilds the TAR with every change made to files without actually ever extracting the TAR file.

    There must be a way to fully extract a TAR file, make changes to files, then rebuild the TAR and the plug-in still work when trying to install it afterwards on your site? But it's as if, once you extract a Tar plugin it then loses something that stops the plug-in from working when you recreate the TAR again and try and install it. And only editing files inside an un-extracted Tar file with 7zip works because you never actually extract the Tar, it simply just gets rebuilt instead

  • I'm manually building tar archives using 7-Zip for the past few years - my guess is that you're creating an archive from the directory itself rather than its contents? When you open the tar, the first thing you should see (among other files) is the "package.xml". If it is one directory deep inside, then that's the problem :)

    It would help if you could upload both a working and a non-working archive for the same plugin so we can look into it to for a reliable answer.

    Alexander Ebert
    Senior Developer WoltLab® GmbH

  • I did it with the Modern Shoutbox download here to fix some issues with it and move the submit buttons outside the input field. I made quite a few changes to CSS and some other files and works fine if just using Notepad++ as the editor with 7zip to edit files in an un-extracted TAR file that gets rebuilt instead. But if I extract the Modern Shoutbox Tar file and then tried to do it that way editing files and rebuild the Tar file afterwords. It failed every time trying to install it.

    At the minute I don't have 7zip installed because I had to do a clean Windows install this week after some problems. But that was the plug-in file I was doing it with. And yes, when you view the archive in 7zip you see the xml file in root of it.

    I guess I must be doing as you said then by mistake if working for you with 7zip. I will double check that I'm not creating the TAR from the (extracted) folder, and not the files inside it.

  • You was right, I've been rebuilding the extracted folder and not the files inside it by mistake. Just tested again with 7-Zip and now it works fine installing it.