Patch-Day 19.04.2018

  • Wir haben soeben Updates für unsere Produkte freigegeben:

    • WoltLab Suite Blog 2.1.11 / 3.0.14 / 3.1.2
    • WoltLab Suite Calendar 2.1.10 / 3.0.14 / 3.1.2
    • WoltLab Suite Core 2.1.21 / 3.0.14 / 3.1.2
    • WoltLab Suite Filebase 2.1.10 / 3.0.14 / 3.1.2
    • WoltLab Suite Forum 4.1.19 / 5.0.14 / 5.1.2
    • WoltLab Suite Gallery 2.1.11 / 3.0.14 / 3.1.2


    Stabilitäts- und Fehlerbehebungsversionen (auch bekannt als "minor releases"), beseitigen ausschließlich Fehler in der aktuellen Version und führen keine neuen Funktionen ein. Es wird ausdrücklich empfohlen diese Updates anzuwenden.


    Wichtiger Hinweis zur DSGVO

    Am 25. Mai 2018 tritt die EU-Regelung zur Datenschutzgrundverordnung (kurz "DSGVO") in Kraft. Mit diesem Update wird sollten Sie keine eigene Datenschutzerklärung hinterlegt haben automatisch eine angepasste Muster-Datenschutzerklärung eingepflegt. Weitere Hintergründe und Informationen erfahren Sie im Artikel Umsetzung der DSGVO.

  • Aktualisierung einer bestehenden Installation (empfohlene Vorgehensweise)


    Öffnen Sie die Administrationsoberfläche und rufen Sie den Menüpunkt Konfiguration > Pakete > Pakete auflisten auf. Klicken Sie dann auf den Button Updates suchen, diesen finden Sie rechts oberhalb der Paketauflistung.


    Aktualisierung einer bestehenden Installation (alternative Vorgehensweise)


    Rufen Sie die Downloads im Kundenbereich auf und wählen Sie die entsprechende Version aus, klicken Sie anschließend auf Update herunterladen. Öffnen Sie die Administrationsoberfläche und rufen Sie den Menüpunkt Konfiguration > Pakete > Pakete auflisten auf. Klicken Sie nun auf den Tab Paket hochladen und wählen Sie die zuvor heruntergeladene Dateien der Reihe nach zum Hochladen aus, die Reihenfolge ist unerheblich.

  • Bitte beachten Sie, dass die unten stehende Liste nur die wichtigsten Änderungen enthält. Kleinere Korrekturen (u.a. Tippfehler) werden nicht separat aufgeführt.


    Die Versionsangabe hinter den einzelnen Aufzählungspunkten gibt die niedrigste Version an, die von dieser Änderung betroffen ist. Alle neueren Versionen enthalten diese Korrektur ebenfalls bzw. es wurde in diesen Versionen bereits in einem früheren Update korrigiert.


    WoltLab Suite Blog

    • Kompatibilität mit PHP 7.2. 2.1.11+
    • Die Berechtigungen zur Anzeige von Likes wurde nicht korrekt berücksichtigt. 2.1.11+

    WoltLab Suite Calendar

    • Kompatibilität mit PHP 7.2. 2.1.10+
    • Die Berechtigungen zur Anzeige von Likes wurde nicht korrekt berücksichtigt. 2.1.10+
    • Der angezeigte Kategorietitel in der Kartenansicht war manchmal falsch. 2.1.10+

    WoltLab Suite Filebase

    • Kompatibilität mit PHP 7.2. 2.1.10+
    • Die Berechtigungen zur Anzeige von Likes wurde nicht korrekt berücksichtigt. 2.1.10+
    • Der Zeitstempel der ersten Version einer Datei wurde manchmal falsch erfasst. 3.0.13+
    • Die Benachrichtigung für neue Kommentare enthielt keinen Link zum Verfasser des Kommentars. 3.1.1+

    WoltLab Suite Forum

    • Die Berechtigungen zur Anzeige von Likes wurde nicht korrekt berücksichtigt. 4.1.19+
    • Die in einer Antwort erstellten Umfragen wurden irrtümlicher Weise verworfen. 5.0.14+

    WoltLab Suite Gallery

    • Kompatibilität mit PHP 7.2. 2.1.11+
    • Die Berechtigungen zur Anzeige von Likes wurde nicht korrekt berücksichtigt. 2.1.10+
    • Der angezeigte Kategorietitel in der Kartenansicht war manchmal falsch. 2.1.10+
    • Die Suche nach einem Album erzeugte einen fehlerhafte Links. 2.1.10+

    WoltLab Suite Core: Conversations

    • Es war nicht möglich auf der Übersicht eine einzelne Konversation als Gelesen zu markieren. 3.0.14+

    WoltLab Suite Core: Importer

    • Burning Board 4.x, WoltLab Suite Forum 5.x
      • Die Übernahme von Authentifizierungsdaten für den Login über Drittanbieter wurde hinzugefügt. 3.0.14+

    WoltLab Suite Core

    • [DSVGO] Die CDN-Unterstützung für jQuery wurde entfernt, die Dateien werden nun direkt von Ihrer Seite ausgeliefert. 2.1.21+
    • [DSGVO] Die Speicherung von IP-Adressen wurde für Neuinstallationen abgeschaltet, kann aber optional wieder aktiviert werden. 2.1.21+
    • [DSGVO] Die Datenschutzerklärung wurde entsprechend der DSGVO aktualisiert. 2.1.21+
    • [DSGVO] Die Gravatar-Unterstützung wurde für Neuinstallationen abgeschaltet, kann aber optional wieder aktiviert werden. 2.1.21+
    • [DSGVO] reCAPTCHA wird nun automatisch deaktiviert, sollte durch den Website-Betreiber kein API-Schlüssel hinterlegt worden sein. 2.1.21+
    • [DSGVO] Eine neue Option zur Deaktivierung von Bildern aus externen Quellen wurde eingefügt und standardmäßig aktiviert. 2.1.21+
    • Der Code-Highlighter entfernte irrtümlich Kommentare in der formatierten Ausgabe. 2.1.21+
    • Beim Löschen des Cache werden nun auch die Paket-Server zurückgesetzt. 3.0.14+
    • Fehlermeldungen wurden manchmal falsch kodiert und erzeugten dadurch eine unleserliche Ausgabe. 3.0.14+
    • Einige Verbesserungen und Korrekturen des Editors. 3.0.14+
    • Vorschaugrafiken wurden nach einem Import bzw. dem Aktualisieren von importierten Inhalten nicht korrekt dargestellt. 3.0.14+
    • Der Zeitzonen-Versatz wurde im Datumswähler nicht immer korrekt verarbeitet und konnte so zu Sprüngen von einem Tag führen. 3.0.14+
    • Die Unterstützung für Google AMP wurde verbessert. 3.1.2+
    • Die Prüfung für die URL-Umschreibungen schlug bei Installationen mit mehreren Domains fehl. 3.1.2+
    • Die Performance des Benutzer-Imports wurde verbessert. 3.1.2+