Something seriously wrong with WoltLab SEO

  • I have been waiting for the last month to transfer my Xenforo boards to the WoltLab that I purchased, and they are not yet on google search results.


    I had to type the full domain in google search for them to pop up AND they popped up AFTER my xenforo boards. For some reason WoltLab isn't sending my Meta keywords and description to google.


    I can prove the results to a developer.


    I was waiting for the results to transfer.


    My Xenforo 2.0 install that I had used to help with the importer is ranked above the WoltLab and it was installed less time than the WoltLab one.

  • I seriously love WoltLab, but I have 10k posts on my forums and I am ranked above on some results, and in the 3rd place on other vs a Forum with millions of posts.

  • Keep in mind some sites pay one way or another to get ranked higher in Google, it isn't as simple as that when it comes to Google ranking results. They may also go off the age of a domain as well, there are lots of quirky factors like that when it comes to google ranking sites


    You can search your site results in google using this: site:yourdomain.com


    I must admit though, I'm a bit surprised how long it's taking for any stuff posted on my site to show up in google results at the minute. It's a new site but over a week later and not one article listed and no images indexed. Seems a little odd all it has indexed so far is just the main Pages like Dashboard, Articles and FileBase - but nothing indexed that is posted on any of them


    I also see that google has indexed the js folder from my site in its search results. And that folder is not protected by any index file, or htaccess file. So if anyone clicks the link in google they see the full contents on that folder. I have just created a robots.txt file to stop google indexing that folder

  • I must admit though, I'm a bit surprised how long it's taking for any stuff posted on my site to show up in google results at the minute.

    Why is Google going to index anything you took from another site? All of your content is taken from somewhere else.

  • You may want to submit the sitemap generated by your Suite to Google, so they have something they can index.

    return null;


    Browser: Firefox Nightly (64bit)

    Betriebssystem: Windows 10

  • Keep in mind some sites pay one way or another to get ranked higher in Google

    Do you have a proof/source for that? I highly doubt that you can get a higher rank by paying Google.

  • Now that I've upgraded to 3.1.1 should I re-submit my sitemap to Google?

    I only ask because it will have changed as WSC 3.0 didn't produce a sitemap before?

    EDIT

    There's an option to rebuild the sitemap and I haven't uploaded an updated one since 23/2, so my question is, does the rebuild sitemap automatically upload a new rebuilt sitemap which I can then submit to Google?

  • I noticed that the WSC generated sitemaps are in a folder called sitemaps within public_html and the sitemaps i generated previously using G-Mapper are in the public_html directory. Does it matter where they are or is it simply a question of pointing Google to them? And it looks like I'll need to edit the robots.txt as it's not pointing to the WSC sitemaps.

    Any advice on this area please?