google adsense

  • Here's my problem in a nutshell : since I run my website on Woltlab, my ads revenues have dropped by 95%. And I don't mean gradually but literally to the day of the installation precise. First I thought it was because I had just migrated and the users of my previous forum software still had to make the step towards the new software, but since 6 months the traffic on the website is actually higher but the ad revenues have dropped further. I'm coming to a point where the revenues of the ads no longer cover the cost of the website. :(


    What I do notice is that the installed ads (by the Ads plugin of the CMS itself) often do not show up or with a serious delay of more than a minute. These same ads, when tested on a non-Woltlab website load instantly, leaving me with the conclusion that somehow Woltlab is making me lose money.


    Does anybody have the same problem and foremost : is there a solution?


    Thanks!

  • Can you show us an example of your ad settings + a link to the page, where the ad should be displayed?

  • I'm actually having the same issue. more often than not my ads don't display and I find they almost never display on mobile.

  • I'm also having an issue with ads taking a while to load.


    Adsense seems OK, but Amazon and Ebay take ages -- but I've been blaming their servers for this.


    I've also noticed a drop in revenue since I changed platform in November - and it was almost instant here too and it still hasn't caught up.

  • i am experiencing same problem, sometimes the ads are not shown at all in desktop, but in mobile it's okay.

  • Sorry for the late update... I've been playing with adsense and have installed the code for their adaptive advertising. You put some code in every header tag of pages where you want google to advertise and they do the rest. No more figgling with ad placement, Google does it for you. You can decide to a certain point where they can and cannot put ads. Anyways, after pasting the code in the correct templates, the ads now load a lot quicker and revenues seem to be up.


    Which makes me wonder about two things :

    1. Is it possible that the default Ads application in the WoltLab package has some issues?

    2. Could it be that Google somehow altered the code somewhat to reduce the amounts they have to pay us? When installing the responsive ads, I noticed a little clause that stated that an ad must be showed for 30 seconds and more than 50% of the ad must be showed to be eligable for revenues. It seems to me that this is new?

  • No more figgling with ad placement, Google does it for you.

    How does that work if you only want ads to appear in certain places, like the sidebar. or not to appear on certain forums?

  • Sorry for the late update... I've been playing with adsense and have installed the code for their adaptive advertising. You put some code in every header tag of pages where you want google to advertise and they do the rest. No more figgling with ad placement, Google does it for you. You can decide to a certain point where they can and cannot put ads. Anyways, after pasting the code in the correct templates, the ads now load a lot quicker and revenues seem to be up.


    Which makes me wonder about two things :

    1. Is it possible that the default Ads application in the WoltLab package has some issues?

    2. Could it be that Google somehow altered the code somewhat to reduce the amounts they have to pay us? When installing the responsive ads, I noticed a little clause that stated that an ad must be showed for 30 seconds and more than 50% of the ad must be showed to be eligable for revenues. It seems to me that this is new?

    I used that setup on the CMS portion of my site (Wordpress) and have been pretty happy with it. Do you mind telling me where you added the code on the woltlab side?


    Thanks!

  • Of course, in your file system,starting from the main folder, go to the folder "Templates" and look for the file "header.tpl". In this file, paste the google code just above the </header> line.