Update von 3.0.11 pl 1 auf 3.1.0 RC 2

  • Hallo Community


    Ich wollte heute ein Update machen von 3.0.11 pl 1 auf 3.1.0 RC 2 und habe hierfür noch entsprechend die Lizenzen erworben.

    Nun erstaunt mich, dass unter den vorgeschlagenen Updates bei den Paketen für keine meiner Apps ein Vorschlag für 3.1 verfügar ist, sonder nur für die Plugins.


    Ich versuche also z.B. das Update Paket "com.woltlab.wbb.tar.gz" in der Version 5.1.0 RC 2 hochzuladen und zu installieren, erhalte dann aber sofort den folgenden Fehler:




    Heisst das jetzt dass ich alle diese Plugin zuerst deinstallieren muss?
    Aber für z.B. Gallery, Calendar oder Blog hab ich doch auch die entsprechenden Update Pakete bereit, wobei mir dann immer noch nicht ganz klar wäre, was ich mit den anderen Plugins machen müsste?


    Die anderen anstehenden Updates (Plugins) kann ich jetzt auch nicht mehr installieren, dort erhalte ich dann z.B. den Fehler:


    An update of package de.mdman.wcf.user.iplog from version 3.0.2 pl 1 to 3.1.0 is not supported.


    Unter den Update Servern habe ich folgende eingetragen:




    Wie muss ich denn vorgehen um meine Suite, die Apps, und die Plugins zu aktualisieren?


    Danke für Euren Input und Gruss


    Tho

  • Ja ich habe es nach genau der Anleitung versucht,
    Jedoch werden bei mir aber keine App Updates angezeigt, nur die Plugins. Und diese kann ich offenbar nur updaten nachdem ich die (Core) Apps aktualisiert habe, was ja aber wiederum nicht geht weil diese nicht unter den Updates verfügbar sind.


    Daher der Versuch es mittels den App Update Paketen hochzuladen und dann zu installieren, was wiederum mit dem im vorigen Beitrag angehängten Fehler endet.

  • Nachtrag: Ich hatte bei dem "Tornado" Update Server kein Passwort mehr drin.
    Nachdem ich das eingetragen habe werden nun in den verfügbaren Updates auch die Apps angezeigt.
    Versuche ich aber diese (auch einzeln) zu aktualisieren erhalte ich nun folgenden Konflikt (der aber wieder in das eigentliche Problem hineingeht):


    Quote

    Konflikt


    Installierte Pakete

    Die folgenden installierten Pakete sind mit den zu installierenden Versionen nicht kompatibel



    • „WoltLab Suite Core: Moderated User Groups“ in Version „3.0.10“ verhindert eine Aktualisierung von „WoltLab Suite Core“ auf Version „3.1.0 RC 2“
    • „WoltLab Suite Core: Legal Notice“ in Version „3.0.0“ verhindert eine Aktualisierung von „WoltLab Suite Core“ auf Version „3.1.0 RC 2“
    • „WoltLab Suite Core: Importer“ in Version „3.0.10“ verhindert eine Aktualisierung von „WoltLab Suite Core“ auf Version „3.1.0 RC 2“
    • „Wer war online“ in Version „2.0.1“ verhindert eine Aktualisierung von „WoltLab Suite Core“ auf Version „3.1.0 RC 2“
    • „User online timer“ in Version „3.0.0“ verhindert eine Aktualisierung von „WoltLab Suite Core“ auf Version „3.1.0 RC 2“
    • „Protokoll der gelöschten Benutzer“ in Version „1.0.3“ verhindert eine Aktualisierung von „WoltLab Suite Core“ auf Version „3.1.0 RC 2“
    • „WoltLab Suite Chronik“ in Version „3.0.7“ verhindert eine Aktualisierung von „WoltLab Suite Core“ auf Version „3.1.0 RC 2“
    • „Hangman“ in Version „1.0.1“ verhindert eine Aktualisierung von „WoltLab Suite Core“ auf Version „3.1.0 RC 2“
    • „Spenden System“ in Version „3.0.0 pl 1“ verhindert eine Aktualisierung von „WoltLab Suite Core“ auf Version „3.1.0 RC 2“
    • „PayPal Spende“ in Version „3.0.0 pl 2“ verhindert eine Aktualisierung von „WoltLab Suite Core“ auf Version „3.1.0 RC 2“
    • „Freunde-System“ in Version „3.0.3“ verhindert eine Aktualisierung von „WoltLab Suite Core“ auf Version „3.1.0 RC 2“
    • „Liste der eigenen Beiträge“ in Version „1.0.0“ verhindert eine Aktualisierung von „WoltLab Suite Core“ auf Version „3.1.0 RC 2“
    • „MysteryPink“ in Version „1.0.0“ verhindert eine Aktualisierung von „WoltLab Suite Core“ auf Version „3.1.0 RC 2“
    • „WoltLab Suite: CMS Restrict Indexing“ in Version „1.0.1“ verhindert eine Aktualisierung von „WoltLab Suite Core“ auf Version „3.1.0 RC 2“
    • „Kontaktformular“ in Version „2.0.0 pl 7“ verhindert eine Aktualisierung von „WoltLab Suite Core“ auf Version „3.1.0 RC 2“
    • „Standard Avatare“ in Version „3.0.0 pl 1“ verhindert eine Aktualisierung von „WoltLab Suite Core“ auf Version „3.1.0 RC 2“
    • „UZ Benutzerkarte für WSC“ in Version „3.0.0 pl 3“ verhindert eine Aktualisierung von „WoltLab Suite Core“ auf Version „3.1.0 RC 2“
    • „Banküberweisung Spende“ in Version „3.0.0 RC 1“ verhindert eine Aktualisierung von „WoltLab Suite Core“ auf Version „3.1.0 RC 2“
    • „Paysafecard Spende“ in Version „3.0.0 RC 1“ verhindert eine Aktualisierung von „WoltLab Suite Core“ auf Version „3.1.0 RC 2“
    • „Benutzer IP-Log“ in Version „3.0.2 pl 1“ verhindert eine Aktualisierung von „WoltLab Suite Core“ auf Version „3.1.0 RC 2“
  • Danke schon mal für Eure Antworten,


    Alexander Ebert:


    Wenn ich versuche die Updates über das automatische Update zu installiere erhalte ich folgende Fehlermeldung:


  • Das "Benutzer IP-Log"-Plugin von MDMAN scheint kein Update zu unterstützen, wende dich für das korrekte Vorgehen an den Entwickler. Möglicherweise ist eine Deinstallation mit anschließender Neuinstallation nach dem Upgrade notwendig, die genauen Informationen kann dir nur MDMAN liefern.

    Alexander Ebert
    Senior Developer WoltLab® GmbH

  • Ich habe nun also das Benutzer IP Paket deinstalliert und nochmals versucht die automatischen Updates anzuwerfen, jetzt erhalte ich diesen Fehler:


    Quote

    Konflikt


    Installierte Pakete

    Die folgenden installierten Pakete sind mit den zu installierenden Versionen nicht kompatibel



    • „Wer war online“ in Version „2.0.1“ verhindert eine Aktualisierung von „WoltLab Suite Core“ auf Version „3.1.0 RC 2“
    • „User online timer“ in Version „3.0.0“ verhindert eine Aktualisierung von „WoltLab Suite Core“ auf Version „3.1.0 RC 2“
    • „Protokoll der gelöschten Benutzer“ in Version „1.0.3“ verhindert eine Aktualisierung von „WoltLab Suite Core“ auf Version „3.1.0 RC 2“
    • „Hangman“ in Version „1.0.1“ verhindert eine Aktualisierung von „WoltLab Suite Core“ auf Version „3.1.0 RC 2“
    • „Spenden System“ in Version „3.0.0 pl 1“ verhindert eine Aktualisierung von „WoltLab Suite Core“ auf Version „3.1.0 RC 2“
    • „PayPal Spende“ in Version „3.0.0 pl 2“ verhindert eine Aktualisierung von „WoltLab Suite Core“ auf Version „3.1.0 RC 2“
    • „Freunde-System“ in Version „3.0.3“ verhindert eine Aktualisierung von „WoltLab Suite Core“ auf Version „3.1.0 RC 2“
    • „MysteryPink“ in Version „1.0.0“ verhindert eine Aktualisierung von „WoltLab Suite Core“ auf Version „3.1.0 RC 2“
    • „WoltLab Suite: CMS Restrict Indexing“ in Version „1.0.1“ verhindert eine Aktualisierung von „WoltLab Suite Core“ auf Version „3.1.0 RC 2“
    • „Kontaktformular“ in Version „2.0.0 pl 7“ verhindert eine Aktualisierung von „WoltLab Suite Core“ auf Version „3.1.0 RC 2“
    • „Standard Avatare“ in Version „3.0.0 pl 1“ verhindert eine Aktualisierung von „WoltLab Suite Core“ auf Version „3.1.0 RC 2“
    • „Banküberweisung Spende“ in Version „3.0.0 RC 1“ verhindert eine Aktualisierung von „WoltLab Suite Core“ auf Version „3.1.0 RC 2“
    • „Paysafecard Spende“ in Version „3.0.0 RC 1“ verhindert eine Aktualisierung von „WoltLab Suite Core“ auf Version „3.1.0 RC 2“


    Muss ich dies nun wirklich mit all diesen Plugins auch noch machen?