WoltLab Suite 3.1 Beta 1 Download

  • Introducing WoltLab Suite Core 3.1 and WoltLab Suite Forum 5.1, the definite answer for community-driven websites and forums.

    System Requirements

    WoltLab Suite 3.1 requires the following prerequisites to install and run the software:

    • Webserver with PHP 5.5.4 or newer
    • MySQL 5.5.35 (or newer) / MariaDB 5.5.47 (or newer) / MariaDB 10.0.22 (or newer)
    • 20 MB free disk space
    • Current Webbrowser (Chrome 61+, Firefox 55+, Safari 11, Internet Explorer 11 / Microsoft Edge 40+ [EdgeHTML 15+])

    Installation Guide

    1. Download the installation archive onto your computer.
    2. Extract the archive.
    3. Upload the files install.php, test.php and WCFSetup.tar.gz onto your webserver.
    4. Start the installation by navigating with your webbrowser to the test.php.

    Updating from earlier versions

    The first beta version explicitly does not support updating from previous versions of our software. Update support will be added with future releases.

    Usage and Support

    This evaluation version is not suitable for use in production environments, doing so is entirely at your own risk. An update from WoltLab Suite 3.1 Beta 1 to future versions is not guaranteed. You may use this version until February 1st 2018, if you wish to continue past this date, a valid license for WoltLab Suite Forum 5.1 is required.


    We're looking forward to hear your feedback and report of possible issues in this forum.



    Download WoltLab Suite Forum 5.1 Beta 1

    Alexander Ebert
    Senior Developer WoltLab® GmbH

  • System

    Approved the thread.