Move forum to root directory?

  • Affected Version
    WoltLab Suite 3.0

    I installed Woltlab core in http://www.mydomain.com/forum/

    I installed Woltlab forum in http://www.mydomain.com/forums/

    My vbulletin installation is currently in the root directory http://www.mydomain.com/

    I did it this way to test the migration. Now I want to move Woltlab forum to the root folder. How do I do this?


    EDIT - You can read down but this is the solution:

    1. Change forum directory path in ACP - Manage Apps - WoltLab Suite Forum (Burning Board) FROM /forums/ TO /
    2. Confirm the changed setting in the database table wcf1_application - row `packageID = 4` Value should be /
    3. Move the forums to the domain root. In my case from http://www.mydomain.com/forums/ to http://www.mydomain.com/
    4. Update the packageDir of the forum changing the setting in the database table wcf1_package TO packageDir = '../' WHERE package = 'com.woltlab.wbb';

    5. Edit the `app.config.inc.php` in the forums directory. Change the last line with the "RELATIVE_WCF_DIR" (assuming the Core is in /forum/) TO:

    if (!defined('RELATIVE_WCF_DIR')) define('RELATIVE_WCF_DIR', RELATIVE_WBB_DIR.'forum/');
    6. Delete PHP files in core cache. In my case located in http://www.mydomain.com/forum/cache/

    Edited 3 times, last by dan1 ().

  • Frustrating, I followed all instructions to the letter and now everything's gone and I can't get into acp. I didn't even move the core.

  • You really should stop using vB and WSC on one site - this will resullt in a complicated htaccess-Configuratetion,,, Why not use XAMP or MAMP or LAMP for testing.....


    That said, opening 100 threads about the same topic will not solve your problem...

    Viele Grüsse aus Stuttgart, Kind Regards from Stuttgart
    TheSonic

    Edited once, last by TheSonic: Link added ().

  • Two different threads, one about moving the forum to root directory, the other about enabling friendly urls. I have more than one forum BTW and they are in different stages of migration. In any case since when does 2 = 100 in Stuttgard?


    As I already stated I moved WSF to the root directory following the instructions in the link. Obviously the vbulletin installation was moved to a backup folder together with the htaccess file (so htaccess is out of the picture). I confirmed in phpmyadmin and the database table wcf1_application has the correct paths. Yet nothing is displayed when I go to my domain. Cache has been emptied.

  • Offending others will not help you...I'm a outta here,

    (BTW; StuttgarT)

    Viele Grüsse aus Stuttgart, Kind Regards from Stuttgart
    TheSonic

  • I can't access acp but the last two errors in error_log are:


    [02-Sep-2017 20:47:39 America/New_York] PHP Warning: require_once(../forum/global.php): failed to open stream: No such file or directory in /home/user/public_html/mydomain.com/global.php on line 13

    [02-Sep-2017 20:47:39 America/New_York] PHP Fatal error: require_once(): Failed opening required '../forum/global.php' (include_path='.:/opt/alt/php56/usr/share/pear:/opt/alt/php56/usr/share/php') in /home/user/public_html/mydomain.com/global.php on line 13


    this will resullt in a complicated htaccess-Configuratetion,,,

    (BTW configuration)


    I thought Woltlab would be happy with English content in this forum that leads to solving end user problems.

    Edited 4 times, last by dan1 ().

  • (BTW configuration)


    I thought Woltlab would be happy with English content in this forum that leads to solving end user problems.

    Thank you, dan1 - you are a hero... (*censored content*)

    Viele Grüsse aus Stuttgart, Kind Regards from Stuttgart
    TheSonic

  • Wow some good old fashioned flaming. Are you like 14 years old?


    I can reverse everything I did and it works fine from the old directory. I think it's time to start a ticket.

    Edited 2 times, last by dan1 ().

  • A ticket is in progress thanks. So far I got these instructions that have steps that are not in the tutorial, but it's still not working.


    (1) Move the Core into the domain root.

    (2) Update the `packageDir` for the forums:

    UPDATE wcf1_package SET packageDir = 'forums/' WHERE package = 'com.woltlab.wbb'

    (3) Edit the `app.config.inc.php` in the forums directory, in particular the last line with the "RELATIVE_WCF_DIR" needs to read this:

    if (!defined('RELATIVE_WCF_DIR')) define('RELATIVE_WCF_DIR', RELATIVE_WBB_DIR.'../');

    (4) Delete the *.php files in the /cache/ directory in your domain root (where the Core is now located).

  • Did you change wcf1_application?

    Are you using Memcached? If so, you might clear it via the command line or change to any other cache through the data base.

    Gruß, Udo

  • Yes wcf1_application was updated correctly when I changed the path in acp.


    I'm not using Memcached.

  • Deleting the files in /templates/compiled/ did not make a change.


    Support provided the correct settings and my site is now working correctly. Initially there was confusion because of the similarity between my /forum/ and /forums/ directories. I rewrote the steps as I did them, hope this helps someone. Thanks for your help everyone.


    1. Change forum directory path in ACP - Manage Apps - WoltLab Suite Forum (Burning Board) FROM /forums/ TO /

    2. Confirm the changed setting in the database table wcf1_application - row `packageID = 4` Value should be /

    3. Move the forums to the domain root. In my case from http://www.mydomain.com/forums/ to http://www.mydomain.com/

    4. Update the packageDir of the forum changing the setting in the database table wcf1_package TO packageDir = '../' WHERE package = 'com.woltlab.wbb';

    5. Edit the `app.config.inc.php` in the forums directory. Change the last line with the "RELATIVE_WCF_DIR" (assuming the Core is in /forum/) TO:

    if (!defined('RELATIVE_WCF_DIR')) define('RELATIVE_WCF_DIR', RELATIVE_WBB_DIR.'forum/');

    6. Delete PHP files in core cache. In my case located in http://www.mydomain.com/forum/cache/

    Edited 2 times, last by dan1 ().