Adding a Forum Login option from Facebook

  • Not sure where to post this, but ...


    I have a Plugin from GeGeek (Plugin -Social Links) which is for adding links to various social sites - Facebook being one of several.

    When I attempted to do this, I received a message from Facebook, to wit:


    "The Facebook SDK for JavaScript doesn't have any standalone files that need to be downloaded or installed, instead you simply need to include a short piece of regular JavaScript in your HTML that will asynchronously load the SDK into your pages.

    The async load means that it does not block loading other elements of your page. The following snippet of code will give the basic version of the SDK where the options are set to their most common defaults. You should insert it directly after the opening <body> tag on each page you want to load it."


    Problem is,

    I didn't know WHERE to add the

    code

    . So I contacted my

    Hosting Provider

    and they responded with this message:


    "Normally, this code can be added to the file of your choice by going to
    cPanel ---> File Manager ---> select file under public_html folder
    and choose Edit option on the top right

    However, under your index.php file I do not see any body option.

    Since we are not developers, I am not sure on what file you will need to add this.

    You will need to speak to your web developer or script maker to assist with adding the code correctly."


    I posted a comment on GeGeek's site about this, but no response yet.

    Does anyone viewing this post know WHERE I am to add the above code since my Hosting Provider has told me

    I have no "body" designation in my files?

    Edited once, last by Ruff Seas: Deleted copy of Code given by Facebook ().

  • In ACP----->Content---->Boxes--->Add Box

    Hi,


    Thanks for your reply.

    Ge Geek did reply to me.


    I went back into the Social Links Plugin, re-did everything, and checked the Facebook LINK once again

    by logging onto my Forum as a VISITOR. I clicked on the Facebook Link in my Forum Header

    (see attachment) and I was directed to the proper Facebook Login for my Forum.


    So the Plugin is working properly!


    DJ

  • In ACP----->User--->Registration---->Facebook APP-ID= 697700683754104 and you have 1 password from APP-ID

    I will have to try implementing your suggestion because I just realized I am involved here with TWO different issues!


    The Social Links Plugin provides for Visitors to my to connect with my Forum's Facebook Page only - which is good

    as far as it goes.


    But it does not provide for a Visitor to my Forum - who has a FACEBOOK ACCOUNT - to become a Registered Member

    of my Forum WITHOUT going through the standard Registration process on my Forum.


    That's why the Code Facebook gave me to put in the html of my Forum Page of choosing -(that would be my landing page) -

    so that Visitors to my Forum can become a Member by use of THEIR Facebook Account.

    The theory is, Visitors will be more likely to join a Forum if they can do so without going through the standard process of

    Forum Membership Registration.


    So hopefully I can accomplish that soon - but not now, it's getting late.

    DJ

  • In ACP----->User--->Registration---->Facebook APP-ID= 697700683754104 and you have 1 password from APP-ID

    Hi tunhj1,


    I want to make sure I understand you correctly before I attempt to make any changes to my Forum's Registration process.


    Are you saying that I type in the following: Facebook APP-ID=697700683754104 in the "Custom Field" Box of "manage phrases"?

    Please refer to my two screen shots I have attached with this post for clarification of my question.


    And how/where did you get that number (in Red) you noted above ?


    DJ

  • Hi SoftCreatR,


    I clicked on the LINK you provided and looked over the material.

    Apparently these are "tutorials" - I did not see any link which would allow me to actually view and download an APP or Plugin

    which would give me those Facebook, etc., etc. Login Boxes where the information / code required is to be typed in /inserted by me.


    Who makes such an APP / Plugin?


    DJ

  • Everything is described, step by step, including images and links. Dunno, what else you need.

    Thanks for your reply!


    I just took another look at the info via the LINK you gave me; saw the Links for Facebook, etc.,; clicked on

    "Facebook"; copied instructions so I can go thru the process; hopefully I will get this set-up for my Forum today.


    DJ

  • Everything is described, step by step, including images and links. Dunno, what else you need.

    OK, I was able to establish the 3rd Party Login (FACEBOOK) for when / if Visitors to my Forum

    would choose to Register / login to my Forum using their Facebook Account.


    HOWEVER, there is a "glitch"! See my attached Screen Shots.


    Do you have a suggestion as to how I can get the 3rd Party Login (Facebook) to appear when

    the Visitor CLICKS on EITHER "Register" Link - (refer to screen shots).


    DJ


    UPDATE 1: As an after thought, I suppose I could just go into: > ACP > Content > Boxes

    and then change the settings so the "registration box" does not appear on my Dashboard OR

    my Main Forum Page. That way Visitors to my Forum would be forced to click on the

    "Login or Register" Link in the Upper Top Corner of the screen.


    UPDATE 2: I made another Box (Text Box) and gave explanation for Visitors to my Forum on how to

    Login / Register to my Forum using their Facebook Account. (See screen shots)


    But there is one last issue I would prefer to improve upon.

    When a Visitor to my Forum clicks on the Facebook Login link, and is taken to the page for doing so,

    but decides for some reason NOT to go thru with logging on, there is a LINK named "not now".

    And if a Visitor clicks on that, a page comes up saying "error", and also gives a link to click on

    which says "back to previous page".


    But what that does is bring the person (Visitor) to another page of Facebook.

    See my screen shots.


    MY QUESTION: After clicking on: "Not Now", can I have the Visitor taken to my main Forum Page?

    I looked for something in the settings of the Facebook APP to do this, but I do not see it.

    Do YOU know where such a setting might be? Or is what I want to accomplish not possible?


    In ACP----->User--->Registration---->Facebook APP-ID= 697700683754104 and you have 1 password from APP-ID

    Finally I got into the correct area of ACP you were referring to!

    And the 3rd Party Login for FACEBOOK works - I tested it.


    But as I said above to SoftCreatR, there is a "glitch". See my Screen Shots attached.


    UPDATE: As an after thought, I suppose I could just go into: > ACP > Content > Boxes

    and then change the settings so the "registration box" does not appear on my Dashboard OR

    my Main Forum Page. That way Visitors to my Forum would be forced to click on the

    "Login or Register" Link in the Upper Top Corner of the screen.


    UPDATE 2: I made another Box (Text Box) and gave explanation for Visitors to my Forum on how to

    Login / Register to my Forum using their Facebook Account. (See screen shots)


    But there is one last issue I would prefer to improve upon.

    When a Visitor to my Forum clicks on the Facebook Login link, and is taken to the page for doing so,

    but decides for some reason NOT to go thru with logging on, there is a LINK named "not now".

    And if a Visitor clicks on that, a page comes up saying "error", and also gives a link to click on

    which says "back to previous page".


    But what that does is bring the person (Visitor) to another page of Facebook.

    See my screen shots.


    MY QUESTION: After clicking on: "Not Now", can I have the Visitor taken to my main Forum Page?

    I looked for something in the settings of the Facebook APP to do this, but I do not see it.

    Do YOU know where such a setting might be? Or is what I want to accomplish not possible?



  • You can copi and edit (boxRegisterButton) Templates:thumbup:


    Thank you for your reply!


    However after trying several times to locate and edit the Box Register Button Template, I have not located WHERE this is found.

    I am assuming it would be in the "manage phrases" section - but did not find anything in particular that related to this.


    So for now - until you (or perhaps someone else) can show me (give me) the exact Manage Phrases entry for Editing this -

    I have just "Unchecked" ALL areas of my Forum where "Register Box" would be "visible".


    That leaves only one option left for Visitors desiring to join, the Login or Register Link displayed at the Top, Right corner

    of my Main Forum Page. That link of course has the 3rd Party Link included - so that suffices for right now.


    DJ

  • 1. go in to ACP

    2. go to Customization

    3. In Templats Groups (Add Templates) Give the group a name

    4. go in to Templats and fine (boxRegisterButton) Templates and copi the templates to the new group you make.

    5. Open up the (boxRegisterButton) in the new group and edit away everything

    6. Copy in this code and save

    7. go in to Styles (in acp) and below (Template Group) you use the Templates name you make:thumbup:


  • I followed your instructions, however what do I put in this field (Directory) ? - SEE my attachment -

    It won't let me add a Template Group without it.

  • Just give the Directory also a name:thumbup:

    Success! Finally got it!!

    Thanks for your help, tunhj1

    Don't know what I can do to help you, but if I ever can will gladly do so.


    There is ONE more thing I would like to accomplish regarding the Sign In using Facebook.

    See the four Screen Shots I attached here with this post.

    Do YOU know how to accomplish what I have proposed in Screen Shot 3?