Fehlermeldung wegen diesen special chars!

  • Hallo,


    Ich habe mal wieder diese Fehlermeldung mit diesen speziellen Chars bei eingem speziellen User, die Threads liessen sich gar nicht aufrufen sodass ich diese gelöscht habe:

    Alexander Ebert wann wird das endlich mal gefixt dass dieses nicht mehr vorkommt, das musste irgendwie bypassed werden?


    Danke

  • Im WSC ist das behoben. Bis dahin kann ich dir nur nahe legen, dir meine Emoji-Erweiterung zu installieren.

    CSS
    1. * { background-color: rgba(255,0,0,.2); }
    2. * * { background-color: rgba(0,255,0,.2); }
    3. * * * { background-color: rgba(0,0,255,.2); }
    4. * * * * { background-color: rgba(255,0,255,.2); }
  • lib/data/shoutbox/MessageAction.class.php

    Wende dich an den Ersteller der Shoutbox, damit diese Smilies korrekt gefiltert werden (\wcf\util\StringUtil::stripCrap()).





    TeRRible__KHONS

    TeRRible__KHONS

    TeRRible__KHONS

    TeRRible__KHONS

    TeRRible__KHONS

    TeRRible__KHONS

    TeRRible__KHONS

    TeRRible__KHONS

    TeRRible__KHONS


    PS: Ja, die Erwähnungen sind Absicht.

  • Och Mensch das war die falsche Fehlermeldung :D

    EDIT: Der Grund ist hier aber wohl der gleiche da hier soein Zeichen in dem Link war der im Thread gepostet wurde. Sollte dann irgendwie doch in WBB gestriped werden :)


    Das andere wurde Sonnenspeer schon mal gemeldet aber bisher noch kein fix in sicht :D


    SoftCreatR dein Plugin "Replace URL by Name" hat hier den Titel vom der Webseite geholt und dort waren diese Zeichen drin, vielleicht ist es auch notwendig (wenn du da noch dran arbeitest) da irgendwas zu fixen) :D

  • Aber zu einem vollkommen anderen.

    CSS
    1. * { background-color: rgba(255,0,0,.2); }
    2. * * { background-color: rgba(0,255,0,.2); }
    3. * * * { background-color: rgba(0,0,255,.2); }
    4. * * * * { background-color: rgba(255,0,255,.2); }
  • Schau halt, was in der Datei httpdocs/lib/system/event/listener/ThreadFormEditButtonListener.class.php steht.

    CSS
    1. * { background-color: rgba(255,0,0,.2); }
    2. * * { background-color: rgba(0,255,0,.2); }
    3. * * * { background-color: rgba(0,0,255,.2); }
    4. * * * * { background-color: rgba(255,0,255,.2); }
  • Laut Google kommt der Fehler vom Themen-Formular-Plugin. Allerdings steht das wohl in Verbindung zu Tapatalk. Solltest du also Tapatalk installiert haben, deinstalliere es und schau, ob der Fehler danach weiterhin erzeugt wird, oder nicht.

    CSS
    1. * { background-color: rgba(255,0,0,.2); }
    2. * * { background-color: rgba(0,255,0,.2); }
    3. * * * { background-color: rgba(0,0,255,.2); }
    4. * * * * { background-color: rgba(255,0,255,.2); }
  • Dann wende dich bitte an Joshua Rüsweg wegen dieses Fehlers.


    PS: Den Code habe ich aus deinem Post entfernt. Lizenz und so ;)

    CSS
    1. * { background-color: rgba(255,0,0,.2); }
    2. * * { background-color: rgba(0,255,0,.2); }
    3. * * * { background-color: rgba(0,0,255,.2); }
    4. * * * * { background-color: rgba(255,0,255,.2); }
  • Das Thema wurde fehlerhaft erstellt und es gibt keine Beiträge in dem Thema. Wahrscheinlich weil der Beitragstext ein Emoticon enthalten hat. Daraus resultiert dann der Fehler im Eventlistener (ergo -> Thema sowieso unbrauchbar, kannst du löschen).

  • Hab ich auch gelöscht, also muss das trt vorher durch das WCF geprüft werden :)


    PS. Das Problem mit der Shoutbox habe ich mit Hilfe des Entwickelers mittlerweile gefixt.

  • dein Plugin "Replace URL by Name" hat hier den Titel vom der Webseite geholt und dort waren diese Zeichen drin


    Wer soll denn auch damit rechnen, dass irgendwer Emoji im Seitentitel verwendet?!

    CSS
    1. * { background-color: rgba(255,0,0,.2); }
    2. * * { background-color: rgba(0,255,0,.2); }
    3. * * * { background-color: rgba(0,0,255,.2); }
    4. * * * * { background-color: rgba(255,0,255,.2); }
  • Die Entwickler der entsprechenden Plugins müssen doch eigtl mit allem rechnen :D Das WWW ist vielfälltig und nicht immer konform :)


    Daher muss auch für "invalide" Sachen eine entsprechende Prüfung stattfinden.

  • Es MUSS gar nichts. Und als das Plugin 2010 entwickelt wurde, war noch keine Rede von Emoji.

    CSS
    1. * { background-color: rgba(255,0,0,.2); }
    2. * * { background-color: rgba(0,255,0,.2); }
    3. * * * { background-color: rgba(0,0,255,.2); }
    4. * * * * { background-color: rgba(255,0,255,.2); }