Upgrade to WSC 3 possible, even if PHP version is insufficient