Benutzer mit deaktivierter Sprache: Trying to get property of non-object

  • Requested URL
    /de/
    Referrer
    https://justcode.xyz/
    Error Message
    Call to a member function getDynamicVariable() on null
    Type
    Error
    File (Line)
    /home/user/public_html/lib/system/exception/IllegalLinkException.class.php (18)
    Stacktrace
    1. /home/user/public_html/lib/system/request/RequestHandler.class.php (183): wcf\system\exception\IllegalLinkException->__construct(…)
    2. /home/user/public_html/lib/system/request/RequestHandler.class.php (71): wcf\system\request\RequestHandler->buildRequest(…)
    3. /home/user/public_html/index.php (9): wcf\system\request\RequestHandler->handle(…)

    Mit freundlichen Grüßen!
    With kind regards!

    Wanna PayPal Me?


    Blog 2.0.x Extension-Kit 1.0.1
    Blog 2.1.x Extension-Kit 1.1.1
    Article "The Sweeet Core Thing" Threads Worker 3.0.0 *


    * no official release, just ask me!

    • Official Post

    Kann ich allgemein nicht reproduzieren. Ich bin wie folgt vorgegangen:

    • WoltLab Suite Forum 5.0.1 mit Deutsch und Englisch installiert (Standardsprache Deutsch)
    • mit Benutzeraccount im Frontend eingeloggt und unter Benutzerkonto -> Verwaltung als Sprache Englisch ausgewählt
    • Sprache Englisch im ACP deaktiviert
    • div. Seiten mit dem Benutzeraccount im Frontend aufgerufen (keine Fehlermeldung/Interface ist logischerweise in Deutsch)


    Falls reproduzierbar, bitte genau erklären, wie man vorgehen muss.

    Marcel Werk
    WoltLab CEO

  • Sorry, habe vergessen zu erwähnen dass der Fehler nur beim Login auftritt.

    Mit freundlichen Grüßen!
    With kind regards!

    Wanna PayPal Me?


    Blog 2.0.x Extension-Kit 1.0.1
    Blog 2.1.x Extension-Kit 1.1.1
    Article "The Sweeet Core Thing" Threads Worker 3.0.0 *


    * no official release, just ask me!