Problems Pasting text into a new post - all jammed together without paragraph breaks

  • I just read this thread, which appears to be related, but my question is actually more simple: Question on Text Spacing when making a NEW post


    When I type a post from scratch, like I am doing now, the formatting seems to be ok. But on my own board, when I paste a series of paragraphs from notepad (Kate, I am in Linux, using Chrome) or from Libreoffice writer, it all looks fine when I paste. Everything is formatted correctly. BUT when I then hit submit, I find that every sentence in every paragraph is jammed together without any line breaks whatsoever. Even when I go back in and edit, it looks fine. If I add new hard returns to try to separate the paragraphs, it looks fine, but then all goes away when I hit submit.


    I am really at my wits end as to why this works when I type manually but not when i paste from a text editor. I have lived with this for months, going back and putting <br> code in to make it look right, but I really need to figure this out. Can anyone suggest a way around this?


    thanks


    EDIT: Yep, just as I suspected, I typed this manually, hit Submit, and it looks great.


    EDIT2- I have played with cutting and pasting what I just wrote into Libreoffice, then pasted it back here, and the formatting seems to work fine. Is it possible that some sites are set up differently than others? Or that I have failed to install some kind of formatting engine on my particular site? I am beginning to think there may be some kind of setting controls that are set diffently on this help forum than on my site.


    EDIT3 - Same problem in both Chrome and Firefox

  • It's super irritating and it's confusing for users.


    The only way I know how to get around it is to disable BBCode (click the little square icon on the top left tool bar in the text editor) before you past the quotes. After you paste the quotes, you can enable the BBCode again before you post it. That should allow the quotes to retain the spacing and paragraphs.


    I wish there was a setting to automatically bypass BBCode or HTML formatting while pasting. It really confuses my users. And I've had to make "how to" threads on both of my forums on how to get around this. People get upset with the quote system a lot on both of my forums, mostly because they don't understand it right away....but that formatting is a legitimate problem and issue, in my opinion.

  • Black Star thank you SO VERY MUCH for posting because it helps to know that I am not insane and alone. Well I might be insane but I am not alone.


    I have fiddled with the BBCode settings in the past without success. I will make an effort to figure that out again, but this is ridiculous.


    Would you be willing to share a link to your "how to" posts that you referenced?


    I don't even understand how this could possibly be an issue. Does it matter if one starts out typing and plays around with the post for a while and THEN pastes the large block? Unless I am just brain-dead (and this problem makes me think I am) then I can't get it to work no matter how I select or deselect the BBCode box.

  • Pasting from Word, LibreOffice and similar apps is always an issue because they generate a lot of internal garbage code that is invisible to the naked eye, but inserted when pasting content. The editor then tries to figure out as best as possible what the pasted content should look like by making assumptions. Unfortunately this isn't always perfect and can lead to different results, in that case I need a proper source document that I can use to reproduce the issue and then work on fixing the cause of it.

    Alexander Ebert
    Senior Developer WoltLab® GmbH

  • Alexander thank you for responding. I just pasted, for a second, a long passage that I have in Libreoffice at the bottom of my last post. I pasted it, pressed submit, and it posted perfectly!!!! I did not leave it there because it is way off topic and I don't want to mess up the board here, but when I paste the very same clip in my own BB, I get the single paragaph jammed-together effect.


    I just tested that again - same browser, same computer, same clipboard paste from Libreoffice writer, and I get dramatically different results depending on whether I post on my forum or yours.


    Is there possibly some setting in the WYSIWYG editing engine I need to check?


    Thanks again.

  • woltlab.com uses a slightly modified version that will be shipped with the next update, but none of these changes have an impact on pasted content.


    If possible please send me the document you're experiencing issues with via email to ebert@woltlab.com, I'll try to see if I can find any reason for this. Please note that if you need to alter the contents (or re-create it) for privacy or other reasons, please double-check if the new content will also cause the described issues. Sometimes there is only a very tiny piece that overthrows the entire editor processing and making slight modifications could cause it to vanish.

    Alexander Ebert
    Senior Developer WoltLab® GmbH

  • @cassiusamicus Enabling HTML for posts exactly means that one has to use pure HTML to format a post, including manually inserting <br> to force line wraps. I cannot recommend every setting this on unless you know exactly what you're doing - when in doubt leave it off at all times.


    I still have you document around here and will look into it as soon as I can, currently have a rather long backlog of things to do first. Be assured that I'll take care of this before the next update is rolled out, so you're going to be on the safe side anyway :)

    Alexander Ebert
    Senior Developer WoltLab® GmbH

  • No, you can (and should) keep bbcode on otherwise you won't be able to use any formatting besides line breaks. Just keep html off and you're done :)

    Alexander Ebert
    Senior Developer WoltLab® GmbH

  • @cassiusamicus Enabling HTML for posts exactly means that one has to use pure HTML to format a post, including manually inserting <br> to force line wraps. I cannot recommend every setting this on unless you know exactly what you're doing - when in doubt leave it off at all times.


    I still have you document around here and will look into it as soon as I can, currently have a rather long backlog of things to do first. Be assured that I'll take care of this before the next update is rolled out, so you're going to be on the safe side anyway :)


    When you enable HTML for a post, does that mean the HTML code is rendered? I thought it was just to allow for typing code that can be viewed as text. I'm kind of slow though, lol.

  • When you enable HTML for a post, does that mean the HTML code is rendered? I thought it was just to allow for typing code that can be viewed as text. I'm kind of slow though, lol.

    Enabling HTML means that the HTML you type is exactly what is rendered in the final post, including JavaScript, iframes and all other stuff that is normally disallowed (and dangerous if used by inexperienced users).

    Alexander Ebert
    Senior Developer WoltLab® GmbH

  • Well I very much appreciate all the suggestions, but turning off html in the permissions for Everyone and Administrator (of which I am one) and then using Ctrl-Shift-V to paste still results in exactly the same result - text all jammed together with no paragraph breaks.

  • For me, pasting copied text with all the breaks and paragraphs in place only works if I disable BBcode in the post before pasting it. Then after I paste it I turn the BBCode back on and do whatever else I want with the message, like put quote tags around it, then submit the post.

  • I continue to thank each and every one who has replied.


    Something here does not pass the "smell test." No matter how I set BBCODE or HTML, I cannot get a page of text to paste into a post correctly. It looks great on the editing screen, then I press preview or submit, and bam it is all jammed together in the final product. On the other hand, when I paste the very same text here, on the official forum, it previews and posts with no problem.


    When I say this does not pass the smell test, I am not complaining. I mean I am anticipating now that something is wrong with my individual setup, because I cannot imagine that thousands of users are happily using Woltlab without this kind of simple pasting working. My confusion deepens when a FEW people here seem to have a similar problem, because I presume I am an idiot in setting this up (though I paid Woltlab to do it) or that my hosting service has some setting wrong (which is always possible). I consider my ability to make stupid mistakes to be unparalleled, so it baffles me that there could be others who have made whatever error I appear to have made.


    In the meantime I wonder if I could entice anyone reading this who has a similar problem to do a comparison test between their board, and posting here at Woltlab, to see if they can duplicate my experience of pasting working here, but not on their own forum.


    I feel confident that at some point someone is going to say "Did you check setting X?" and I am going to be revealed as the incompetent administrator that I probably am. In the meantime, I do appreciate knowing that there are a few others in my boat!


    ;-)

  • Just for fun I tried another test. I selected and copied my last post from here at the forum, went over to my forum, and pasted into a new thread with CTRL-SHFT-V. If I can get attachments here to work, I will paste a screen shot. You guessed it - mashed together!


    Edit: Just to eliminate another variable, I did this first in Flashpeak-Slimjet, which I understand to be Chrome-based, and then I did it in Chrome itself. Same result.

  • @cassiusamicus I finally managed to give it a try with the document you've send me and can't reproduce any of these issues with LibreOffice and Chrome, all though I've tested it on Windows 10 only. Would you be so kindly to submit a ticket and provide the required access credentials so I can run the same tests on your forums?

    Alexander Ebert
    Senior Developer WoltLab® GmbH