Trying to update 4.1.5 to 4.1.9, getting nginx 504 timeout errors

  • ACP notifies me I have 4 updates pending. In fact, I definitely need to update at least wcf to install Gallery.


    When I try, I get the spinning "Loading" icon for a while, then "nginx 504 : gateway timeout"


    Any clues as to what I can try? I already tried upping the proxy timeout on my nginx install, that didn't seem to help


    Thanks

  • Are you trying to update everything at once or each package individually?


    I had problems updating packages before with timeout errors and the solution was to update them one at a time.

  • Have you tried to upgrade using the package from this website and uploading it ?

    Yes, I downloaded the 4.1.9 update, put it on the server, went to "Install Packages", selected the file location, and got this. Is there somewhere else I should be going to "update" vs. "install" ?


    The package cannot be installed, please review the validation results below.
    PropertiesIdentifiercom.woltlab.wbbVersion4.1.9Package DateDec 20th 2015DeveloperWoltLab GmbH


    PackageIdentifierStatusThe package “WoltLab Burning Board” (installed version: “4.1.5”) should be updated to version “4.1.9”, but an update is not supported.

  • Probably don't work cause trying to update to big of gap between version numbers, might have to do it one at a time. 4.1.5 > 4.1.6 > 4.1.7 > 4.1.8 > 4.1.9 etc..there's min-required version number in xml file for installer, if 4.1.9 says "min required 4.1.8" then you have to do it gradually I think. Or I could be wrong.

  • Probably don't work cause trying to update to big of gap between version numbers, might have to do it one at a time. 4.1.5 > 4.1.6 > 4.1.7 > 4.1.8 > 4.1.9 etc..there's min-required version number in xml file for installer, if 4.1.9 says "min required 4.1.8" then you have to do it gradually I think. Or I could be wrong.


    Thanks for the tip! That worked, going 6 - 7 - 8 - 9. Was used to vBulliten, which would always walk through from version to version no matter which patch you downloaded.


    Have you tried to update via the package server?


    I don't know if that would have made any difference. However, once I was on 4.1.9 and wcf was up-to-date, the package server route worked perfectly for installing Gallery!


    Thanks again to everyone for your help