Importer: some bugs and ideas to improve data import from IPB 3.4.x

  • I have few things to report about Importer, when importing data from IPB 3.4.x into WBB


    1. Quotes in IPB can be also in simple format:


    Code
    [quote name="some name"]some content[/quote]

    Currently such quotation is not converted.


    2. Something is wrong when converting formatting options, for example this (this is how it looks in database):

    Code
    <p><span style="color:rgb(28,40,55);font-family:arial, verdana, tahoma, sans-serif;font-size:13px;background-color:rgb(250,251,252);">content</span></p>

    is converted to this (and does not work, it is showed as text):


    Code
    [color=rgb(28,40,55);font-family:arial, verdana, tahoma, sans-serif;font-size:13px;background-color:rgb(250,251,252)]content[/color]

    This is happening both in post content and signatures. Probably this situation can exist if user in IPB pasted post content from other website/place without cleaning formatting options, so IPB saved his port with that formatting.


    3. Some links are surrounded with:


    Code
    <!-- l -->
    or
    <!-- m -->

    (in IPB database there are also such surroundings in some links, but they are invisible in thread view, don't know from where they came from)


    4. In signatures:


    Code
    [size=2]content[/size]

    was converted to:


    Code
    [size=36]content[/size]

    which resulted gigantic signatures for some users after conversion. I saw that sometimes in IPB database there are signatures with:


    Code
    [size=NaN]content[/size]

    which are converted to size=36 as well.


    5. If in board name chars "<" or ">" are present, they are replaced to:

    Code
    > or <

    6. Looks like warnings are not imported at all (?)

    Edited 3 times, last by PolUser ().

  • Update to 2:


    Looks like this is something more complicated.


    Post in IPB database:


    was converted to:


    Because HTML is disabled by default - post is showed with visible HTML code. I'm not sure is it bug, because HTML tags are preserved, but this would lead to need to manually turn on HTML for some particular posts...

  • One more, sorry for that, but I'm still evaluating data after conversion :(


    Looks like in pools titles some chars are as HTML entities, eg. " is as & quot; (of course without space ;) )

  • Please don't kill me - I got one more :P


    When importing additional profile fields - language strings are added only to default board language, not for all languages, which give result in names for other languages "wcf.user.option.option30" etc.