Awaiting Approval of Started Thread

  • On my Forum, I have set the permissions in some of the Forums so that a MEMBER has to have admin or mod approval when a new Thread is started.



    However, it has recently come to my attention that if the Member who started the Thread which is awaiting approval, logs out and then logs back in again, he will have the Moderation Box highlighted in the top task bar of the Forum.
    Clicking on the "moderation box" brings up the Thread awaiting approval, and if that Member clicks on "approve" at the bottom of the new Thread, the Thread is approved!


    Also, any other registered Member will have this same Moderation Notice, and if he clicks on the notice and then clicks on the "approve" link in that Thread awaiting approval, it does indeed get approved !


    However, I was under the impression that ONLY the [color=#8B4513]ADMIN or MOD could approve[/color] Threads "awaiting approval".[color=#0000CD][/color]
    So what settings am I configuring incorrectly (or perhaps have not configured at all) to make the above described situation occur?




    Dave

  • On my Forum, I have set the permissions in some of the Forums so that a MEMBER has to have admin or mod approval when a new Thread is started.

    Prepare to be frustrated :) . Did you create a new user group and place the users you want to have this restriction in it?

  • However, it has recently come to my attention that if the Member who started the Thread which is awaiting approval, logs out and then logs back in again, he will have the Moderation Box highlighted in the top task bar of the Forum.
    Clicking on the "moderation box" brings up the Thread awaiting approval, and if that Member clicks on "approve" at the bottom of the new Thread, the Thread is approved!

    Not tested that yet, but have you reported that back to WoltLab?

  • Just tested it now with the restricted group set-up I have, logged-out after making thread on my test account that gets put into moderation, then logged back in again with forum and can't see any moderations options to approve my own topic doing that?


    Sounds to me like you have somehow given the group moderator permissions by mistake, and also have that groups posts going into moderation via forum permissions to reject posting without approval

  • Moderators can approve their own threads that are waiting for approval. If you don't like to do so, you need to disallow the specific right(s) in the forum permissions settings.

  • However, I was under the impression that ONLY the ADMIN or MOD could approve Threads "awaiting approval".
    So what settings am I configuring incorrectly (or perhaps have not configured at all) to make the above described situation occur?

    This group that you have for members to need their posts moderating. Is it a new group you created? If yes, you didn't clone the moderator group did you to create it. If it is an extra group added, click the Mod Permissions TAB under that Usergroup and make sure nothing is ticked (and same for all other sub sections under that tab). Same thing with Admin Permission TAB as well. The only two groups that should have any boxes ticked under Mod and Admin tabs is Admins and Mods groups.


    Only General Permissions TAB, and all sub sections under it are used for normal members


  • The easy way to create a new group that when users are moved into it, they have all their threads and posts moderated.


    1: Clone a new group based on USERS group (that already has the boxed ticked Yes for can post threads and posts without approval). So your cloned new group of it has same boxes ticked yes as well.
    2: Then with all forums you have created, go to forum permissions for each one they can post on, and for custom group (add it to each forum) and tick No for can start threads and posts without approval (picture below).




    3: Keep in mind when you move a member into the new group created (mine is called restricted). That you must make sure they are "only in that one group" (so that is their primary group, and not listed in multiple groups like "Users and Restricted" at same time (not two boxes ticked), otherwise they will still inherit permission from USERS group to post without approval. Picture below to show again what I mean for a user put in the group.


    When you want to move them out the moderated group just untick that one box - then put them back in USERS group ticking that box instead "same as they was originally".


    I have auto promotions set-up on my forum though to move users auto into all the different groups added based (first) on USERS group having a minimum of 0 points, so I could just untick that restricted box, save it ticking none at all and they still moved in correct groups later when cron job next runs promotions.


  • Thanks to PJK, GTB, and fauha for your comments and help!


    Following GTB's suggestions, I went back into the particular Forum whereby this issue surfaced in the first place and noticed that
    (as Administrator) I had made some Permissions Settings that should not have been made.


    Then I checked the "Moderative Permissions" and "Administrative Permissions" for EVERY USER GROUP that I have on my Forum - of which total 9.
    Indeed, a few had to be "corrected" - as GTB pointed out.


    In the meantime a MEMBER had logged into my Forum and left a comment (of which had to be approved).
    A friend of mine checked it out (logged in as a Member) and told me he couldn't "approve" the comment; so that was good.
    Then I (logged in as Administrator) "approved" the comment; and that worked correctly.


    As for the remainder of the Categories and Forums I have established on my Forum (there are over 100 in total) its going to take awhile
    to make sure I have all Permissions checked the way I want them for every Category and Forum; but perhaps an easier (less time consuming) method is to follow GTB's instructions directly above THIS post?


    Again, thanks to all of you who extended their time and effort to helping me regarding this issue!


    Dave