Fatal error when deleting a thread

  • Hi there is an error occurred when I wanted to delete a thread.



    Fatal error: An error occured. Sorry.
    Information:


    ID: 905a6dff34dab278d31a82c271fbd0e853b1e3b6
    Please send the ID above to the site administrator.
    The error message can be looked up at “ACP » Logs » Errors”.
    WCF::destruct() Unhandled exception: SQLSTATE[HY000]: General error: 2006 MySQL server has gone away#0 /home/xcibaico/public_html/wcf/lib/data/DatabaseObjectEditor.class.php(68): wcf\system\database\Database->prepareStatement('UPDATE\twcf1_ses...')#1 /home/xcibaico/public_html/wcf/lib/data/acp/session/ACPSessionEditor.class.php(42): wcf\data\DatabaseObjectEditor->update(Array)#2 /home/xcibaico/public_html/wcf/lib/system/session/SessionHandler.class.php(857): wcf\data\acp\session\ACPSessionEditor->update(Array)#3 /home/xcibaico/public_html/wcf/lib/system/WCF.class.php(175): wcf\system\session\SessionHandler->update()#4 [internal function]: wcf\system\WCF::destruct()#5 {main}Is that normal? :|

  • when I try to restore the thread, I received another error.



    {"code":503,"message":"The server encountered an unresolvable problem, please try again later.","returnValues":[],"exceptionID":"66b8502049929738044ffc1ee15132c04bea8f52"}
    WCF::destruct() Unhandled exception: SQLSTATE[HY000]: General error: 2006 MySQL server has gone away#0 /home/xcibaico/public_html/wcf/lib/data/DatabaseObjectEditor.class.php(68): wcf\system\database\Database->prepareStatement('UPDATE\twcf1_ses...')#1 /home/xcibaico/public_html/wcf/lib/data/acp/session/ACPSessionEditor.class.php(42): wcf\data\DatabaseObjectEditor->update(Array)#2 /home/xcibaico/public_html/wcf/lib/system/session/SessionHandler.class.php(857): wcf\data\acp\session\ACPSessionEditor->update(Array)#3 /home/xcibaico/public_html/wcf/lib/system/WCF.class.php(175): wcf\system\session\SessionHandler->update()#4 [internal function]: wcf\system\WCF::destruct()#5 {main}

  • Do you use an older MariaDB as database for you wcf? There are some german thread here (just use search) regarding a bug in some versions of MariaDB with SQL prepared statements that are used by wcf. I think there should be a newer version of MariaDB that fixes those SQL prepared statement issues.

  • Thank you for your help, I guess I will use google translator ;/
    Hmm, maybe I need to seek support from my web hosting provider.


    Currently MariaDB for my shared web hosting:
    root@pam [~]# mysql --version
    mysql Ver 15.1 Distrib 5.5.46-MariaDB, for Linux (x86_64) using readline 5.1

    Edited once, last by siong ().

  • Well, I don't know if it is fixed in 5.5.46...


    According to this bug ticket at maria db version tree 5.5, 10.0 and 10.1 are affected, and there are fixed versions for 10.0.22 and 10.1.19... nothing said about the 5.5 tree.

  • received the solution from support, either make a downgrade to version 5.5.44 or an upgrade to 10.0.22 or 10.1.9


    However, I'm using shared hosting so I'm not allowed to do so. No budget for vps or dedi. Thinking to change web hosting provider.


    UPDATE*
    Switched to Hawkhost, it works well now.

    Edited once, last by siong ().