Installation Error - Line 34

  • Trying to install wBB 3.1.8 locally with Apache 2.4, php 5.6, mysql 5.6 on a Windows 7. It's been ever so long since I've attempted anything of the sort, so this may be an obvious fix. I'm getting the follow error when trying to run the install script.


    Quote

    Parse error: syntax error, unexpected '@', expecting ')' in C:\Windows\Temp\ec829b9f_2003_stepSelectSetupLanguage.php on line 34


    OR


    Quote

    Parse error: syntax error, unexpected 'bb4769dc99f9534e2a7a10244ce1ff' (T_STRING), expecting ')' in C:\Windows\Temp\dacf9a07_2003_stepSelectSetupLanguage.php on line 34


    When I searched I could only find two options to resolve. First was keep hitting refresh until it works. Done that for several minutes, and it's not doing anything for me. The second was to downgrade to php 5.4. Does anyone know what the issue is here, or how to solve it without changing my php installation?

  • I assume you are trying to install it on locahost? If my memory isn't tricking me, I remember I encountered a similar problem twice back when I used wbb 3.1.x The first time I think it was a simple problem of folder permission in Xampp, once I set them to 777 the errors disappeared. In the second case, it was related to PHP caching addon. Disabling all but memcache fixed the problem. Give it a try.


    Hopefully, someone with more insight or experience with this problem might be able to chime in and help.

  • I assume you are trying to install it on locahost? If my memory isn't tricking me, I remember I encountered a similar problem twice back when I used wbb 3.1.x The first time I think it was a simple problem of folder permission in Xampp, once I set them to 777 the errors disappeared. In the second case, it was related to PHP caching addon. Disabling all but memcache fixed the problem. Give it a try.


    Hopefully, someone with more insight or experience with this problem might be able to chime in and help.

    Yes, I am installing locally to develop before going online. I can't adjust permissions to 777, because I'm running Windows. Back in the day... it was automatic if you were on a Windows server. Has it changed? I'm using Windows 7 Home Premium.


    I have tried to downgrade PHP at this point, now running 5.5 and it's still giving me the exact same error.


    Can you explain more about the caching issue? I would like to try this to see if it helps.

  • Thinking of it, I believe that cache settings isn't the problem here, since you are using a local installation, and the main cause could actually be related with file permissions.


    If you installed Xampp under C:\... then UAC (User Account Control) could be in the way -- try disabling it in control panel, and see if you keep experiencing those errors during wbb installation.


    Windows doesn't allow to change and fine tune file permissions the same way as Linux does, (it's more like all or nothing) and installing Xampp under C:\ (which the system considers Windows 'root') might actually trigger PHP errors related to permissions. First off, you want to check PHP-log shows warnings or errors concerning file permissions. If that's the case, you will have to find out under what user name Apache is running (via Administrative Tools, Services), and then add read/write permissions for that user in the appropriate folder.

    Edited once, last by rafix73 ().

  • Thinking of it, I believe that cache settings isn't the problem here, since you are using a local installation, and the root cause could actually be related with file permissions.


    If you installed Xampp under C:\... then UAC (User Account Control) could be in the way -- try disabling it in control panel, and see if you keep experiencing those errors during wbb installation.


    Windows doesn't allow to change and fine tune file permissions the same way as Linux does, (it's more like all or nothing) and installing Xampp under C:\ (which the system considers Windows 'root') might actually trigger PHP errors related to permissions. First off, you want to check PHP-log shows warnings or errors concerning file permissions. If that's the case, you will have to find out under what user name Apache is running (via Administrative Tools, Services), and then add read/write permissions for that user in the appropriate folder.

    I didn't install anything with a third party program like Xamp. Apache is located at c:/apache24 and php is located at c:/php as I recall this being the best physical setup previously. My php error log shows only the error that I've reported here after accessing the install script. Otherwise, there are no errors when starting up the server and php. Apache is running as a service using the local system account. I am logging into the computer on an administrator account. Here's some pictures if that helps explain more...? The Apache files (httpd-2.4.16-win64-VC11) were from Apache Lounge, as per php.net recommended on the Windows php download page.

  • I didn't install anything with a third party program like Xamp

    Ah, considering we were talking about a local installation, I automatically assumed you did -- my bad. Both Xampp or Wamp simplify the bundled installation of Apache, MySQL, and PHP in your system, and make life easier when you want to test wbb locally.


    You should give it a try, just make sure application that use ports 80 and 443, such as Skype aren't running when you launch the webserver.


    I just installed Xampp on Windows 7 Ultimate, and I had no troubles, error, or hiccups installing wbb 3.1.8 in it. Why make our life harder when some tools can make it easier? Give it a shot ;)

  • Ah, considering we were talking about a local installation, I automatically assumed you did -- my bad. Both Xampp or Wamp simplify the bundled installation of Apache, MySQL, and PHP in your system, and make life easier when you want to test wbb locally.
    You should give it a try, just make sure application that use ports 80 and 443, such as Skype aren't running when you launch the webserver.


    I just installed Xampp on Windows 7 Ultimate, and I had no troubles, error, or hiccups installing wbb 3.1.8 in it. Why make our life harder when some tools can make it easier? Give it a shot ;)

    You used to read nothing but problems about using packages like that before. I did a quick read before deciding to go manual this time, and read nothing but complications & people having to go in and do manual configurations anyhow. Which version did you use? The one with php 5.5 or 5.6? I'm at the point where I'm considering it now.


    Also, it looks like the page you linked is 32bit and I'm on a 64bit OS. If you were running all 32bit installations I might try that manually before resorting to a third party software.

  • I agree that some time ago such programs had issues, but today they have become rather intuitive and easy to configure. The most common problems you actually see today are related to users not being able to start Apache or MySQL, usually because they share common ports (80, 443) with apps like Skype. If that's the case, the trick is simple, instead of fumbling with Xampp config files and change ports (which perse isn't really harder than editing the file and type another number), simply close those apps before starting Xampp and all goes well.


    Concerning Xampp version, I used the one having PHP 5.6. Only the 32bit version of Xampp is available for Windows, but it works without problems in a 64bit system. For instance, today I installed Xampp on Windows 8.1 64bit and ran a wbb 3.1.8 test install in it, which went without hiccups. Xampp should work well on Windows 10, too.


    Really, you shouldn't encounter any major issues, and using Xampp will simplify things and allow you to test all you like in safe environment. If you have any problems with Xampp, I'm happy to help you out along the way, but I'm sure you won't have many.



    Edited once, last by rafix73 ().

  • Sure. Through the years, I have also tried and used with success the various Wamp, EasyPHP, and Mamp (for Mac OS), but sometimes when you start with one program that serves you well, you tend to stick with it ;)

  • Well thank you so much for all of your replies, and helping me hash through this so far! I'll give the php 5.6 version a go next time I get a chance from the link you posted. Could be a few days, I have two children under two years old right now & a birthday party this weekend, but I'll let you know how it goes! :) I've forgotten how much I miss doing this stuff! I'm excited to get something up again even if I just end up designing locally.

  • You are welcome. It does sound like you'll have your hand full this weekend :)


    I'm sure you have missed setting up, designing, and organizing sites/forums, and even more if you used to really be into it in the past, as it sounds you were. And yes, give Xampp a try and see how it goes. If you'll need any help with it let me know.


    Enjoy your weekend, and the party ;)

  • OK completely uninstalled everything I did, and restarted the system. Downloaded XAMPP win32-5.6.8-0-VC11, ran the installer to the default location, started apache & mysql with no errors... but I'm still getting this error when I run the wBB installer!


    Quote

    Parse error: syntax error, unexpected 'df025bd4be7b10dac7a82eae3e0396' (T_STRING), expecting ')' in C:\xampp\tmp\05e159a8_1003_stepSelectSetupLanguage.php on line 34


    I'm not sure if that makes me feel better, or worse. :| Despite not being the current version, I'm sure this did work for many people before. What gives! I didn't adjust anything for fear I'd goof it up somehow.

  • It's an odd problem, but it can fixed. Go back to our convo and try to troubleshoot it as I suggested, and let me know how it goes there or here.

  • And here's from the php error log below - forgot to post that. These errors, save the line 34, are all new errors. I never had them with the manual server installations. I think some may be the results of me exploring XAMPP.



    Here is the apache error log below.



    Here is the mysql error log below.



    Will update with results of your suggestions as I manage to complete them. Just thought I'd post this in case someone sees something.

  • Yes, try what I suggested, and let see if in the meantime someone with 3.1.8 experience encountered similar problems, and is willing to share.


    But I have another question in the meantime. Did you remove MySQL, Apache, and PHP that you installed manually before trying Xampp? I just realized that I forgot to mention that. Maybe those errors are "leftovers" (and possibly the result of some conflict) of one installed with Xampp.

  • So, rafix73 and I ended up doing a pile of troubleshooting to see if this error could be resolved. In the end here's what we tried:


    • Manually reinstalling apache, php, and mysql
    • Downgrading php
    • Using a 32-bit version of php
    • Removing Skype
    • Disabling UAC on Windows
    • Automated reinstalling apache, php, and mysql
    • Checking the disk for errors
    • Checking the memory for issues
    • Removing all temporary files
    • Disabling anti-virus & firewall
    • Redownloading the wBB3 files
    • Installing older versions of wBB3 and wBB2



    After absolutely nothing seemed to make any difference I gave up on using Windows. The solution was to setup a local lamp-server on Ubuntu Desktop 14.04 LTS. The only issues I had with installing that was was forgetting to CHMOD, and that was easily resolved. So the issue isn't with wBB it's something to do with Windows.