Please add the ability to disable plugins

  • Hi



    You talking about the IP Tools plugin?YOu did not have to do such a "Mess"


    1. go to wcf1_package delete the faulty package
    2. empty cache /wcf/cache wcf/templates/compiled
    3. working again ;)

    Stop giving such advice. While this may have worked for that plugin (I did not check) it definitely does not work for every plugin.

  • Hi

    this was working for that...

    It is not. The plugin ships with some templates. They won't be removed by using your method and once you delete the entry in wcf1_package one cannot perform a clean uninstallation of the package.

  • It is not. The plugin ships with some templates. They won't be removed by using your method and once you delete the entry in wcf1_package one cannot perform a clean uninstallation of the package.

    but it comes with an event-listener which isn't removed so a new installation will fail


    I was using that plugin, and at the same time as adam tried to update I did the update as well.
    It failed for both of us, I deleled the package, the cache and page was working again.
    Then clean uninstall of the ip tool packages and then after (1st fix) again install fresh.
    Fail again, so i did the steps again


    Finally, sascha fixed it with pl2 and i did clean install of all ip tool packages


    No problem there, So for that plugin my steps are working and way faster than removing completely wbb html/sql and using a backup

  • You talking about the IP Tools plugin?YOu did not have to do such a "Mess"


    1. go to wcf1_package delete the faulty package
    2. empty cache /wcf/cache wcf/templates/compiled
    3. working again ;)

    That is no guarantee, because it would leave entries in your database. It is possible depending on the plugin that it would then be still trying to load something that isn't there.


    That is not something I would recommend.




    edit: I think we're getting off topic...



    It doesn't matter which plugin. The concept of needing something to disable things safely is very important. So important that every mainstream development such as IP.Board, XenForo, vBulletin, WordPress, ect... Has included it.

  • Not always because of Referential integrity (using foreign keys where possible).

    True, but that's something more people wouldn't know or think to check (unless you're developing something or working with the raw code).


    The average 'end user' is going to look for something as simple as a check box to disable add-ons as they would in any other development such as WordPress, vBulletin, IP.Board, or XenForo.

  • @Marcel Werk This is critical.


    It should be included in WCF 2.2. It is the one drawback that actually has forced me to look elsewhere concerning other projects that I manage and it is something standard in ALL your competition.


    Please consider this.

  • I'd rather have seen this included in 4.2 than Extended Ignore, lol. Ability to disable plugins to determine bad/culprit plugins which break the site is more important than an ignore feature. But... priorities aren't always right around here lol.

  • As much as I'd love to see it in 4.1 or even 4.2, it's probably not going to be possible in any future 4.x series, most likely in 5.x series. I could be wrong though, but I'm not sure. Just seems like too big of a change for 4.x series (would almost have to built-in from ground up while developing new version series), and factoring in upgrade compatibility issues that might arise etc.


    I'd still like to see this happen for 4.2 though: Prevent display of update notifications for plugins with new versions not purchased. And maybe a plugin for it for 4.1. :P