Zentrierung nicht korrekt

  • Hoi,
    ich habe heute meine kleine HP aktualisieren wollen und mir dabei ein kleines Script eingebaut, welches ein Menu ausklappt. Das Problem: das Menu namens "Links" ist nicht zentriert, sondern etwas nach rechts verschoben, dadurch passt es natürlich nicht zur Grafik darüber, hier ein Link:
    http://xeno.game-aktuell.de


    Könnte es daran liegen, dass es sich bei dem Menu um eine Liste handelt und diese mit einem Listenzeichen beginnt? Wenn ja, wie kann ich das eleminieren? Habe schon vieles probiert aber nichts half.



    Außerdem würde ich die Seite gerne mal valid bekommen, aber das hießige Problem hat Vorrang. ^^

  • Code
    ul {
    	padding: 0;
    }


    sollte das Problem beheben ;)

    Demjenigen, der link ist, ist alles recht.

    Das Gute - dieser Satz steht fest - ist stets das Böse, was man lässt!

    Perfektion ist ein stummes Gut.

  • Ich möchte mich hier nochmal melden, weil ich nun immernoch einige Probleme mit dem Validieren habe. Scheinbar keine einfachen Synthaxfehler sondern seltsame Fehler, die ich nicht zu deuten verstehe:
    http://validator.w3.org/check?…2Fxeno.game-aktuell.de%2F


    Besonders diese: there is no attribute "height", was mich auf " und > verweist. ?(
    Außerdem scheint embed irgendwie Probleme zu machen, dabei habe ich den Code 1zu1 von selfhtml -oder einer ähnlichen Seite- übernommen.

  • Laut meinem Validator ist <embed ...> kein W3C-Standard mehr und daher fehlerhaft. Es gibt doch glaube ich noch eine andere Möglichkeit oder?

    Mit freundlichem Gruß
    Tristan "Gemini" Gottschling

  • Naja geben würde es noch


    Code
    <bgsound src="blabla" loop="infinite">


    oder man könnte es als Objekt einbinden.


    Code
    <object data="harddrivers.mp3" type="audio/x-mpeg">
    	<param name="src" value="harddrivers.mp3">
    </object>


    Diese Angaben sind wie immer ohne Gewähr *peng* ;)


    Eine Frage an dich Xeno³:


    Warum nimmst du eigentlich Xhtml1.0 Frameset? Ich würde da eigentlich Xhtml1.0 Transitional nehmen.

    "coding styles are like assholes, everybody has one, but nobody likes anyone elses"
    KEIN SUPPORT PER PN!


  • Vielen Dank, ich konnte nun die Fehler auf 3 reduzieren.
    Bgsound wurde im FF nicht abgespielt und war scheinbar ebenso invalide wie embed. :D
    Der andere Möglichkeit ging super. Der Sound hört sich zum Teil sogar besser an. 8|
    Weiter habe ich jetzt den Doctype geändert, hatte da den Kopf von meiner Alienseite reinkopiert, was ich vergessen hatte war, dass ich dort das Frameset verwenden musste.

  • oh hab noch nen fehler entdeckt, hatte vergessen den param-tag zu schließen:


    So müsste er richtig heißen:

    Code
    <param name="src" value="harddrivers.mp3" />


    und gib mal bei den Links statt & einfach

    Code
    & amp;

    ein, das dürfte noch einen Fehler beseitigen (natürlich ohne leerzeichen).

    "coding styles are like assholes, everybody has one, but nobody likes anyone elses"
    KEIN SUPPORT PER PN!


  • Ja die Encodierung wurde nicht gesetzt, im <head>-Bereich nur:


    Code
    <meta http-equiv="Content-Type" content="text/html;charset=utf-8" />


    einfügen, dürfte funzen.

    "coding styles are like assholes, everybody has one, but nobody likes anyone elses"
    KEIN SUPPORT PER PN!


  • Kein Problem, sind ja nicht wirklich weltbewegende Sachen gewesen ;)

    "coding styles are like assholes, everybody has one, but nobody likes anyone elses"
    KEIN SUPPORT PER PN!