Show Forums not working

  • Hi, over the past 2 days I imported around 3000 forums, after I exceeded 1000 the Show Forums (content->forums->show forums) started acting up, whenever i clicked Submit on that page (after changing order or something) it would log me out and not do the changes. Still, no big deal as I can just go in and change them individually. But now when I have 3000 forums, the Show Forums page just crashes, does not show anything, Internal Server Error.


    Now I can't really modify the forums that I already have, I can still make new forums forums and everything else works, it is just this one page in ACP.


    I think this is the error ERR_CONTENT_DECODING_FAILED


    Thanks for your help!

    Edited once, last by akotalik ().

  • Please check the webserver's error logs, as "Internal Server Error" is one of the most meaningless errors that can occur :/ If you cannot submit the page, you're most likely running the PHP extension "suhosin" which comes with an already broken configuration, preventing rather large forms from submitting.

    Alexander Ebert
    Senior Developer WoltLab® GmbH

  • Well this is all I got from it, unless I am looking in a wrong place (which is entirely possible, sorry)


    Error 330 (net::ERR_CONTENT_DECODING_FAILED): Unknown error.


    Sorry to bother you so much :)

  • Yeah I got that, but I think the problem is me- I don't know where to look :D I have the CGI error log in my fatcow control panel, but it is empty. The normal log does not contain any errors

  • Please upload the attached phpinfo.php to your webspace and post the link, furthermore you better get in touch with the support staff of fatcow and ask for their assistance.

    Files

    • phpinfo.php

      (17 Byte, downloaded 48 times, last: )

    Alexander Ebert
    Senior Developer WoltLab® GmbH

  • I've looked through the configuration and noticed a low memory_limit, it is currently set to 32 MB which is a bit small, especially if running configuration options for rather huge setups, the current recommendation by the PHP developers is 128 MB. Please ask your hosting company to raise that limit, for example to 64 MB and keep an eye on the system stability. If the issues persist, please get in touch with your hosting company and ask them for assistance in order to track down the problem.


    You can safely remove the previously uploaded phpinfo.php.

    Alexander Ebert
    Senior Developer WoltLab® GmbH

  • Nice, that was the issue. I asked them to raise it to 128 and it works again. Thanks a lot Alex, if you ever get to American Midwest, I probably owe you a beer for all your help :D