Neuinstallation von 3.1.6

  • Hallo,


    ich versuche gerade, mir das wbb 3.1.6 auf mein Forum zu installieren - vorhandene Version 3.1.2. soll überspielt werden.
    Ich komme bis zu 12% der Installation, also der Prüfung der Systemvoraussetzungen, bei denen alles grün, also ok, angezeigt wurde. Danach leitet der installer mich aufs ACP um, allerdings nicht auf das vom burningboard, sondern zu burningpedia, und zeigt mir dort in der Infobox folgenden Fatal Error an:




    Fatal error: PHP notice in file
    /var/www/web382/html/potter/wcf/acp/templates/compiled/208_1_index.php
    (116): Undefined index: updateType






    Information:



    error message: PHP notice in file /var/www/web382/html/potter/wcf/acp/templates/compiled/208_1_index.php (116): Undefined index: updateType
    error code:

    0
    file:

    /var/www/web382/html/potter/wcf/lib/system/WCF.class.php (281)
    php version:

    5.2.11-0.dotdeb.0
    wcf version:

    1.1.2 (Tempest)
    date:

    Thu, 13 Oct 2011 21:40:30 +0000
    request:

    /wiki/acp/index.php?
    referer:

    http://www.hp-ff.at/wcf/acp/index.php?form=Login&packageID=1&




    Stacktrace:


    #0 /var/www/web382/html/potter/wcf/acp/templates/compiled/208_1_index.php(116): WCF::handleError(8, 'Undefined index...', '/var/www/web382...', 116, Array)
    #1 /var/www/web382/html/potter/wcf/lib/system/template/Template.class.php(267): include('/var/www/web382...')
    #2 /var/www/web382/html/potter/wcf/lib/page/AbstractPage.class.php(100): Template->display('index')
    #3 /var/www/web382/html/potter/wcf/lib/page/AbstractPage.class.php(46): AbstractPage->show()
    #4 /var/www/web382/html/potter/wcf/lib/util/RequestHandler.class.php(64): AbstractPage->__construct()
    #5 /var/www/web382/html/potter/wcf/lib/util/RequestHandler.class.php(101): RequestHandler->__construct('Index', Array, 'page')
    #6 /var/www/web382/html/potter/wiki/acp/index.php(3): RequestHandler::handle(Array)
    #7 {main}





    Installation wurde nach Vorschrift durchgeführt; Daten hatte ich (logischerweise) für das 2. Mal installieren neu hochgeladen.
    Kann mir jemand erklären, wo mein Problem liegt?

  • Wird wohl einfach am BunringPedia liegen ;)
    Ist es auf der aktuellsten Version?

    Liebe Grüße,
    Lacelte

    Seelenschmerz-Forum
    Selbsthilfeforum für Betroffene und Angehörige psychischer Erkrankungen.


    Entziehe der Gruppe "Jeder" alle Rechte und du wirst nie Probleme mit den Benutzergruppen-Berechtigungen bekommen!

  • Wenn du mir sagst, wo ich das sehe?
    Weder in der Fußzeile des Wikis noch im ACP des burningspedias steht da was von einer Version.
    Das hatte mein Vorgänger aufgespielt, etwa anderthalb Jahre her....ich habs so übernommen.
    Könnte ich das abkoppeln vom wbb, ohne, daß die Daten verloren gehen, wenn es denn am burningpedia liegen würde?

  • Quote

    Wenn du mir sagst, wo ich das sehe?


    Option-Paketverwaltung-Pakete auflisten.
    Dort suchst du das BurningPedia und dort steht auch die Version.


    Bitte mache bevor du etwas am Forum machst, immer ein BackUp von der Datenbank und vom FTP - gerade wenn du dich nicht gut auskennst ist das ratsam; eig. immer.

    Quote


    Das hatte mein Vorgänger aufgespielt, etwa anderthalb Jahre her....ich habs so übernommen.


    Dann ist es wahrscheinlich eine ältere, schau mal nach.

    Quote


    Könnte ich das abkoppeln vom wbb, ohne, daß die Daten verloren gehen, wenn es denn am burningpedia liegen würde?


    Nicht das ich wüsste.

    Liebe Grüße,
    Lacelte

    Seelenschmerz-Forum
    Selbsthilfeforum für Betroffene und Angehörige psychischer Erkrankungen.


    Entziehe der Gruppe "Jeder" alle Rechte und du wirst nie Probleme mit den Benutzergruppen-Berechtigungen bekommen!

  • Backups werden jede Nacht automatisch vom Hoster gemacht


    BurningPedia 1.0.0 Beta2 (auf die paketverwaltung hätt ich auch selbst kommen können :pinch: )

  • Warum machst du dann eine Neuinstallation, und führst kein Update durch?


    So wie ich das verstehe, möchte er/sie doch updaten, sonst hätte er/sie nicht das Problem mit dem BurningPedia.

    Quote

    ich versuche gerade, mir das wbb 3.1.6 auf mein Forum zu installieren - vorhandene Version 3.1.2. soll überspielt werden.


    Quote

    Backups werden jede Nacht automatisch vom Hoster gemacht

    Sind das Firmen-Interne BackUps oder kommst du an sie auch heran?
    Würde immer BackUps auf meinem Rechner legen.
    Habe auch schon erlebt, das solche Sicherungen vom Hoster, die man zb. auch selbst über zb. Confixx anlegen kann, später gar nicht funktionieren oder anderweitige Probleme gibt.
    seit dem her nutze ich ur noch MySQLDumper - damit werde ich net enttäuscht und habe die Datenbank sicher auf meinem Rechner liegen.


    Aktuelle VErsion von BP ist 1.1.1
    Würde ja sagen, das du es auf die aktuellste Version erst mal bringst.

    Liebe Grüße,
    Lacelte

    Seelenschmerz-Forum
    Selbsthilfeforum für Betroffene und Angehörige psychischer Erkrankungen.


    Entziehe der Gruppe "Jeder" alle Rechte und du wirst nie Probleme mit den Benutzergruppen-Berechtigungen bekommen!

  • ich kann kein update durchführen, da die lizenz abgelaufen ist und wir eine neue kaufen mussten, daher komplettpaket.


    da wir schon einmal auf ein backup zurückgreifen mussten, weiß ich, daß die ok sind. ich selbst hätte den platz nicht auf dem rechner.die backups sind jederzeit verfügbar, anruf genügt.


    kann ich das burningpedia so updaten oder brauch ich auch dafür eine lizenz?
    sry, wie gesagt, ich hab das übernommen und mein vorgänger hatte mich dumm sterben lassen in der hinsicht.

  • ich kann kein update durchführen, da die lizenz abgelaufen ist und wir eine neue kaufen mussten, daher komplettpaket.


    Also installierst du es doch komplett neu?
    Mit neuer Datenbank und neuem FTP-Ordner?


    Warum kannst du denn nicht Updaten, verstehe ich net so recht? ;)

    Liebe Grüße,
    Lacelte

    Seelenschmerz-Forum
    Selbsthilfeforum für Betroffene und Angehörige psychischer Erkrankungen.


    Entziehe der Gruppe "Jeder" alle Rechte und du wirst nie Probleme mit den Benutzergruppen-Berechtigungen bekommen!

  • Das geht aber so auch nicht.
    Du kannst nicht in einer vorhandenen Datenbank ein neues Forum installieren und diese weiterhin benutzen.


    Du musst einfach nur die aktuelle Version des Forums unter Paket suchen oder Automatische Updates im ACP rüber bügeln.


    EDIT:

    Quote

    da wir schon einmal auf ein backup zurückgreifen mussten, weiß ich, daß die ok sind. ich selbst hätte den platz nicht auf dem rechner.die backups sind jederzeit verfügbar, anruf genügt.

    Ist nur doof, wenn es mal Probleme beim Hoster gibt und er die Daten verliert ;)
    Würde nicht nur allein darauf vertrauen, auch wenn Raid und externe Backups - gab es alles schon :D

    Liebe Grüße,
    Lacelte

    Seelenschmerz-Forum
    Selbsthilfeforum für Betroffene und Angehörige psychischer Erkrankungen.


    Entziehe der Gruppe "Jeder" alle Rechte und du wirst nie Probleme mit den Benutzergruppen-Berechtigungen bekommen!

  • *seufz*
    wenn ich aber eine neue Datenbank anlege, sind alle vorhandenen Posts weg, wenn ich das so richtig verstehe, oder?
    Und genau das will ich ja eben nicht. Das sind knapp 155000 Beiträge :S
    Und selbst wenn, weiß ich nicht, wie man die auf die neue Datenbank rüberziehen müsste, wenn das denn ginge....


    wat ne driss ;(

  • Auch das haben wir schon versucht, mit folgendem Ergebnis:


    Serverfehler!







    Die Anfrage kann nicht beantwortet werden, da im Server
    ein interner Fehler aufgetreten ist.







    Fehlermeldung:


    Premature end of script headers: index.php







    Sofern Sie dies für eine Fehlfunktion des Servers halten,
    informieren Sie bitte den
    Webmaster
    hierüber.





    Error 500



    www.hp-ff.at



    Fri Oct 14 01:04:08 2011


    Apache/2.2.3 (Debian) mod_python/3.2.10 Python/2.4.4 PHP/5.2.11-0.dotdeb.0 with Suhosin-Patch mod_ssl/2.2.3 OpenSSL/0.9.8c
    </address>

  • Was sagt das Error-Log des Apaches?

    Liebe Grüße,
    Lacelte

    Seelenschmerz-Forum
    Selbsthilfeforum für Betroffene und Angehörige psychischer Erkrankungen.


    Entziehe der Gruppe "Jeder" alle Rechte und du wirst nie Probleme mit den Benutzergruppen-Berechtigungen bekommen!

  • Des was? ^^


    Sry, wenn das etwas auf dem webftp ist, muss ich an dieser Stelle passen, da meine Technikerin, die das pflegt, bereits in der Heia liegt ^^
    Hört sich doof an, ich weiß...
    :whistling: Ich sag ja: ich hab da nicht so die Ahnung

  • Es ist ja nicht mal klar, ob überhaupt das Loggen von Errors aktiviert ist.
    Außerdem ist es auch unterschiedlich, wie man an das Log heran kommt.


    Am besten ist es, ihr schreibt euren Support vom Hoster an und fragt einmal nach dem Error-Log vom Apache vom Fri Oct 14 01:04:08 2011 und generell ob er weiß, an was es liegen kann, das ihr die oben genannte Fehlermeldung erhaltet (Post 14)
    Das Updaten ist der einzige richtige und einfache Weg.


    Möglich ist es auch, das ihr das Forum KOMPLETT neu macht/installiert und dann per "Importer" alle Daten aus dem alten Forum übernehmt.
    Aber hier müsst ihr alle anderen individuelle Anpassungen wie PlugIns, Stile und extra Seiten neu erstellen - darum zu umständlich denke ich mir ;)

    Liebe Grüße,
    Lacelte

    Seelenschmerz-Forum
    Selbsthilfeforum für Betroffene und Angehörige psychischer Erkrankungen.


    Entziehe der Gruppe "Jeder" alle Rechte und du wirst nie Probleme mit den Benutzergruppen-Berechtigungen bekommen!

  • oki, also hoster anfragen...


    na, das ist nicht nur zu umständlich, wir müssten dafür auch ne neue datenbank anmieten, soweit ich das verstanden hab....*herzhaft seufz* ich bin begeistert *ironie off*


    okay, dann leier ich das mal an und meine technikerin kann sich das morgen dann mal alles durchlesen...denk, sie ist da der bessere ansprechpartner, muss der Kram halt während des Forenbetriebs erledigt werden.


    Ich danke bis hierhin für deine Geduld, Lacelte, und hoffe, deine Stirn ist nicht allzusehr in Mitleidenschaft geraten ob der bestimmt aufgekommen *Hand-vor-Stirn* ^^


    Bis demnächst in diesem Theater, wenn ich denn weitere Info habe *wink*

  • Alles klar, mal schauen ob er euch helfen kann.
    Ansonsten einfach hier melden - gibt ja schlaue Köpfe hier ;)


    Meine Stirn ist junge 23, die hält noch :D

    Liebe Grüße,
    Lacelte

    Seelenschmerz-Forum
    Selbsthilfeforum für Betroffene und Angehörige psychischer Erkrankungen.


    Entziehe der Gruppe "Jeder" alle Rechte und du wirst nie Probleme mit den Benutzergruppen-Berechtigungen bekommen!

  • Du hast das andere Thema auch nicht wirklich verstanden fürchte ich. Nur weil Du ne Lizens neu kaufst, mußt Du nicht neu installieren. Mache doch mal folgendes im bestehenden Forum: Die neuen Lizensdaten im ACP unter Paketverwaltung --> Server auflisten --> jeweiliger Server einfach die Daten der neuen Lizens eintragen. In der neuen Lizens hier im Mitgliederbereich trägst Du noch die URL zum Forum ein und alles sollte laufen.