Fehlermeldung ohne ersichtlichen Grund

  • Beim Aufrufen meines Boards bekomme ich folgende Fehlermeldung:



    Da niemand in den letzten tagen dort irgendetwas verändert hat, weiß ich nicht woran das liegt, und hoffe auf hilfe
    Dank im Voraus

  • Es wurde was verändert:
    Der Hoster hat PHP 5.3 installiert (das ist nämlich erst vor 4 Tagen erschienen)
    Anscheinend muss da das WBB noch leicht angepasst werden...


    Eigentlich ist das sehr vorbildlich vom Hoster!
    Andere wollen ja nichtmal von PHP 4 weg...


    Bei welchem Hoster bist du denn?
    Den muss ich mir nämlich mal für die Zukunft merken :D

    Hello, IT. Have you tried turning it off and on again?

  • Ist bei Bplaced...
    Nur löst das nicht mein Problem, was kann man tun ist die Frage?
    Und zudem taucht das problem bei allen anderen Foren die ich bei BPlaced laufen hab nicht auf

  • Scheint aber noch nicht auf allen Servern da umgestellt zu sein. Ich habe noch 5.2.8 ausgewiesen.

    Es gibt für alles eine Lösung, auch wenn einem die Antwort dazu nicht immer gefällt ;)

  • nun knifferkniffer, wenn ich beim wbb2 im Quellcode rumschreib, dann dürfte das nur dazu führen, das gar nix mehr angezeigt wird, nicht aber dazu das der Fehler behoben wird^^
    Also bitte eine verständliche anleitung

  • Sorry kenn mich da auch nicht aus, hab das ausm BPlaced Forum kopiert.


    http://forum.bplaced.net/viewtopic.php?f=5&t=10190


    Kansch dir ja ma durchgucken.


    hf^^

    • Official Post

    Blödsinn, ihr unterdrückt nur die Anzeige des Fehlers, der Fehler bleibt trotzdem bestehen. Das Forum ist so nicht oder nahezu nicht nutzbar, da es sich um einen schweren Fehler in der EventListener-Klasse des WCF handelt.

    • Official Post

    Nö, denn es macht keinen Sinn, das dort ein Fehler produziert wird. Bevor get_class() aufgerufen wird, erfolgt eine Überprüfung ob $eventObj überhaupt ein Objekt ist (und damit Instanz einer Klasse).


    Den Fehler mittels error_reporting nicht mehr anzeigen zu lassen ist mit so die schlechteste "Lösung" die vorstellbar ist. Das ist ungefähr so, als würdest du dir bei einem Sprung von einem Hochhaus ohne Sicherungsmaßnahmen einreden, dass dir nichts passieren kann.

  • Deswegen bitte ich ja darum mir zu sagen warum das im quellcode als objekt deklarierte $eventObj nicht als Objekt anerkannt wird, und wie ich das verändern kann, und warum das erst seit der einführung von php 5.3 auftritt

  • @dtdesign, ich wäre die dankbar, wenn du schon sagst, das ein Fehler im WCF vorliegt, dieses erst mal dann zu durchforsten.
    Die Verwendung von get_class ist im WCF so, wie es sein soll: if (is_oibject($eventObj) $ className = get_class($eventObj);
    Ich konnte also aktuell dort keinen Fehler finden.


    Was sein kann ist aber, dass eine alte WCF-Version da läuft, und es deswegen nicht geht!


    Ich schau nacher das WCF1.0 noch an wie es da aussieht, aber es wäre ungewöhnlich. Kannst du es mal bitte mit einem reihnen WBBLite 2 testen, ohne Plugins und ko?

    Hey, Designer: Ich will ein neues Design, aber nicht das was Ihr schon habt! Macht doch mit beim Design-Contest!

  • Und wie kann man das ganze jetzt wieder richten?
    Muss ich das Forum dazu auf einen anderen Server umsiedeln, oder gibt es einen einfacheren weg?

    • Official Post

    @dtdesign, ich wäre die dankbar, wenn du schon sagst, das ein Fehler im WCF vorliegt, dieses erst mal dann zu durchforsten.


    Ich habe mir die entsprechenden Zeilen angeschaut und dort finde ich nur ordnungsgemäße Prüfungen. Ich habe gerade noch einmal nachgeschaut, meine lokale Testinstallation verwendet bereits das WCF 1.0.11, ich kann mich aber nicht daran erinnern, es einem Update unterzogen zu haben *g*


    Der Verweis auf einen Fehler des WCF war die - meiner Ansicht nach - sinnvollste Aussage, da sonst alle brav die Anzeige von Fehlern unterdrücken und schon haben wir Tausende von mysteriösen Fehlern, die nur daraus resultieren das sie eben nicht angezeigt werden. Nenne es von mir aus Schadensbegrenzung ;)

  • Mhhh, einzige wäre, dass Forum neu zu installieren und zu importieren.
    Ich werde auch bescheid geben, dass das WBBLite 2 noch die aktuelleste WCF-Version bekommt.

    Hey, Designer: Ich will ein neues Design, aber nicht das was Ihr schon habt! Macht doch mit beim Design-Contest!

  • Hallo



    Ich habe exakt das selbe Problem wie DrakenKorin.


    Auch ich komme nicht mehr auf mein Forum rauf.



    Also wenn ich das richtig verstanden habe, bleibt mir jetzt nur noch die Möglichkeit, ein neues Forum bei einem anderen Hoster aufzuspielen und dann das alte Forum zu importieren. Aber geht das mit dem importieren überhaupt, wenn da solch ein fehler mit dem EventListener besteht?



    Gruß Paddy

  • hi,


    ich bin miro, der Chef/Admin von bplaced.


    Nun, in der Tat sieht es so aus, als ob in Eventhandler.class.php ein Übergebener Wert nur zu einem Objekt gecastet werden muss. Auf den ersten Blick sehe ich hier kein Problem damit, konkret geht es um diese Zeile


    Quote

    Fatal error: PHP warning in file /users/k12/www/wbb2/wcf/lib/system/event/EventHandler.class.php (73): get_class() expects parameter 1 to be object, string given


    if ((get_class($eventObj) == $parentClassName || is_subclass_of($eventObj, $parentClassName)) && isset($actions[$eventName]) && count($actions[$eventName]) > 0) {



    Hierbei sollte es reichen, bei get_class einfach nur den Wert durch folgendes auszutauschen:



    Code
    if ((get_class((Object)$eventObj) ....



    Was meinen die Entwickler zu dieser Änderung? Sie soll eigentlich nur temporär eine Lösung darstellen, bis ein offizieller Patch da ist.
    Dies wird hiermit auf bplaced automatisch ausgeführt - auf allen Servern, die aktuell auf PHP 5.3 migrieren.
    Sollte jemand gerade ein neues WBB installiert haben, das diese oder eine offizielle entsprechende Änderung noch nicht enthält, so reicht ein kurzer hinweis im bplaced-Forum in einem entsprechenden Thread, ich lasse die Änderung dann manuell für dieses eine Konto gerne wiederholen.



    ciao, miro
    bplaced.net

    • Official Post

    hi,


    ich bin miro, der Chef/Admin von bplaced.


    Hallo und herzlich willkommen bei uns im Forum! Nett, dass du selbst vorbeischaust! :thumbup:


    Was meinen die Entwickler zu dieser Änderung?


    In dieses Forum schauen die Entwickler so gut wie nie rein, weil wir nur der Vollversion WBB 3 Support bieten und nur in den dafür vorgesehenen Bereichen auch posten. Wir sind eine kleine Firma, daher fehlt neben dem Entwickeln die Zeit, auch noch in allen Forenbereichen mitzulesen oder gar zu schreiben, so müssen wir uns auf die Bereiche beschränken, die sich um die kostenpflichtige Software drehen.


    Wenn du mit den Entwicklern Kontakt wegen dieser Sache aufnehmen möchtest, dann wende dich bitte an die E-Mailadresse woltlab@woltab.com, der Zuständige wird sich dann bei dir melden! Wir sind immer froh, wenn wir konstruktive Rückmeldungen erhalten und natürlich noch glücklicher, wenn unsere Software auf möglichst vielen Servern gut läuft. :D


    Natürlich werde ich auch selbst auf dieses Thema hinweisen …


    Danke nochmal, dass du so nett warst selbst hier reinzuschauen. :)

  • hi,



    klar, ich will ja auch zufriedene Benutzer, die nicht mein Forum mit Fehlermeldungen zuposten.
    Ich meine schon, dass dies in einer nächsten Version korrigiert wird, meine "Lösung" ist ja nur ein Workaround.


    Generell füge ich diese Modifikation ja auf allen Servern automatisch durch, daher hielt sich das nur in Grenzen bzw. war anfangs nur so Aufsehen erregend, da mir der Fehler bis dahin eher unbekannt war. Erst als ich sah, dass da viele Betroffene sind und dass einige Testseiten mit diesem Problem auftraten, habe ich mich eben zu dieser Änderung entschlossen. Ein Patch wäre natürlich sehr erfreulich.




    ciao,
    miro