Time format: 24h instead of 12h

  • Ah I see, well is it possible to change for every language then? Only using english on my board but here in Sweden we're not going by their time format.


    regards

  • You can try that :
    On the admin page, go to "Design" -> "Languages" -> "List languages".


    Click English (if it's the language you use)


    Then, on language Category, choose "wcf.global"


    Look for the two strings : shortTimeFormat and timeFormat


    Make this changes :


    replace on shortTimeFormat

    Code
    M jS Y, g:ia

    by

    Code
    M jS Y, H:i


    replace on timeFormat

    Code
    l, F jS Y, g:ia

    by

    Code
    l, F jS Y, H:i


    Then tell me if it's working :)

  • Hi,


    What if the language is German? In English the time is displayed correctly. However, changing to German you start seeing (wcf.global.shortTimeFormat) in place of the date/time. I tried endless combinations of variables and all those some people mentioned in the forum. I don't really know what to do.

  • You should search for PHP date and time format for help, in some languages like mine, there was a bug about PHP, i am not sure it is handled by PHP guys.

  • You should search for PHP date and time format for help, in some languages like mine, there was a bug about PHP, i am not sure it is handled by PHP guys.


    mm, I'm a co-administrator who helps with the forum (not dodo1977) and don't have access to that for the moment. I was advised to clear the content of the following directories, * wcf/template/compiled/ and > * wcf/language/. Any suggestion on I could do that?

  • What do you mean by content? Content of forum or ftp directory?

    Yes, the file contained in the ftp directories. Today I gained access to the server and cleared the cache as suggested by tech support (I opened a ticket but being in different time zones we're at the speed of a post/reply a day. The idea was to clear language cache in order to eliminate some conflicts between the 3 languages in use. Unfortunately it didn't work. I also reinstalled the portal package, but browsing the forum in German I keep seeing variables instead of dates. In English all looks perfect. I even tried editing the various Timeformat and give different values, but still nothing. I have no idea. It may be due the fact that synchronizing the 3 languages in use created some conflicts in the variables (it all started there). I even reinstalled the language packages, which created other new issues that I already addressed and fixed, but it didn't resolve the timeformat error. I'm open to any suggestion.


    Would you be so kind to check if these settings are correct? I attached 3 screenshots with the variables for timeformat, as well as 1 pictures that shows the kind of error the forum displays.


    Thanks


    --------------------------- EDIT:


    [size=8]I was finally able to find what caused the issue. There was a spelling error in the Language category "wcf.global.shortTimeFormatLocalized" for the German informal, which had a "." in the middle of the string. I guess that happened during the language synchronization (the moment the problem first appeared). In addition, the "wcf.global.shortTimeFormatLocalized" for German standard language had an empty field--it wouldn't save the value upon submitting it and no value was ever registered. I deleted those variables in both German languages and re-created them; now it shows the time correctly (16.07.2013, 09:45). Do you happen to know the value I should use in order to add the day of the week to the date for the German time format?


    Thank you
    [/size]

    Edited 3 times, last by dodo1977 ().